Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Update could not be installed

  • 2 replies
  • 19 have this problem
  • 19 views
  • Last reply by butcher99

more options

When starting FF 3.68 using quick launch icon, I get this popup before the window loads. I have tried to follow the instructions in this page:

http://support.mozilla.com/en-US/kb/Software+Update+Failed?s=update+could+not+be+installed&as=s

and it still does the same thing.

All Replies (2)

more options

Try to run Firefox once as Administrator (right-click the desktop shortcut > Run as Administrator).

If that didn't work then do a clean reinstall and download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop.

Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.

It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

You can skip the step to create a new profile, that is not necessary for this issue.

See http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

more options

wrong answer. it is a problem in a setup file. Keep looking as I am.