X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

In the search bar google search engine missing (and others)

Posted

A number of search engines have gone missing. I guess I can add back the ones I've added in the past but Google is missing and I'm not sure how to add that back.

Chosen solution

Try restoring the default Search Engines by selecting "Manage Search Engines" in the dropdown next to the Search on the Address Bar and then clicking "Restore Defaults", This will attempt to restore the default Search Engines e.g. Google to the list. You should now be able to select Google as a Search Engine, although this may remove ones you have added previously.

Read this answer in context 20

Additional System Details

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • np-mswmp
  • 1.9.0042.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • iTunes Detector Plug-in
  • GEPlugin
  • 4.0.50524.0
  • Office Live Update v1.5
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0E)

More Information

MDavies 1 solutions 2 answers

Chosen Solution

Try restoring the default Search Engines by selecting "Manage Search Engines" in the dropdown next to the Search on the Address Bar and then clicking "Restore Defaults", This will attempt to restore the default Search Engines e.g. Google to the list. You should now be able to select Google as a Search Engine, although this may remove ones you have added previously.

Question owner

That's fab, many thanks.

Ajax4Hire 0 solutions 1 answers

Helpful Reply

After I upgrade to Firefox, the "Restore Defaults" is not available. Might as well as said click the selection that is not available to do the thing that you want.

Really irritating that Yahoo has confiscated my search bar and completely kicked out Google. This is the first time that Mozilla has really irritated me enough to switch to Chrome.

Bye.

MDavies 1 solutions 2 answers

@Ajax4Hire, the "Restore Defaults" option is available in the current stable version of Firefox (3.6.10). If it appears disabled e.g. Greyed Out, simply delete an existing Search Engine entry from the list and it should become active. The option can be found by following my previous instructions. If the Search Box has been removed from the interface you can add it again by firstly right-clicking on a toolbar and selecting “Customise” then dragging the Search Component onto the toolbar.

lascott7 0 solutions 5 answers

Man, I have tried that I do not have anything under 'Manage Search Engines" even though the 'set default' option is greyed out. What in the world has caused this??? I really need help. I even tried going to the firefox add ons just to add them and still doesn't do any good :( I need steps asap!

RobbinOfPhoenix 0 solutions 2 answers

I sure hope someone offers a solution to this soon. I'm having the same identical problem and have tried all of the solutions so far including the (Safe Mode) resets. No success. Can't add 'em, can't Manage 'em, They won't install and you can't Manage Blanks. This seems to be a condition of 3.6.10

RobbinOfPhoenix 0 solutions 2 answers

That button is "greyed" out. Unavailable.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You can try to delete search.sqlite and search.json in the Firefox Profile Folder

See also http://kb.mozillazine.org/Unable_to_search_or_add_new_engines

rpr.nospam 0 solutions 6 answers

Helpful Reply

I encountered this problem on Ubuntu 10.10 (amd64) after upgrade to FF 3.6.15. The user uses the en-GB locales.

Creating a new profile in FF did not solve the problem.

After a little bit of investigation I've found out that it can be fixed by copying all files from /usr/lib/firefox-addons/searchplugins/en-US/ to /usr/lib/firefox-addons/searchplugins/en-GB/ and restarting Firefox. Here is the command:

sudo cp /usr/lib/firefox-addons/searchplugins/en-US/* /usr/lib/firefox-addons/searchplugins/en-GB/

-- rpr.

Echo 0 solutions 1 answers

Here is my best option for you! First, because I had the exact problem as yours.

Fist of all, backup your bookmarks so you won't have the desire to cut my head off. Then once you done that, try to install CCleaner if you do not have it already.

Open it, and then look at the left panel and click on "Tools". Now, select Firefox and on your right press "Run uninstaller".

After you done that, look at your left again and press on "Registery" then at the bottom of the window, press on "Scan for issues".

Obviously, there will have some issues founds. Once the scan is completed, click on "Fix selected issues...". Once you done that, start a second scan just in case, to be sure there is nothing left.

Then, re-download Firefox and it should be restored.

firefoxfan123 0 solutions 1 answers

i tried to do that but google search not apear

1971hemicuda 0 solutions 1 answers

I was able to get this resolved...the problem is you are probably missing all the .xml search engines from within /usr/lib/firefox/searchplugins (or where ever your distro puts firefox)

I downloaded the latest firefox, extract the tarball, and copied over the .xml files from within the search plugins directory...aaaaand magic happened! restart firefox (make sure you have 0644 perm's on the files) and you should be good to go

Ahmad Robin 0 solutions 1 answers

I faced the same problem yesterday. I had no option under "manage search engine" menu. Then I install older version (3.6.0) of fire fox and again install the fire fox 10. Now all the search engine are here. Hope it would work for you too....:)