X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot open more than one window with Firefox

Posted

I've been having this problem for a couple of weeks, now, and I've run out of ways to try and fix this.

One day, after starting my computer up, I opened Firefox. No big deal, everything looks fine, tabs are working, etc. Then, when I went to open a second window, nothing. The first window still works fine, I can open tab upon tab, but it just won't open any more windows.

As much as I'm a fan of the browser tabs, I still prefer to have them spread out over more than one window.

I've read through a ton of different troubleshooting walkthroughs and whatnot, reinstalled three or four times, restored settings, but nothing works.

Well, not entirely, I guess. Here's the part that I can't quite figure out. When I disable every single addon, Firefox works just fine. I've done the checking down the list, trying to single one out, but it's *any* addon. Even something as simple as a dictionary search (https://addons.mozilla.org/en-US/fire.../68/) causes this to happen.

I've checked with an older computer with an older version of Firefox, and it still seems to work fine with addons enabled, so I'm wondering if this is an update issue?

Would reverting back to a previous version of Firefox solve this, and if so, where would I be able to find downloads for a previous version?

So, like I said, I'm at a bit of a loss here. Sort of at a crossroads for trying to figure out what to try next, so I'm hoping someone a bit more knowledgeable can help steer me in a direction.

Edit: I just noticed that the posting includes system information with my question. I should clarify that I'm posting this from an older computer with an older version of Firefox. On the computer that I'm having this issue with, I'm using the newest version of Firefox (3.6.8).

Modified by Newt234

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • Default Plug-in
  • Java(TM) Platform SE binary
  • DivX® Web Player
  • Office Plugin for Netscape Navigator
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • 1.5.0723.1
  • Mozilla ActiveX control and plugin module
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1465
  • Adobe ESD Version Manager 2.0
  • Shockwave Flash 10.0 r32
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • DivX® Content Upload Plugin
  • 2.0.40115.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Yahoo! activeX Plug-in Bridge
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13 (.NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.
You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Helper7677 165 solutions 1653 answers

Helpful Reply

Some old posts indicate the following add-ons have caused the problem of not being able to open a new window in Firefox in the past. If you have any of them you might want to disable or uninstall them to see if that is causing your problem.



You need to update your plug-ins. It is important to keep them updated due to continuing security fixes and improvements in those plug-ins:

  • Adobe Shockwave for Director Netscape plug-in, version 11.5 (you may need to update)
  • Shockwave Flash 10.0 r32
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Shockwave Flash
  4. Update Java:


You are using an out-of-date version of Firefox. Unless you have a reason for using that old version, you might want to consider upgrading.

  • The Firefox version series 3.0.x is no longer being supported or updated, even for security issues.
  • The last version in the 3.0.x series was 3.0.19 which was released 03/15/2010.
  • You are using version 3.0.13 which was released 07/31/2009.

Consider upgrading to the current version, Firefox 3.6.8. Firefox 3.6.9 is scheduled to be released in a few days and the new Firefox 4 will be released later this year or early next year.

Question owner

Done and done.

I've taken those steps a few times, and as I said, it's not that there's any one specific addon that's causing it. It's the fact that *any* addons are enabled. I can disable everything, and then enable the simplest of addons, like the Dictionary search that I highlighted in my original post, and this begins to occur.

If this is a known issue with the latest version, I can accept that, but I would imagine I'd see more people with this issue.

Edit: Just saw the second reply after submitting this one.

Problematic addons: Not using any

Plugins Updated: Done

Old version: As I said, the computer I'm having this issue on is using 3.6.8, the most current version available.

Modified by Newt234

Mike Field-Dodgson 0 solutions 6 answers

This is Mid Feb 2012. I have just upgraded to version 10 :-(

Some log ins on sites I use won't work.

Can't open more than one application of Firefox at a time.

Small issues but frustrating - I wish I hadn't up graded.

Exactly the same thing happened last time so I went back to the old version.

Have had to use Explorer to use log in sites, and this seem to load a cookie etc., that stops Firefox working properly so I have to go and empty my cache blah blah blah

Modified by Mike Field-Dodgson