X
Tap here to go to the mobile version of the site.

Support Forum

Firefox hangs for several minutes at startup

Posted

When ever I start up Firefox it consistently takes a few minutes to start up.

It also appears to be slowing down my system in general also.

This has been happening since upgrading to ver 3.4 and has continued with every subsequent update.

When ever I start up Firefox it consistently takes a few minutes to start up. It also appears to be slowing down my system in general also. This has been happening since upgrading to ver 3.4 and has continued with every subsequent update.

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • http://www.facebook.com/fbplugin/
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.50524.0
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

qingbo 0 solutions 2 answers

I suffered the same problem but it disappeared now. Possible reason here. Anyone has the same situation? Please give me some feedback if it's correct.

I suffered the same problem but it disappeared now. Possible reason [http://thinlight.org/2011/03/10/mac-firefox-hangs-on-startup-possible-solution/ here]. Anyone has the same situation? Please give me some feedback if it's correct.
Selfie 0 solutions 1 answers

I have the same issue but I have not found a solution yet. I have problems with version 3.4 and up like mentionned. I am using Mac OS X 10.6.7

I have the same issue but I have not found a solution yet. I have problems with version 3.4 and up like mentionned. I am using Mac OS X 10.6.7
Randy Davis 0 solutions 4 answers

Have you tried starting in safe mode? This article will explain how to do it:

http://support.mozilla.com/en-US/kb/Safe+Mode

If it starts up fine in safe mode, there may be an extension that you have loaded that is behaving badly.

Have you tried starting in safe mode? This article will explain how to do it: http://support.mozilla.com/en-US/kb/Safe+Mode If it starts up fine in safe mode, there may be an extension that you have loaded that is behaving badly.

Question owner

I've tried starting in Safe Mode and it takes even longer to start.

My system is definitely affected when starting Firefox (NeoOffice, QuarkXPress, InDesign and others respond much slower during Firefox starting up).

I'm now using Firefox 4.0.1 and the problem still persists. I've tried a clean install of Firefox rather than updating also but without any change.

I've tried starting in Safe Mode and it takes even longer to start. My system is definitely affected when starting Firefox (NeoOffice, QuarkXPress, InDesign and others respond much slower during Firefox starting up). I'm now using Firefox 4.0.1 and the problem still persists. I've tried a clean install of Firefox rather than updating also but without any change.