Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

characters in Korean language broken

  • 7 replies
  • 85 have this problem
  • 106 views
  • Last reply by cor-el

more options

Certain web sites in Korean are showing broken characters as below URL. Other certain sites are happening the same. Korean added in the option. And the system is based on Win 7 English version with Korean language selected in Control panel/Language. Other Korean sites are showing without problems.

Certain web sites in Korean are showing broken characters as below URL. Other certain sites are happening the same. Korean added in the option. And the system is based on Win 7 English version with Korean language selected in Control panel/Language. Other Korean sites are showing without problems.

Modified by ks.choi@grace.com

Chosen solution

Firefox seems to have a problem to detect the encoding and uses ISO-8859-1 instead of EUC_KR that is send: Content-Type: text/html; charset=EUC_KR


You can try View > Character Encoding > Auto-Detect > Universal , that works for me.

Read this answer in context 👍 3

All Replies (7)

more options

Your post does not include the problematic URL. Could you please include it?

more options
more options

Hello, Anybody answers my problem? I've tested in Firefox 4.0 Beta 3 but it's still happening. It would be strong stopper for Korean to use Firefox as an alternative of IE. In Korea IE occupies over 90% of browser market share but because the policy and government is driving Web compatibility Users are seeking alternatives. So unless this language broken issue is solved Firefox could loose the market.

more options

Below is a sample. I don't know why the sample image is not attached.

Modified by ks.choi@grace.com

more options

Chosen Solution

Firefox seems to have a problem to detect the encoding and uses ISO-8859-1 instead of EUC_KR that is send: Content-Type: text/html; charset=EUC_KR


You can try View > Character Encoding > Auto-Detect > Universal , that works for me.

Modified by cor-el

more options

Yes, it works. I can see the contents correctly. But a problem is the problem. Thank you very much, cor-el.

more options

You're welcome