Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need Firefox 3.0 for school website, I need to downgrade

more options

Everest Online only supports Firefox 2.0 & 3.0, I need to go back from 3.6 how do I do it?

URL of affected sites

http://www.onlinecci.com

User Agent

Opera/9.80 (Windows NT 6.0; U; en) Presto/2.6.30 Version/10.60

All Replies (2)

more options

My advice is to install the Firefox Portable version that you need on your computer, and use that installation only for Blackboard. Continue to use 3.6.x for all other web browsing. The Portable version won't affect the official version at all. FP 3.0.x is here: http://portableapps.com/apps/internet/firefox_portable/localization#legacy FP 2.0.0.20 is here: Firefox, P.E. Legacy/Firefox_Portable_2.0.0.20_en-us.paf.exe

more options

This page shows that Firefox 3.5 is supported as well: http://onlinecci.com/index.learn?action=Technical

Supported versions:(Mozilla Firefox) * Mozilla Firefox 2.0 * Mozilla Firefox 3.5

So try the portable Firefox 3.5 version. See "Legacy Versions" http://portableapps.com/apps/internet/browsers/portable_firefox