X
Tap here to go to the mobile version of the site.

Support Forum

Everytime firefox opens, it has all my old tabs saved. How do I turn this off?

Posted

I accidentally clicked "Don't ask again" when I had the final dialogue box open before closing FF which asks "Do you want to Save and Quit, Quit, or Cancel?" and I clicked Save and Quit. Now, every time I open FF, it has all my old tabs open. How can I stop this from happening? I've looked in Tools > Options but I can't see anything there.

I accidentally clicked "Don't ask again" when I had the final dialogue box open before closing FF which asks "Do you want to Save and Quit, Quit, or Cancel?" and I clicked Save and Quit. Now, every time I open FF, it has all my old tabs open. How can I stop this from happening? I've looked in Tools > Options but I can't see anything there.

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16263
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iPrint Plug-in 1.0.0 - Provides iPrint client services for Windows
  • Java Plug-in 1.5.0_10 for Netscape Navigator (DLL Helper)
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Firefox Version 3.63

cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158475 answers

That happens if you have this setting: Tools > Options > General|Main > Startup: "When Firefox Starts": "Show my windows and tabs from last time"

Choose one of the other settings: Tools > Options > General|Main > Startup: "When Firefox Starts": "Show my home page" "Show a blank page"

That happens if you have this setting: Tools > Options > General|Main > Startup: "When Firefox Starts": "Show my windows and tabs from last time" Choose one of the other settings: Tools > Options > General|Main > Startup: "When Firefox Starts": "Show my home page" "Show a blank page"
mikeb 0 solutions 1 answers

If you select "Show my home page", then also check the contents of "Home page" (same settings tab as above). If it contains multiple URLs, all those URLs will be opened each time. This drove me nuts for a while, as I had bookmarked all open tabs and used them as my "Home page", so kept getting an old news story on the news website I was using.

If you select "Show my home page", then also check the contents of "Home page" (same settings tab as above). If it contains multiple URLs, all those URLs will be opened each time. This drove me nuts for a while, as I had bookmarked all open tabs and used them as my "Home page", so kept getting an old news story on the news website I was using.