X
Tap here to go to the mobile version of the site.

Support Forum

How do I configure Firefox 4 Beta to use the Adobe flashplayer 10.x plugin?

Posted

I'm using FireFox 4 Beta 1 on openSUSE 11.1 (x86_64). I created a ~/bin/firefox/plugins/ and ~/bin/plugins I copied the latest the libflashplayer.so there and also to /usr/lib/browser-plugins/

Since adding plugins and folders I get black flashplayer screens

This happened

Every time Firefox opened

== Prior to moving plugins Flashplayer crashed, blank flashback screen, no video after plugin directories and moves

I'm using FireFox 4 Beta 1 on openSUSE 11.1 (x86_64). I created a ~/bin/firefox/plugins/ and ~/bin/plugins I copied the latest the libflashplayer.so there and also to /usr/lib/browser-plugins/ Since adding plugins and folders I get black flashplayer screens == This happened == Every time Firefox opened == Prior to moving plugins Flashplayer crashed, blank flashback screen, no video after plugin directories and moves

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.1 r53
  • The next generation Java plug-in for Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

More Information

AdblockPlus 1.2.1, Download helper 4.8, Download Status Bar 0.9.7, Feedback 1.0.rc1, Flashgot 1.2.12.8, NoScript 1.10, UnPlug 2.026

charlieman 0 solutions 2 answers

Helpful Reply

I'm also having this problem.

I have Firefox 4 beta installed in ~/.local/opt/firefox and I've tried placing the libflashplayer.so file (which works fine on Firefox 3.5 and other browsers) in the following places with no luck:

  • ~/.mozilla/plugins/
  • ~/.local/opt/firefox/
  • ~/.local/opt/firefox/plugins/
  • /usr/lib/firefox/plugins/
I'm also having this problem. I have Firefox 4 beta installed in ~/.local/opt/firefox and I've tried placing the libflashplayer.so file (which works fine on Firefox 3.5 and other browsers) in the following places with no luck: * ~/.mozilla/plugins/ * ~/.local/opt/firefox/ * ~/.local/opt/firefox/plugins/ * /usr/lib/firefox/plugins/

Modified by charlieman

cor-el
  • Top 10 Contributor
  • Moderator
17681 solutions 159964 answers

Firefox 4.0 b1 is a very old and outdated version.

You should update to the latest beta version: http://www.mozilla.com/firefox/all-beta.html

You can try to delete the file pluginreg.dat and let Firefox rebuild a new version.

See http://kb.mozillazine.org/Issues_related_to_plugins

Firefox 4.0 b1 is a very old and outdated version.<br /> You should update to the latest beta version: http://www.mozilla.com/firefox/all-beta.html You can try to delete the file pluginreg.dat and let Firefox rebuild a new version.<br /> See http://kb.mozillazine.org/Issues_related_to_plugins