X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why isn't iframe working in Firefox?

Posted

iframe does not work in firefox. I can't click anything inside the iframe, i can't scroll, i can't do anything with it. But in other browsers it works just fine.

This happened

Every time Firefox opened

== When I last tried it

Additional System Details

Installed Plug-ins

  • -Office Plugin for Netscape Navigator
  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • getplusplusadobe16244
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.0 r32
  • 4.0.50524.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java Plug-in 1.6.0_05 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; pt-PT; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)

More Information

Morbus 134 solutions 2338 answers

Hello Gonçalo.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem is not disappears when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

Question owner

I have the same problem and it is still coming after disabling all addons

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96968 answers

Does it happen with all iframes or only on specific web pages? Can you post a link if it is the latter?

tandybar 0 solutions 1 answers

I had the same problem with an iframe not displaying php content, till I added a '?' to the end of the filename. (src="file.php?")

David Favor 0 solutions 4 answers

This problem seems to relate to surround HTML.

Simple iframe code works.

Complex iframe code fails.

First example is just an iframe in a div.

Second example is an iframe embedded within Wordpress + Thesis.

Second site uses a modified DTD to validate code.

Switching DTDs has no effect. The iframe fails to render in the second case.

Second case works in webkit browsers and fails in Firefox. Addons toggling seems to make no difference.

David Favor 0 solutions 4 answers

Flarg... Was Ad Blocker Plus blocking the Amazon iframe.

shmish 0 solutions 1 answers

I'm having this problem. I have an embedded google doc in an iframe. I create a simple html file with the iframe and it doesn't show in firefox on my laptop. If I open the file in ie or chrome it works. As well, if I open the file on a different PC the file does open in firefox.

I had disabled all of the plugins in firefox on the laptop and this didn't make any difference. firefox v7.01

Bill 1 solutions 4 answers

I have an iframe inside another iframe. The second iframe shows the HTML source instead of its contents (a Google graph). This has worked in Firefox previous to today (I am now at 8.0), It works find with other browsers, and in Firefox if I do not nest the iframes.

Modified by Bill

raavimohanty 0 solutions 1 answers

Well I heard it always that iframe is not getting loaded... Hope you can try this solution. In the iframe tag if you are calling the source directly, then it won't work. Just use the full url of the src.

Ex. <iframe name="InlineFrame1" id="InlineFrame1" style="position:absolute;width:550px;height:420px;" src="http://www.yourdomain.com/file.html" scrolling="no" frameborder="0">Your browser does not support inline frames or is currently configured not to display inline frames.</iframe>

Don't write src="filename.html"

Thanks,

Raavi Mohanty

download23 0 solutions 1 answers

I had the Disconnect add-on enabled and this caused problems with iframes coming from Google. After disabling it (and restarting) they work for me!

D. Tripodes 0 solutions 2 answers

Firefox 3.x, 4.x, 5.x all the way to 8.x and now 9.01 won't display iFrame on Windows XP. Firefox 9.01 on a new Windows 7 does display iFrame.

Has anyone found a work-around to get this displaying, versus saying disable add-ons?

Sample iFrame -

<iframe src="http://www.facebook.com/plugins/likebox.php?id=99999999999&width=480&connections=16&stream=false&header=false&height=300" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:480px; height:300px;" allowTransparency="true"></iframe>

where "99999999999" is any Facebook fan page.

Thanks-

Modified by D. Tripodes

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96968 answers

Does it work in Save mode?

  • Help > Restart with Add-ons Disabled

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
craigru 0 solutions 1 answers

I’m using a 3-part frameset, with a header and 2 columns for iframes that load pairs of related content-pages. On my Mac, everything (basic heights, widths, and links, plus javascript to swap images or load 2 iframes with 1 link) works perfectly with Safari & Chrome, and almost all with Firefox. But both Opera and Firefox (with no add-ons) show my iframed pages in a short window, using only about 25% of the available vertical window-space. I’ve tried MANY fixes suggested online (using html, css, and/or javascript) but nothing works. Why do Safari & Chrome show iframe-heights properly, but not Firefox? Or, what can I do to make it work? CraigRu

D. Tripodes 0 solutions 2 answers

Thanks cor-el,

Help > Restart with Add-ons Disabled did get iFrame working again - both for Facebook fan pages as well as embedded Google calendars that also use iFrame.

Raphael 0 solutions 1 answers

I have a similar problem on a simple site of mine. It is valid XHTML 1.0 Transitional. While a source site is shown, the default text is not shown when no source is provided.

I run Firefox 10.0 on Ubuntu with kernel 2.6.35-31-generic. The problem persists when all addons are disabled.

Modified by Raphael

the-edmeister
  • Top 10 Contributor
  • Moderator
3201 solutions 24439 answers

Now you need to figure out which add-on is causing that problem.

Start with this section of this support page, and work your way down.
https://support.mozilla.org/en-US/kb/Troubleshooting-extensions-themes#w_turn-off-hardware-acceleration

hyside2 0 solutions 1 answers

I had the same problem. My iFrames worked in IE and Chrome but not Firefox. Changed the slashes from slash to back slash and all is now working. This one did not work in FF <IFRAME src="\myride\TheRider\index.html" width="640" height="640" frameborder="no"></IFRAME>

This one works great! <IFRAME src="/myride/TheRider/index.html" width="640" height="640" frameborder="no"></IFRAME>

cornelius123 0 solutions 1 answers

Problem not solved with addons and plugins off. When browsing in private mode the Iframes are visable!

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96968 answers

Helpful Reply

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"