Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 31 can not get value from child iframe in parent website

  • 13 replies
  • 10 have this problem
  • 212 views
  • Last reply by fkapnist

more options

Firefox 31 can not get value from child iframe in parent website.

In all previous Firefox versions, I could get a field value from an iframe within my own website. But now I can't.

All other browsers: Explorer, Chrome, and Opera work just fine. Firefox stopped working as of version 31.

All Replies (13)

more options

Please try Diagnose Firefox issues using Troubleshoot Mode Please make sure there are no add ons blocking the content

Please try to allow insecure content: To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

Last resort: I wonder if this has to do with the single origin policy. There was a new security https://blog.mozilla.org/security/201.../exciting-updates-to-certificate-verification-in-gecko/ update for certificate verification.


Please post back with your results/ or an example url for further investigation. Thank you.

Modified by guigs

more options

Could you post a link to a page demonstrating this problem, either the actual page, or a reduced test case?

more options

Yes I have made two pages to demonstrate the problem....

1.

If you go to http://os.verticalbrowser.com/index.htm


and click on the blue "Play AutoSurf" button it will automatically rotate some links....


2.

But if you go to http://os.verticalbrowser.com/indexOLD.htm

the blue button does nothing... it no longer responds to my iframe......

(I put some browser sniffing code in the first example to switch to another page that works because it is a less complicated iframe but has less features.....)


Thanks,

more options

Yes I have made two pages to demonstrate the problem....

1.

If you go to http://os.verticalbrowser.com/index.htm


and click on the blue "Play AutoSurf" button it will automatically rotate some links....

2.

But if you go to http://os.verticalbrowser.com/indexOLD.htm

the blue button does nothing... it no longer responds to my iframe......

(I put some browser sniffing code in the first example to switch to another page that works because it is a less complicated iframe but has less features.....)


Thanks,

more options

This is little complicated for a Sunday afternoon peek...

The script on the "Play AutoSurf" button runs doPlay(). Here is the first problem:

thetitle=surfframe.document.Auto12Surf.slotTitle.value;

Experimenting in the web console:

surfframe.document.Auto12Surf.slotTitle.value
=> TypeError: surfframe.document is undefined
surfframe.nodeName
=> "IFRAME"
surfframe.contentDocument.Auto12Surf.slotTitle.value
=> "AutoSurf Play List"

Do all browsers support contentDocument now? If not, or to minimize your code changes, you could try putting the following somewhere in your code that runs on load (i.e., global context):

if (!surfframe.document) surfframe.document = surfframe.contentDocument;

Does that fix it?

more options

changing .document to .contentDocument in the code got it to partially work with Firefox 31 (it still freezes later on) but all previous versions of Firefox don't work now...

more options

It is an iframe within a DIV....... I could access it in all previous versions of Firefox, but now it just hangs....

more options

It is an iframe within a DIV....... I could access it in all previous versions of Firefox, but now it just hangs.... I have made two pages to demonstrate the problem....

1.

If you go to http://os.verticalbrowser.com/index.htm


and click on the blue "Play AutoSurf" button it will automatically rotate some links....

2.

But if you go to http://os.verticalbrowser.com/indexOLD.htm

the blue button does nothing... it no longer responds to my iframe......

(I put some browser sniffing code in the first example to switch to another page that works because it is a less complicated iframe but has less features.....)


Thanks,

more options

Could you test in Firefox 32 and see whether the problem continues?

more options

I tried it in version 32.... the same problem continues.... It cannot access data from an iframe in a DIV..... I think Firefox is slowly turning into another Chrome browser.... Chrome is a fast ad-delivery platform (that is its first priority, to protect AdSense code from hackers).... too bad...

more options

Now the old version does this: I click on the blue button, get a pop up that asks to start browsing. I am taken to another page with a grey button to auto surf. I clicked that and was back to the first page. Then clicking the blue button a second time the auto surfing started. (news about shelling the Ukraine was the first page) Is this intentional?

more options

Any version older than Firefox 31 should bring you here: http://os.verticalbrowser.com

I put a browser sniffer in the code... the new version now automatically takes you to the Chrome (webkit) platform: http://wk.verticalbrowser.com

try it with Explorer or Opera to see the difference.....

more options

when you go to the OLD.htm page, you are at this address: http://os.verticalbrowser.com

But when you clicked on the blue button a second time, you were brought to a new page: http://wk.verticalbrowser.com

I made a simplified Chrome or Webkit version (wk) of the same site, but now it seems that Firefox has also changed its innards to act like Chrome..