X
Tap here to go to the mobile version of the site.

Support Forum

My Firefox spellchecker doesn't seem to be working; in fact I'm not sure it exists. I have a hotmail account and when I try and use the hotmail spellcheck I get a message to say that I'm using a browser with a built-in spellcheck. Where on earth do I find

Posted

My firefox spellcheck doesn't seem to be working; that's assuming it exists at all.For example when I misspell a word when composing an email, using hotmail and I try to correct it using hotmail's spellcheck, I get a message saying that I'm using a browser that has it's own inbuilt spellcheck. If it's inbuilt how on earth do I find it?

This happened

Every time Firefox opened

== As far as I'm aware, always

My firefox spellcheck doesn't seem to be working; that's assuming it exists at all.For example when I misspell a word when composing an email, using hotmail and I try to correct it using hotmail's spellcheck, I get a message saying that I'm using a browser that has it's own inbuilt spellcheck. If it's inbuilt how on earth do I find it? == This happened == Every time Firefox opened == As far as I'm aware, always

Chosen solution

You need to install a spell check dictionary, only the en-US version comes with a dictionary. https://addons.mozilla.org/en-US/firefox/language-tools/

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • 6.0.12.46
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • getplusadobe15235
  • Firefox Proxy component for eMail ID
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

More Information

Adblock Plus 1.2.1
Blinkx Toolbar 1.0
DownloadHelper 4.7.4
Iconix 3.90.1
Java Console 6.0.20
Java Quick Starter 1.0
McAfee SiteAdvisor 3.1
Search Cloudlet 0.7.4.75
Subtile 1.3

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40290 answers

Chosen Solution

You need to install a spell check dictionary, only the en-US version comes with a dictionary. https://addons.mozilla.org/en-US/firefox/language-tools/

You need to install a spell check dictionary, only the en-US version comes with a dictionary. https://addons.mozilla.org/en-US/firefox/language-tools/

Question owner

Unfortunately when I tried to install the suggested add-on, Firefox prevented this with a warning about only downloading from sources you trust etc etc.

Unfortunately when I tried to install the suggested add-on, Firefox prevented this with a warning about only downloading from sources you trust etc etc.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40290 answers

Helpful Reply

That's just the standard notice when you install an addon from the AMO web site.

Wasn't the Install Now button active? Sometimes you have to wait for up to 4 seconds for that button to be active - IOW, not greyed-out.

That's just the standard notice when you install an addon from the AMO web site. Wasn't the '''Install Now''' button active? Sometimes you have to wait for up to 4 seconds for that button to be active - IOW, not greyed-out.

Question owner

Thanks ed-meister. I followed your advice and the spellcheck is now installed and working just fine. Kind regards,

                                          Geoff
Thanks ed-meister. I followed your advice and the spellcheck is now installed and working just fine. Kind regards, Geoff
klonos 0 solutions 1 answers

in latest 4.0b4pre, when I installed and enabled the English - Greek Spelling dictionary https://addons.mozilla.org/en-US/fire.../3451/ I've noticed that the default spell-checking option was disabled in the right-click menu on text areas. Enabling it in one text box doesn't enable it by default.

My settings in about:config are:

extensions.spellcheck.inline.max-misspellings 500

layout.spellcheckDefault 1 (Enable spellchecker for multi-line controls according to http://kb.mozillazine.org/Spellchecker.dictionary)

spellchecker.dictionary en-US (the English - Greek is defined as such)

Is this a known bug in 4.x?

in latest 4.0b4pre, when I installed and enabled the English - Greek Spelling dictionary [https://addons.mozilla.org/en-US/firefox/addon/3451/] I've noticed that the default spell-checking option was disabled in the right-click menu on text areas. Enabling it in one text box doesn't enable it by default. My settings in about:config are: extensions.spellcheck.inline.max-misspellings 500 layout.spellcheckDefault 1 (Enable spellchecker for multi-line controls according to http://kb.mozillazine.org/Spellchecker.dictionary) spellchecker.dictionary en-US (the English - Greek is defined as such) Is this a known bug in 4.x?
jobo 0 solutions 1 answers

excellent thanks for posting this solution.

excellent thanks for posting this solution.