X
Tap here to go to the mobile version of the site.

Support Forum

why did firefox disable the IDM cc on its add on? many people now are complaining about this since they use their firefox as main browser. based on my observation, 5 out of 10 users are now switching to google chrome due to this predicament. i hope you wo

Posted

why did firefox disable the IDM cc on its add on? many people now are complaining about this since they use their firefox as main browser. based on my observation, 5 out of 10 users are now switching to google chrome due to this predicament. i hope you would give an action regarding this matter..

This happened

Just once or twice

== today with me

why did firefox disable the IDM cc on its add on? many people now are complaining about this since they use their firefox as main browser. based on my observation, 5 out of 10 users are now switching to google chrome due to this predicament. i hope you would give an action regarding this matter.. == This happened == Just once or twice == today with me

Additional System Details

Installed Plug-ins

  • -nphpclipbook
  • np-mswmp
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape
  • Google Update
  • Shockwave Flash 10.0 r32
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Yahoo Application State Plugin version 1.0.0.7
  • Next Generation Java Plug-in 1.6.0_15 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10

More Information

IDM cc

Question owner

it works great i don't know why firefox disabled it

Please enable it.

it works great i don't know why firefox disabled it Please enable it.

Question owner

Situation/Fix-

The block was in error, and should have only applied to beta versions of Firefox 4.0 due to the large number of crashes it caused on that version. However, a programming error resulted in the extension being blocked on all Firefox versions.

The change has already been rolled back according to Bug 578433 listed here.

https://bugzilla.mozilla.org/show_bug.cgi?id=578443

However, browsers that have already blocked the extension may not immediately register the change. All Firefox browsers connected to the internet should have unblocked the extension within 24 hours, to my understanding.

"I need a fix for this right away though!"

First, restart your browser and see if the block persists.

Those in desperate need of the extension may wish to disable the extension blocklist functionality in Firefox, which should re-enable the extension (according to reports unconfirmed by me).

Instructions on how to do that are provided here.

http://support.mozilla.com/en-US/kb/Firefox+makes+unrequested+connections#Extension_blocklist_updating

I would personally encourage re-enabling the extension blocklist in a day or two, as it normally provides a valuable defense against the possibility of dangerous extensions being run.

Situation/Fix- The block was in error, and should have only applied to beta versions of Firefox 4.0 due to the large number of crashes it caused on that version. However, a programming error resulted in the extension being blocked on all Firefox versions. The change has already been rolled back according to Bug 578433 listed here. https://bugzilla.mozilla.org/show_bug.cgi?id=578443 However, browsers that have already blocked the extension may not immediately register the change. All Firefox browsers connected to the internet should have unblocked the extension within 24 hours, to my understanding. "I need a fix for this right away though!" First, restart your browser and see if the block persists. Those in desperate need of the extension may wish to disable the extension blocklist functionality in Firefox, which should re-enable the extension (according to reports unconfirmed by me). Instructions on how to do that are provided here. http://support.mozilla.com/en-US/kb/Firefox+makes+unrequested+connections#Extension_blocklist_updating I would personally encourage re-enabling the extension blocklist in a day or two, as it normally provides a valuable defense against the possibility of dangerous extensions being run.

Question owner

oh **** wats happening this!!!!

oh **** wats happening this!!!!

Question owner

Disable extensions blocklist - see above post!!

It's been over 24 hours and restarting Firefox did not enable the IDM cc add on. I used instructions at link posted above to disable the extensions blocklist by setting it to false.

Thank you!! IDM is back in business. I will reset this to true in about:config in a day or two and see what happens.

Disable extensions blocklist - see above post!! It's been over 24 hours and restarting Firefox did not enable the IDM cc add on. I used instructions at link posted above to disable the extensions blocklist by setting it to false. Thank you!! IDM is back in business. I will reset this to true in about:config in a day or two and see what happens.
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40427 answers

Helpful Reply

You can also delete the blocklist.xml file from your Profile folder, when Firefox is closed. When you open Firefox it will retrieve a new version of that file from Mozilla as part of the launch process. http://support.mozilla.com/en-us/kb/Profiles#How_to_find_your_profile

That's usually a little quicker than waiting for Firefox to update that file all by itself (which is usually a next day process).

You can also delete the '''blocklist.xml''' file from your Profile folder, when Firefox is closed. When you open Firefox it will retrieve a new version of that file from Mozilla as part of the launch process. [http://support.mozilla.com/en-us/kb/Profiles#How_to_find_your_profile] That's usually a little quicker than waiting for Firefox to update that file all by itself (which is usually a next day process).

Question owner

It works now.. Hooray for firefox.. I thought I was going to use a different browser, but glad firefox fix this problem.. Please don't let it happen again.

It works now.. Hooray for firefox.. I thought I was going to use a different browser, but glad firefox fix this problem.. Please don't let it happen again.