X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keeps trying to substitute Ask as my search engine. I want to use Google, but FF keeps changing it back to Ask, even when I delete Ask in the "manage search engine" function.

Posted

See the question. It's all there!

This happened

Every time Firefox opened

See the question. It's all there! == This happened == Every time Firefox opened

Chosen solution

Uninstall Ask Several free programs will install Ask as an "extra". Foxit Reader, which you have installed, is one of those. You must opt-out on such items either at download of the free program or during the installation of the free program. In Foxit Reader, the opt-out is during the installation of Foxit Reader. See the image attached for the Foxit Reader opt-out.

First try to disable or uninstall the Ask.com Toolbar in Firefox via "Tools -> Add-ons -> Extensions". See: Disable or remove Add-ons.

In some cases, you may need to uninstall the Ask Toolbar using Windows Control Panel . See Cannot uninstall an add-on - Uninstall from Windows Add/Remove Programs.

You may also need to reset preferences related to Ask.com via about:config, specifically the keyword.URL preference - -Open a new tab or window. -Type about:config in the URL/address bar and press the Enter key -If you see a warning, accept it (promise to be careful) -Filter = keyword.url -Right-click on the preference below the Filter, and choose Reset -Restart Firefox (File > Restart Firefox) See: http://kb.mozillazine.org/Keyword.URL for details.

See: http://kb.mozillazine.org/Problematic_extensions#Ask_Toolbar http://kb.mozillazine.org/Uninstalling_toolbars


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

Update Java: your ver. 1.6.0.17; current ver. 1.6.0.20 (important security update 04-15-2010) (Firefox 3.6 and above requires Java 1.6.0.10 or higher; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) (Windows users: Do the manual update; very easy.) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: Updating Java Do the update with Firefox closed.

NOTE: There is no need to have 2 PDF Readers installed; you have Foxit Reader and Adobe Reader. The un-install of either is done using Setting > Control Panel > Add or Remove Programs (with Firefox closed).

If you intend to keep Adobe Reader: You ~~red:MAY~~ need to Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox): your ver. N/A; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader You may be able to update from the Adobe Reader installed on your system instead of going to the Adobe site and downloading. Open the Adobe Reader installed on your system (in Windows, Start > Program Files, find and click Adobe Reader to open), click Help, click Check for Updates. If you go to the Adobe site to download the current Adobe Reader: -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -In Windows: check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • -NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 AskTbFXTV5/3.8.0.12304 Firefox/3.6.6 ( .NET CLR 3.5.30729)

More Information

TXGuy 87 solutions 861 answers

Chosen Solution

Uninstall Ask Several free programs will install Ask as an "extra". Foxit Reader, which you have installed, is one of those. You must opt-out on such items either at download of the free program or during the installation of the free program. In Foxit Reader, the opt-out is during the installation of Foxit Reader. See the image attached for the Foxit Reader opt-out.

First try to disable or uninstall the Ask.com Toolbar in Firefox via "Tools -> Add-ons -> Extensions". See: Disable or remove Add-ons.

In some cases, you may need to uninstall the Ask Toolbar using Windows Control Panel . See Cannot uninstall an add-on - Uninstall from Windows Add/Remove Programs.

You may also need to reset preferences related to Ask.com via about:config, specifically the keyword.URL preference - -Open a new tab or window. -Type about:config in the URL/address bar and press the Enter key -If you see a warning, accept it (promise to be careful) -Filter = keyword.url -Right-click on the preference below the Filter, and choose Reset -Restart Firefox (File > Restart Firefox) See: http://kb.mozillazine.org/Keyword.URL for details.

See: http://kb.mozillazine.org/Problematic_extensions#Ask_Toolbar http://kb.mozillazine.org/Uninstalling_toolbars


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

Update Java: your ver. 1.6.0.17; current ver. 1.6.0.20 (important security update 04-15-2010) (Firefox 3.6 and above requires Java 1.6.0.10 or higher; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) (Windows users: Do the manual update; very easy.) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: Updating Java Do the update with Firefox closed.

NOTE: There is no need to have 2 PDF Readers installed; you have Foxit Reader and Adobe Reader. The un-install of either is done using Setting > Control Panel > Add or Remove Programs (with Firefox closed).

If you intend to keep Adobe Reader: You ~~red:MAY~~ need to Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox): your ver. N/A; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader You may be able to update from the Adobe Reader installed on your system instead of going to the Adobe site and downloading. Open the Adobe Reader installed on your system (in Windows, Start > Program Files, find and click Adobe Reader to open), click Help, click Check for Updates. If you go to the Adobe site to download the current Adobe Reader: -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -In Windows: check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader

<u>'''Uninstall Ask'''</u> Several free programs will install Ask as an "extra". Foxit Reader, which you have installed, is one of those. You must opt-out on such items either at download of the free program or during the installation of the free program. In Foxit Reader, the opt-out is during the installation of Foxit Reader. See the image attached for the Foxit Reader opt-out. First try to disable or uninstall the Ask.com Toolbar in Firefox via "Tools -> Add-ons -> Extensions". See: [[Uninstalling add-ons]]. In some cases, you may need to uninstall the Ask Toolbar using Windows Control Panel . See [http://support.mozilla.com/en-US/kb/Cannot+uninstall+an+add-on#Uninstall_from_Windows_Control_Panel Cannot uninstall an add-on - Uninstall from Windows Add/Remove Programs]. You may also need to reset preferences related to Ask.com via about:config, specifically the keyword.URL preference - -Open a new tab or window. -Type '''about:config''' in the URL/address bar and press the Enter key -If you see a warning, accept it (promise to be careful) -Filter = keyword.url -Right-click on the preference below the Filter, and choose Reset -Restart Firefox (File > Restart Firefox) See: http://kb.mozillazine.org/Keyword.URL for details. See: http://kb.mozillazine.org/Problematic_extensions#Ask_Toolbar http://kb.mozillazine.org/Uninstalling_toolbars ---------------------------------------- <u>'''''Other Issues'''''</u>: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~ <u>'''Update Java'''</u>: your ver. 1.6.0.17; current ver. 1.6.0.20 (<u>important security update 04-15-2010</u>) (Firefox 3.6 and above requires Java 1.6.0.10 or higher; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) ''(Windows users: Do the manual update; very easy.)'' ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: '''[http://support.mozilla.com/en-US/kb/Using+the+Java+plugin+with+Firefox#Updates Updating Java]''' Do the update with Firefox closed. <u>'''NOTE: There is no need to have 2 PDF Readers installed; you have Foxit Reader and Adobe Reader. '''</u> The un-install of either is done using Setting > Control Panel > Add or Remove Programs (with Firefox closed). <u>'''If you intend to keep Adobe Reader:'''</u> <u>'''You'''</u> ~~red:<u>'''MAY'''</u>~~ <u>'''need to Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox)'''</u>: your ver. N/A; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader ''<u>You may be able to update from the Adobe Reader installed on your system</u>'' instead of going to the Adobe site and downloading. Open the Adobe Reader installed on your system (''in Windows, Start > Program Files, find and click Adobe Reader to open''), click Help, click Check for Updates. ''<u>If you go to the Adobe site to download the current Adobe Reader:</u>'' -'''<u>use Firefox to download</u>''' and <u>'''SAVE to your hard drive'''</u> (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -In Windows: check to see that Firefox is completely closed (''Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window'') -double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader *<u>'''NOTE: On Vista and Windows 7'''</u> you may need to run the plugin installer as Administrator by starting the installer via the right-click context menu if you do not get an UAC prompt to ask for permission to continue (i.e nothing seems to happen). See this: http://vistasupport.mvps.org/run_as_administrator.htm *'''<u>NOTE for IE:</u>''' Firefox and most other browsers use a Plugin. IE uses an ActiveX version. To install/update the IE ActiveX version, same instructions as above, except use IE to download the ActiveX installer. See: [[ActiveX]] *Also see: http://kb.mozillazine.org/Adobe_Reader ~~red:'''''AND'''''~~ [[How do I edit options to add Adobe to the list of allowed sites]]
Bazinga 0 solutions 1 answers

Helpful Reply

Removing Ask Toolbar --This is a nasty creature and did not go away with all the fixes I tried--except this last one.

The permanent fix: I have ZoneAlarm ForceField from CheckPoint software. Get this and install on your browser, click on the ZoneAlarm icon click on 'Settings', open the 'Advanced' tab--leave all default settings, go to bottom of the settings and click on "Clear Virtual Data" and then on "OK".

The browser will close and when you reopen another browser window, the insidious Ask toolbar will have been removed and your default search address bar will be back to Google. You can change this if you like to any other toolbar of course.

'''Removing Ask Toolbar''' --This is a nasty creature and did not go away with all the fixes I tried--except this last one. '''The permanent fix: '''I have ZoneAlarm ForceField from CheckPoint software. Get this and install on your browser, click on the ZoneAlarm icon click on 'Settings', open the 'Advanced' tab--leave all default settings, go to bottom of the settings and click on "Clear Virtual Data" and then on "OK". The browser will close and when you reopen another browser window, the insidious Ask toolbar will have been removed and your default search address bar will be back to Google. You can change this if you like to any other toolbar of course.

Modified by Bazinga

Summer313 1 solutions 4 answers

At the risk of sounding totally idiotic, I'll post my issue. The last 3 days have driven me totally crazy. Regarding the displayed solution, I have checked and have nothing at all linking or directing me to ask.com and over 200 times have had to reset my default search to Google. Ask.com doesn't ever find anything I search for it just gives me another page with the exact search terms I used underlined that I must click on before getting anywhere. No thanks to ask.com, I have many more important things to do rather than click and click and click to find something using ask.com. It royally sux that I cannot get this to stay set. When I check in about:config my default search engine says it is Google, (I've checked it about 200 times already in the last couple of days) but then the very next search I run goes right back to ask.com.

I am sure someone out there knows a million times more than me and will give the fastest easiest answer in no time, so I am awaiting your expertise. I did check the process of the previous solution but that didn't work for me.

Is there some way I can totally block ask.com? I am ready to start screaming at them.  :( Grrr...

For right now, I have found that if I leave the "about:config" tab open at the browser default that my searches will be in Google, but what a total PITB!

I've included an image of the window/tab I must keep open for those who have no clue to what I am referring. Until yesterday, I had no clue about any of this until I did a bit of investigating! (I lock the tab so it stays open-but that doesn't help me keep track of the 30-40 already open tabs that I use for researching my medical articles!)

For quick reference to those who may also be experiencing difficulty. Just make sure that you don't change anything you are not sure about or you will have more problems than just this one!

Type about:config in your address bar and select enter, then find browser.search.defaultenginename

Then I re-started, but no luck!

The article I read said to right click and select Reset but mine is already at Google like the image shows and Reset is not available. Just opening it seems to reset it somehow.

I wish I were intelligent enough to know what to look for to permanently fix the issue but unfortunately, I am just a dummy and the most I know about home computers dates back to when we booted from a cassette tape and the internet was just beginning with BBS which my husband hosted! Yes, I am a bit behind the times but still learning! I may be too old to use the computer by the time I learn all I need to know but oh well, it's a process!  ;) I will certainly not be offended if someone posts a fix I don't know about.

At the risk of sounding totally idiotic, I'll post my issue. The last 3 days have driven me totally crazy. Regarding the displayed solution, I have checked and have nothing at all linking or directing me to ask.com and over 200 times have had to reset my default search to Google. Ask.com doesn't ever find anything I search for it just gives me another page with the exact search terms I used underlined that I must click on before getting anywhere. No thanks to ask.com, I have many more important things to do rather than click and click and click to find something using ask.com. It royally sux that I cannot get this to stay set. When I check in about:config my default search engine says it is Google, (I've checked it about 200 times already in the last couple of days) but then the very next search I run goes right back to ask.com. I am sure someone out there knows a million times more than me and will give the fastest easiest answer in no time, so I am awaiting your expertise. I did check the process of the previous solution but that didn't work for me. Is there some way I can totally block ask.com? I am ready to start screaming at them. :( Grrr... For right now, I have found that if I leave the "about:config" tab open at the browser default that my searches will be in Google, but what a total PITB! I've included an image of the window/tab I must keep open for those who have no clue to what I am referring. Until yesterday, I had no clue about any of this until I did a bit of investigating! (I lock the tab so it stays open-but that doesn't help me keep track of the 30-40 already open tabs that I use for researching my medical articles!) ''For quick reference to those who may also be experiencing difficulty. Just make sure that you don't change anything you are not sure about or you will have more problems than just this one!'' ''Type'' '''about:config''' ''in your address bar and select enter, then find '''''browser.search.defaultenginename''' Then I re-started, but no luck! The article I read said to right click and select Reset but mine is already at Google like the image shows and Reset is not available. Just opening it seems to reset it somehow. I wish I were intelligent enough to know what to look for to permanently fix the issue but unfortunately, I am just a dummy and the most I know about home computers dates back to when we booted from a cassette tape and the internet was just beginning with BBS which my husband hosted! Yes, I am a bit behind the times but still learning! I may be too old to use the computer by the time I learn all I need to know but oh well, it's a process! ;) I will certainly not be offended if someone posts a fix I don't know about.