X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps redirecting me, after I try to open a webpage I've found in "search"

Posted

Locked due to age. If you still have a problem, please start a new thread

After doing a search, I will click on suggested websites. It will start to load, then will redirect me to another site that generally has nothing to do with the original search.

This happened

Not sure how often

== a couple of days ago

Modified by Shawn

Chosen solution

One of your add-ons might be the culprit too. Try running Firefox in Troubleshoot Firefox issues using Safe Mode with all add-ons disabled. If that solves the problem, see Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and possibly Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Also your issue may be caused by Malware. You can run and update the following free anti virus software:

1. Malwarebytes (Free version) - http://www.malwarebytes.org

2. Spybot Search & Destroy - http://www.safer-networking.org

3.Spyware Terminator - http://www.spywareterminator.com

In addition, there are a number of forums you can use to help get rid of your infection. These include:

Read this answer in context 10

Additional System Details

Installed Plug-ins

  • -npsnapfish
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.1483
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Google Update
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

More Information

rondelrio 0 solutions 2 answers

I had this same problem which was driving me crazy !! ..I followed some of the suggestions and some seemed to work for a short while.. After a few days i have managed to succeed in stopping the redirects from happening ..what i did was this ..

I installed browser protect add on from the extensions page then i surfed the net for about 15 mins and constantly browsing and searching with google. I then clicked addons -extensions and options on browser protect.. in options you get 4 tabs look through them and you will see the offending search links ..Delete them all and leave only the ones you know are safe.. then browse and you will see you dont get redirected anymore ... check your options if you start to get redirected again and go through the same process and delete the suckers ...

This is the only solution that has really worked for me, malware scans virus scans and all the rest didnt work .. I even deleted firefox re booted and downloaded again only to find it started to redirect to some crappy "alltheweb2 links and some other links i cant remember now..

Give the above a shot it works !.

MustangLarry 0 solutions 1 answers

Super helpful and simple. I found two entires on this and deleted them both. Nop roblems now. Thanks

LJL 0 solutions 1 answers

On the Menu Bar, Go to TOOLS - OPTIONS- ADVANCED- un-check "Warn me when websites try to redirect or reload the page" This is a solution that has worked for me for the past few months.

Modified by LJL