Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn off all keyboard shortcuts?

more options

Like many people I suck at typing. For some reason, a certain accidental keystroke combo makes me go back the to the previous page, thereby losing everything I typed, such as form data or forum comments. This happens randomly and I NEVER use keyboard shortcuts while browsing because I always use the mouse except when typing. I really, really want to disable all keyboard shortcuts but there is no option to do this. What do I do? Go back to Exploder? I hope not!

This happened

A few times a week

== since installing FF

All Replies (8)

more options

Try to disable them with the Keyconfig extension. http://kb.mozillazine.org/Keyconfig_extension - Keyconfig_extension http://dorando.emuverse.com/projects/mozilla/readme.html

more options

It might help to know that the keyboard shortcut you probably keep accidentally hitting is backspace (when a form field is not focussed). Note that you can press Forward again and often you will get back to the page you just left, with forms intact.

Gerv

more options

For disabling the backspace action you can set the pref browser.backspace_action to 2 on the about:config page.

See http://kb.mozillazine.org/browser.backspace_action

more options

Well i have same problem and i don't press "Backspace" when this happens.

more options

Boris_yo

Please do not use old, existing, threads to ask a question, but start a new thread.

Then you can provide troubleshooting information like your operating system and installed plugins (about:plugins), and extensions (Tools > Add-ons) and we will be better able to help you.

more options

Those keyboard shortcuts are a god awful pos. I've lost so much data it's ridiculous because of them. I have no idea what happens. My fingers slip off a key and, boom, I get switched to another page and I never see the stuff I've been typing again. You just made my decision to go with Opera much easier to make. There's absolutely no reason for those shortcuts. All they do is ruin the work I'm doing. I have no idea what key combination it is. I just know that suddenly. for no reason I can find, I lose everything I've typed for the last 20 minutes, all the work I've put into the things I've typed, and all the time I've put in. What a total joke. You make me screaming mad because you and your "gotta put new stuff in there" attitude has just made my life miserable. Thanks for nothing.

Modified by KingGhidora

more options

84 users have this problem (myself included) but I don't see that anyone has told us how to disable ALL keyboard shortcuts. Isn't there one simple way to turn all keyboard shortcuts off in FF8 (or earlier versions)?

more options

Sorry, there is no switch to turn off all keyboard shortcuts in ant version of Firefox.

Other than the Backspace key, Esc key, and the Cursor / Navigation part of the keyboard, most single key shortcuts involve the F-keys or are multiple key combos using a modifier key - Shft, Alt, or Ctrl.
https://support.mozilla.com/en-US/kb/Keyboard%20shortcuts