X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox says I need plugin updates Plugins are listed as Netscape plugins am I supposed to use these for Firefox

Posted

Firefox says my plugins need updating. When I look at the plugin update page it says these are Netscape plugins. Do I need to use these with Firefox? I have 3.6 installed.

This happened

Just once or twice

== Today

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16263
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

More Information

Adobe Acrobat Plug-In Version 7.00 for Netscape
Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)
DRM Store Netscape Plugin

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24449 answers

Yes.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Your plugins list shows outdated plugin(s) with known security and stability risks.

  1. Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

Update the Java plugin to the latest version. See http://java.sun.com/javase/downloads/index.jsp#jdk (you need JRE)