X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox sayst billing.microsoft.com uses an invalid security certificate

Posted

I'm trying to close out my hotmail account, but when I try to access billing.microsoft.com, Firefox says that page is using an invalid security certificate because the issuer certificate is unknown, and warns me not to proceed by creating an exception

URL of affected sites

https://billing.microsoft.com/helppane.aspx

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.0 r45
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.9.0042.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • Default Plug-in
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

billing.microsoft.com uses an invalid security certificate.
The certificate is not trusted because the issuer certificate is unknown.
(Error code: sec_error_unknown_issuer)

Question owner

The certificate provided is indeed invalid. It is signed by Microsoft themselves, not a trusted certificate authority.

Question owner

Apart from that ,latest Google Chrome has the same error message.

Question owner

This is a root certificate which serves as a website certificate at the same time. This is an oddity, since in all other cases (that I know), you have a root certificate which signs a website certificate.

I wrote more about this at http://certwatch.simos.info/2010/08/0.../the-new-billing-microsoft-com-root-certificate/

skrias 0 solutions 2 answers

It is related to browser settings do,

Firefox -> Tools -> Advanced -> view certificates -> servers -> Add exceptions


and add the your url in that dialogue box.