X
Tap here to go to the mobile version of the site.

Support Forum

How do I delete search history? I tried the steps in "how to clear search history but when I click on history it still shows search history

Posted

I cannot clear search history. I tried procedures found in "How to clear search history" in help but when I click on "History" it's all still there>

This happened

Every time Firefox opened

== since i've had my computer

I cannot clear search history. I tried procedures found in "How to clear search history" in help but when I click on "History" it's all still there> == This happened == Every time Firefox opened == since i've had my computer

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Office Plugin for Netscape Navigator
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • Shockwave Flash 10.0 r45
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

More Information

i don't know what this means

cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Make sure that you do not get confused by Use popular search suggestions in the Firefox Search bar. The "Search Suggestions" are not your search history. The search suggestions are loaded in real time by querying the (Google) search engine site based on what you typed so far in the search bar. If "Clear Search History" is grayed out then the history is cleared or disabled.

You can disable the search suggestions by right-clicking the text field in the search bar and remove the mark before "Show Suggestions".

Make sure that you do not get confused by [[Search suggestions]]. The "Search Suggestions" are not your search history. The search suggestions are loaded in real time by querying the (Google) search engine site based on what you typed so far in the search bar. If "Clear Search History" is grayed out then the history is cleared or disabled. You can disable the search suggestions by right-clicking the text field in the search bar and remove the mark before "Show Suggestions".

Question owner

there is no "show suggestions" when right clicking text field

there is no "show suggestions" when right clicking text field

Question owner

i tried that but it didn't work!

i tried that but it didn't work!