Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 beta does not have aero.

more options

I just updated to Firefox 4.0b1 and there is no Aero interface. The button in the upper left is grey, not orange, and the minimize, maximize, and close buttons are missing. I'm using Vista Home Premium. Screenshot available here: http://img541.imageshack.us/img541/7409/screennf.png

This happened

Every time Firefox opened

== After update.

All Replies (11)

more options

I also have the same problem. Pls advise solution. Thanks.

more options

I found the a solution that works for me, go into your themes and delete everything. Glass should then work. There is most likely a more direct method but I don't feel like tinkering so brute force works for me.

more options

do what helix says. it works :)

more options

You should not have to remove the other themes. Just make sure that the default theme is enabled.

more options

I had the same issue and all I had to do was enable the default theme and restart, not remove any other themes.

I know it's only a beta, but I would have thought that they would enable the default theme by... default!

more options

I have a similar problem but my theme says it is incompatible.

more options

Fixed, problem was a windows 7 theme

more options

I have a similar problem. When I first installed FF4b1, it reported that the Default theme was incompatible with FF4. Strangely, that has resolved itself without any help from me, and I am supposedly using the new FF4b1 default theme. However, my FF window still has the ordinary windows title bar, including min/max/close buttons, and the Firefox button is on the same row as the tabs.

See attached screenshot, or http://andstuff.org/ff-ui.jpg

Suggestions?

more options

I just want to make sure you are using this on Vista or Windows 7 as XP or before does not have Aero.

more options

John, ah, ok, yes, I am using XP. Didn't realize that Aero was only half-working on XP. Thanks.

more options

By me, the default theme was marked incompatible several times (in the new add-on manager), and I had to use a little step-around, but simple solution. I just:

  1. Closed Firefox 4 preview
  2. opened an older version of Firefox
  3. enabled the default theme
  4. closed the older version
  5. opened Firefox 4 preview

However, I admit bug (577098) is a weird bug