Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove Bing search from my location bar search and return it to Google as it once was?

  • 10 replies
  • 79 have this problem
  • Last reply by 1isztomania

more options

I noticed it a few weeks ago. When I just search in the address bar as I normally do Firefox has begun using Bing search as oppose to Googles "I'm Feeling Lucky". This is very frustrating, as Google is far superior to Bing.

This only seems to happen however when I search one word in the address bar. If I search 2 or more words, it continues to use Google.

I have searched for solution to this already and nothing seems to work. I don't have any Bing/Microsoft search bars installed. I have no search extensions from Microsoft. And there are no updates on my computer that have been recommned to be removed on other forums.

Please get my Firefox back to normal!

This happened

Every time Firefox opened

== Started a few weeks ago.

All Replies (10)

more options

"Bing" appears as a little search window to the right side of the window where the web addresses appear. How do I remove it?

more options

I dont under any circumstances want to retain the Bing search bar. Can you help me get rid of it once and for all ?

more options

Please help me get Goggle back. I don't want Bing.

more options

To bb: I discovered that the icon on the left of the little search window has a drop down arrow. IF you click on that, you can select Google or another search option.

more options
more options

I'm not getting google or my inbox or email

more options
more options

I'm furious that a browser decided for me that I wanted to use Bing. If I wanted it, I would have installed it. If I can't find a way to get rid of it, I'm going to uninstall Firefox and go back to Explorer.

more options

Step A) Go to the following link, scroll down to the Steps 1-4 and do as they say. Stop at step 5 on the site and go to step B bellow.

Step B) Instead of doing step 5 in the link above; Right Click "keyword.URL" and left click "Reset"

I added an image for help.......

Step C) It should now be back to default firefox.

Note: Step 5-7 work, but don't actually bring back the old firefox feature, they just replace it with non-bing searches.

Also, this isn't Firefox's fault, Microsoft forced an update for Windows that caused Bing to rape IE and Fire Fox...

Modified by TeslaDan5

more options