X
Tap here to go to the mobile version of the site.

Support Forum

I keep getting the following message and crash - "plugin container for firefox has stopped working." How can I fix this?

Posted

Over the last few day the interent has been crashing with the following response - "plugin container for firefox has stopped working." Why and how can I fix this issue?

Over the last few day the interent has been crashing with the following response - "plugin container for firefox has stopped working." Why and how can I fix this issue?

Chosen solution

If anyone wants to disable the plugin container, read this: http://support.mozilla.com/en-US/kb/The%20Adobe%20Flash%20plugin%20has%20crashed#Disable_hang_protection


Note that the above referenced KB article is about disabling the timeout and not about disabling the container process. To disable the container process you need to sett all dom.ipc.plugins.enabled prefs to false.

See http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins

cor-el

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -npmnqmp 989898989877
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 6.0.11.3006
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 10.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • Rhapsody Player Engine Plugin
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 (.NET CLR 3.5.30729)

More Information

Question owner

I have the same exact problem. Still looking for a solution.

I have the same exact problem. Still looking for a solution.
Morbus 135 solutions 2340 answers

Arun, have you read this post? If it didn't help, please go into Help > Troubleshooting Information... (alternatively, access about:support in your location bar) and click "Copy all to clipboard". Then paste here. Hopefully that will give me a bit more information to work with.

Arun, have you read [https://support.mozilla.com/en-US/forum/1/708305?forumId=1&comments_threshold=0&comments_parentId=708305&comments_offset=20&comments_per_page=20&thread_style=commentStyle_plain#threadId709375 this post]? If it didn't help, please go into ''Help > Troubleshooting Information...'' (alternatively, access ''about:support'' in your location bar) and click "Copy all to clipboard". Then paste here. Hopefully that will give me a bit more information to work with.

Question owner

i had the same problem. i fix it by downgrading to 3.6.3. a sec ago when i thought id upgrade again and upgraded to 3.6.6 i got the same problem so i downgraded again.

  1.  Go to the Mozilla FTP server.
  2. Choose the version you want.
  3. Choose the win32/mac/linux-1686/ folder
  4. Choose your language. en-US is US English.
  5. Choose the file that does not end in .asc. The download will then start.
  6. Once the file is downloaded, install it. 

After downgrading, if you intend to stay with that version, you will need to turn off Software Update.

i had the same problem. i fix it by downgrading to 3.6.3. a sec ago when i thought id upgrade again and upgraded to 3.6.6 i got the same problem so i downgraded again. 1. Go to the Mozilla FTP server. 2. Choose the version you want. 3. Choose the win32/mac/linux-1686/ folder 4. Choose your language. en-US is US English. 5. Choose the file that does not end in .asc. The download will then start. 6. Once the file is downloaded, install it. After downgrading, if you intend to stay with that version, you will need to turn off Software Update.
Morbus 135 solutions 2340 answers

Version 3.6.3 is not recommended as it doesn't contain the latest security fixes. If you want a Firefox version without plugin isolation, please use version 3.5.10.

Version 3.6.3 is '''''not''''' recommended as it doesn't contain the latest security fixes. If you want a Firefox version without plugin isolation, please use version 3.5.10.

Question owner

Same problem with Windows 7

I am now mostly using Iron for my browsing simply because Firefox is getting way unstable 

I have the disconnetion issue as well

Same problem with Windows 7 I am now mostly using Iron for my browsing simply because Firefox is getting way unstable I have the disconnetion issue as well
Morbus 135 solutions 2340 answers

Strant, please read this post.

Strant, please read [https://support.mozilla.com/en-US/forum/1/708305?forumId=1&comments_threshold=0&comments_parentId=708305&comments_offset=20&comments_per_page=20&thread_style=commentStyle_plain#threadId709375 this post].

Question owner

The issue here is still that the plugin container in v3.6.6 crashes and takes the rest of Firefox down also, which is not what is supposed to happen. From the docs: "In Firefox 3.6.4 and above, some plugins are loaded separately from Firefox in plugin-container.exe, allowing the main Firefox process (firefox.exe) to stay open if a plugin crashes." It does not work as advertised. In addition, blaming this problem solely on buggy plugins doesn't make sense, since re-installing v3.6.3 over v3.6.6, as a test, without downgrading plugin versions, eliminates the crash problem. Plugin-container.exe needs to be fixed.

The issue here is still that the plugin container in v3.6.6 crashes and takes the rest of Firefox down also, which is not what is supposed to happen. From the docs: "In Firefox 3.6.4 and above, some plugins are loaded separately from Firefox in plugin-container.exe, allowing the main Firefox process (firefox.exe) to stay open if a plugin crashes." It does not work as advertised. In addition, blaming this problem solely on buggy plugins doesn't make sense, since re-installing v3.6.3 over v3.6.6, as a test, without downgrading plugin versions, eliminates the crash problem. Plugin-container.exe needs to be fixed.

Question owner

I have the same problem. Also, when firefox reloads, google toolbar will ask to translate webpages already in English into English and I will have to tell it to never translate English into English. Is Google Toolbar to blame?

I have the same problem. Also, when firefox reloads, google toolbar will ask to translate webpages already in English into English and I will have to tell it to never translate English into English. Is Google Toolbar to blame?

Question owner

i have the same problem using 3.6.6

i have the same problem using 3.6.6

Question owner

I have had the same problem with Firefox version 3.6.6. When I go to a page with Flash video it freezes. I then have to close down Firefox via Task Manager.

I then get the message "Plugin Container for Firefox has stopped working".

Like other people I have resolevd the problem by downgrading to an earlier version of Firefox. And with version 3.5.10, which is recommended on this page for security reasons, I do not get the problem.

But how will I know when to upgrade to a later version (ie later than version 3.6.6) and still not have the problem?

I have had the same problem with Firefox version 3.6.6. When I go to a page with Flash video it freezes. I then have to close down Firefox via Task Manager. I then get the message "Plugin Container for Firefox has stopped working". Like other people I have resolevd the problem by downgrading to an earlier version of Firefox. And with version 3.5.10, which is recommended on this page for security reasons, I do not get the problem. But how will I know when to upgrade to a later version (ie later than version 3.6.6) and still not have the problem?
Morbus 135 solutions 2340 answers

David, your issue will only be fixed in versions after 3.6.6 if the issue is caused by a problem with Firefox. To know if it is a problem with Firefox or with an add-on, please read this post. Post the results if you wish for further help.

If it's a problem with an add-on, it will never be fixed by just updating Firefox alone. You need to update the problematic add-ons, and if their latest versions are still causing problems, disable them altogether.

David, your issue will only be fixed in versions after 3.6.6 ''if'' the issue is caused by a problem with Firefox. To know if it is a problem with Firefox or with an add-on, please read [https://support.mozilla.com/en-US/forum/1/708305?forumId=1&comments_threshold=0&comments_parentId=708305&comments_offset=20&comments_per_page=20&thread_style=commentStyle_plain#threadId709375 this post]. Post the results if you wish for further help. If it's a problem with an add-on, it will never be fixed by just updating Firefox alone. You need to update the problematic add-ons, and if their latest versions are still causing problems, disable them altogether.

Question owner

Same problem w/3.6.6

Same problem w/3.6.6

Question owner

I got that problem when i go in fullscreen while watching videos, at internet explorer it's the same even some of my games won't start anymore.Like if i want to play spore it always says: "SPORE has stopped working"

I got that problem when i go in fullscreen while watching videos, at internet explorer it's the same even some of my games won't start anymore.Like if i want to play spore it always says: "SPORE has stopped working"

Question owner

it sucks. I always thought Firefox was exceptional...now it seems to keep developing more and new glitches, routinely. Where is the solution for this plug-in container/crash/sound situation???

it sucks. I always thought Firefox was exceptional...now it seems to keep developing more and new glitches, routinely. Where is the solution for this plug-in container/crash/sound situation???
Morbus 135 solutions 2340 answers

Here hopefully.

[https://support.mozilla.com/en-US/forum/1/708305?forumId=1&comments_threshold=0&comments_parentId=708305&comments_offset=20&comments_per_page=20&thread_style=commentStyle_plain#threadId709375 Here] hopefully.

Question owner

There are those of us with moderate computer skills who are unwilling to spend the time to disable all plug-ins; it is simply not worth dealing w/a program that crashes every 5-10 min. & requires task manager to close. I suggest chrome -- takes some getting use to but DOES NOT CRASH.

There are those of us with moderate computer skills who are unwilling to spend the time to disable all plug-ins; it is simply not worth dealing w/a program that crashes every 5-10 min. & requires task manager to close. I suggest chrome -- takes some getting use to but DOES NOT CRASH.
Morbus 135 solutions 2340 answers

If you have a problem with Google Chrome, you need to contact Google, since they are the ones that develop it. Be mindful that the big amounts of RAM it uses up when browsing multiple tabs is not a bug, but rather a "feature" of Chrome. Also, be mindful that the impossibility of having many tabs in the same window is not a bug, but rather a "feature" of Chrome. Bear in mind, in addition, that the relatively poverty of add-ons for Google Chrome is not as much due to its age as it is to the impossibility of developing add-ons for it that are as rich as those for Firefox. Don't forget either that the fact that Chrome will send, by default, potentially private information to Google is not a bug, but rather a "feature" of Chrome. You may also end up finding the very same problems you found in Firefox, if those were due to careless usage of add-ons or an infected system. For any usability problems, you will need to contact Google directly, too.

Also, if you are using another browser out of spite or because you can't fix your problem with Firefox, I will remind you that Mozilla is a non-profit, public service organization, and, as such, doesn't have the same financial interests Google (or any other company developing a major web browser) does. Mozilla's objective is that you, the user, use the browser you want, be if Firefox or any other browser. If you want to use Firefox but can't, due to a problem, I'm glad to work with you the best I know and can to fix it. If you actually want to use another browser, then I'm happy that you finally found your "home", and my job is successfully done.

If you have a problem with Google Chrome, you need to contact Google, since they are the ones that develop it. Be mindful that the [http://dotnetperls.com/chrome-memory big amounts of RAM it uses up] when browsing multiple tabs is not a bug, but rather a "feature" of Chrome. Also, be mindful that the impossibility of having many tabs in the same window is not a bug, but rather a "feature" of Chrome. Bear in mind, in addition, that the relatively poverty of add-ons for Google Chrome is not as much due to its age as it is to the impossibility of developing add-ons for it that are as rich as those for Firefox. Don't forget either that the fact that Chrome will send, by default, potentially private information to Google is not a bug, but rather a "feature" of Chrome. You may also end up finding the very same problems you found in Firefox, if those were due to careless usage of add-ons or an infected system. For any usability problems, you will need to contact Google directly, too. Also, if you are using another browser out of spite or because you can't fix your problem with Firefox, I will remind you that Mozilla is a non-profit, public service organization, and, as such, doesn't have the same financial interests Google (or any other company developing a major web browser) does. Mozilla's objective is that ''you'', the user, use the browser ''you want'', be if Firefox or any other browser. If you want to use Firefox but can't, due to a problem, I'm glad to work with you the best I know and can to fix it. If you actually want to use another browser, then I'm happy that you finally found your "home", and my job is successfully done.

Question owner

yh will you lot sort this coz it taking the PISS >.< im leaving the program if you dont bring out an update soon i cant do fuck all on the net now THANKS A LOT!

yh will you lot sort this coz it taking the PISS >.< im leaving the program if you dont bring out an update soon i cant do fuck all on the net now THANKS A LOT!

Question owner

Same problem using facebook and facebook apps. crashed 5 times in 15 minutes...

Same problem using facebook and facebook apps. crashed 5 times in 15 minutes...

Question owner

Who said Google Chrome crashes -- CHROME DOES NOT CRASH -- a willful misinterpretation of the post. FF CRASHES! I for one have no intention of fooling around disabling recommended plug-ins. I have chosen in the past to be a beta tester but not this time.

Who said Google Chrome crashes -- CHROME DOES NOT CRASH -- a willful misinterpretation of the post. FF CRASHES! I for one have no intention of fooling around disabling recommended plug-ins. I have chosen in the past to be a beta tester but not this time.