Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

3.6.4. Browser won't start - Process runs, no window

  • 70 replies
  • 533 have this problem
  • Last reply by Zendo08

more options

After upgrading to 3.6.4 the browser will not open. The process starts, but a window never appears.

Firefox will not open in Safe Mode. Profile Manager will not open.

Have performed a complete uninstall/reinstall, removing both the program files\mozilla folder and the mozilla folder in %appdata% before reinstalling.

Uninstalled all security software (MS Essentials, Outpost) and attempted reinstalling with no security software installed at all.

Have installed other builds, including Minefield and Namoroka. No 32 bit builds 3.6.4 or later will open on my system. The problem does not exist with 64 bit builds.

I have reverted to 3.6.3 but do not want to be stuck on this version forever.

All Replies (20)

more options

I went thru the same process as Stan... alas

the only reason I use FF over Chrome is because of the developers tools: Html Validator and Web Developer 1.1.8 If they are causing the problem - I'll switch to chrome and verify my HTML/CSS some other way. alas.

more options

You could try downgrading to 3.6.3. Here's a link:

more options

Same problem..:(

more options

Same thing here too.

Is there any solution out there? Took me a while to reinstall 3.6.3 and all my addons.

Very annoying!

more options

I tried 3.6.6. Same thing.

I reinstalled 3.6.3. over 3.6.6. and the browser starts again. I updated all plugins etc. No change.

more options

Hello everyone.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and theme and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

more options

Thanks Morbus.

But as stated by the original author FF will NOT start even in Safe Mode. Not a chance with versions above 3.6.3.

more options
more options

Mhh. I don't think this is helpful. Sorry. Any other ideas?

Process is running, but browser won't open. I'm running 3.6.3 again at the moment.

more options

Morbus, It might be good for you to pass on to the "powers that be" that in my developers user group, the ONLY reason we use FF over Chrome is because -up thru 3.6.3- of its awesome ability with the addons... ...and it sounds like MANY addons are no longer working. it may behoove those in marketing and development to take that into account since FF USED to support the addons, now no longer does. Having us contact all of the authors of the many addons that no longer function is, perhaps, a new policy of FF. But will, unfortunately, lead to many folk just staying with 3.6.3 until it is obsolete, or switching to Chrome (or, alas, IE ugh) just a suggestion. :-)

more options

Well I will use 3.6.3 until I find a fix, simply because 3.6.4 won't work. Can't see the connection of your post to the thread topic really.

more options

Hi FatBaron, ...connection to the thread is that its the addons that are causing the issue in 3.6.4+ so... I was just suggesting to Modzilla (not to any of us users) that perhaps they would like to address that issue as a company.

dats dat

more options

Problem still exists with 3.6.6. This is NOT an add-on issue. The problem still exists on a clean install. This issue seems to be fairly widespread.

more options

@ Lori "I was just suggesting to Modzilla (not to any of us users) that perhaps they would like to address that issue as a company." Mozilla Foundation develops Firefox, not Mozilla Corporation.

@ Stan Plugins (which are add-ons too) are not removed/modified by clean installing Firefox. Please run Firefox in safe mode to remove add-ons temporarily. If the problem remains, you know it's not an add-on issue.

more options

I think Stan is right. There has nothing to do with addons. Otherwise the safe mode would work. But it doesn't.

Perhaps it has something to do with Norton Internet Security. Is anybody using it? It is said to falsely recognize recently changed FF files as virus-like.

more options

mmm Stan,

I have disabled all of my addons EXCEPT two, that work with 3.6.4+ (the other addons all caused the issue) and I have no problem with 3.6.4 running. I had 4 additional addons that caused the "process runs/no window" issue... I had disabled them as Morbus suggested as a test.

wierdness, aye? ain't development a challenge thou.

more options


"Mozilla Foundation develops Firefox, not Mozilla Corporation." dont really care who develops it really, just suggesting that perhaps, as a game-plan, all of a sudden crashing instead of just getting a "addon no supported" alert is a bad business move for whoever develops it. dats all. cuz, bottom line, I love FireFox and it was JUST getting up there in % usage compared with IE (the bane of my existance)

more options

@lori: Which addons were the troublemakers?

more options

FatBaron, Yust 4 for me (see below) BUT, from the threads, i know there a more than that so I would suggest that you do the labor-intensive test that Morbus suggested last week for all of your addons.

1. uninstall FF 2. install version 3.6.3 (plays nice with all addons) 3. disable ALL addons and remove all plugins 4. upgrade to 3.6.4 (FF will work is all addons/plugins are gone) 5. install one addon at a time, restarting FF ea time 6. when you loose your window, that addon is an issue. 7. go back to #1 and start again, disabling the issue addon/plugin and moving on to the next one that you haven't tested.

yes, this takes some time but at least you'll know.

problem addons for me. - telephony 17.0 - microsoft .NET Framework Assistant 1.1 - Java quick starter 1.0 - an FTP client, but I can't remember which one i had on there...

2 that DO play nice so far (i'm at 3.6.4 - haven't upgraded to 3.6.6 yet) are: - HTML Validator - Web Developer 1.1.8

more options

p.s. to FatBaron FF 3.6.4 would NOT start in safe mode for me hence the uninstall and reinstall of an older, stable version 3.4.3

  1. 1
  2. 2
  3. 3
  4. 4