Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 3.6.4 uses a custom google search??

  • 29 replies
  • 133 have this problem
  • 1039 views
  • Last reply by ADCX_Rob

more options

I updated Firefox and now it's using a google custom search in the built in box instead of a standard google search. This fills the top half of the page with an adsense block, removes all the menu navigation from the left side (as seen on the new google search) and kills the top menu bar as well (for image searches, etc.) How can I get around this and get back to a normal google search again?

This happened

Every time Firefox opened

== I updated firefox an hour ago

All Replies (20)

more options

Hello Steve.

Can you please show me a screenshot of this faulty behavior? You may be having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not coming from one of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode and select Disable all add-ons. If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and theme. You can troubleshoot plugins the same way.

If you want support for one of your add-ons, you'll need to contact its author.

more options

Attached is a screen shot. This is with all addons disabled, and I restored the default search engines for good measure. When you search using the default built in google search you get this type of results page, rather than the standard google results page.

more options

I should add that it can be circumvented by using the 'Add to Search Bar' add-on and re-adding google. It seems kind of ridiculous to do that though.

more options

Well, about the lost bookmarks, see this: http://support.mozilla.com/en-US/kb/Lost+Bookmarks

And about the search thing, see this: http://support.mozilla.com/en-US/kb/Searches+are+redirected+to+another+site

Hopefully that will cover both of your problems...

more options

I never lost any bookmarks. It's also not all searches, just the ones using the default firefox google search. Any other google search (such as those from the site), or re-adding google search, works fine.

Also, it's not malware. These are corporate machines running Deep Freeze (they wipe themselves every boot). Unless the virus came directly from Mozilla, which I doubt, I don't have one. Thanks anyway though.

more options

I thought you lost your bookmarks because of that huge blank toolbar. If you don't want to see it, go into View > Toolbars > Bookmarks toolbar.

Anyway, glad it's fixed. Sorry for the confusion :P

more options

No, that's what safe mode looks like when you don't have anything in that folder. It displays the normal toolbars, which of course includes the bookmarks toolbar. I don't have any favorites IN the bookmarks toolbar folder, ergo a blank bar in safe mode. My normal display doesn't have that.

The problem isn't fixed. I don't know why it's pointing to a custom search page. Getting around a problem does not equal fixing it. It doesn't really matter at this point because I can avoid it, but I can't figure out why it would default to that anyway.

more options

"No, that's what safe mode looks like when you don't have anything in that folder. It displays the normal toolbars, which of course includes the bookmarks toolbar. I don't have any favorites IN the bookmarks toolbar folder, ergo a blank bar in safe mode. My normal display doesn't have that. " Oh, my mistake. I had never tried it like that

"The problem isn't fixed. I don't know why it's pointing to a custom search page. Getting around a problem does not equal fixing it. It doesn't really matter at this point because I can avoid it, but I can't figure out why it would default to that anyway. " I misunderstood you. I'm sorry.

Ok, so, basically what's happening is that your google search engine, in the search bar, is using a custom search. Have you tried deleting that engine and adding it again? To do so, click the engine logo, and go into Manage search engines... If this doesn't work, try reinstalling Firefox. I know it may sound extreme, but please do. The thing is, the default search engines are stored alongside the browser itself, and not in your profile folder. So if, somehow, your search engine got messed up, reinstalling will fix it.

more options

Yeah, that's what's happening. I already deleted it and added it again myself, which takes care of it as far as usability is concerned. What I'm wondering is why the update would cause that. The installation was fine before hand, and the update made the switch to a custom search. It doesn't make sense.

more options

I doesn't. I cannot replicate it from my end (although Google is behaving weirdly on my system - no matter the browser), so I can only think it must be some kind of coincidence... What I'm not sure is, is the issue fixed or not? Previously, I thought it was fixed... Now you're saying you took care of it as far as usability is concerned. So, it's fixed, right? Or is there an additional problem?

more options

Sorry Steve, I left in your name in the box somehow for the post directly above this one.

-igrigori

Fixed by Moderator: Steve, I noticed the exact same thing! I posted a similar finding about this but in a different manner. My forum question is "Has anyone else noticed this about 3.6.4???" under the name igrigori.

I was interested if anyone else had noticed, and you certainly have. If it's alright I'd like to duplicate that post here because people should know about this:

Anyone else notice that using the default search bar with Peerblock enabled and blocking HTTP with the default lists loaded you can no longer get any results?

Every Google search now is directed by "ValueClick Corporation" and Yahoo search is "Inktomi Corporation". Wasn't like this with 3.6.3. At least searching with Google it wasn't. Nope, not at all.

So if you want to continue using PeerBlock with HTTP blocking enabled you have to rollback to 3.6.3. Unless any of you know of any other options to continue using the default search bar. The search bar has changed to generate advertising for large corporations. I wonder how have the results changed? Most of you probably didn't even notice this. Most of us have no idea how much port activity takes place in the background or what kind of companies and corporations are connecting to us at any given point and time.

Any comments???

more options

Is PeerBlock an extension? That seems like it's causing the problem with the update. Again, if you want support for one of your add-ons, you'll need to contact its author. Most extensions are not developed by Mozilla, so Mozilla can't really do anything about them.

more options

No problem igrigori.

Yes, it's fixed. I deleted the bad one and replaced it with a good one. However the larger question is why it's happening in the first place.

I work in tech support for a living. Solving a problem is half of it, but knowing why it happened is equally important.

more options

No ,it's not an extension.

I had no problems with the update whatsoever.

I'm simply commenting on the fact that the default search bar has changed since Firefox build 3.6.3.

You can't use the default search bar with Peerblock HTTP blocking enabled. This is not a functionality issue, rather an issue with "whom" the search bar now directs our searches.

more options

I know what you mean, but I can't really say anything about that. All I know is I didn't have this problem on my side. I'll be on the lookout for people with similar problems, and will notify the developers for the possibility that something may be wrong with the update. It's very awkward though.

more options

So peer block is causing an update from firefox to swap it's default google search engine with a custom google search that includes a giant ad block? I find that hard to believe. How is an addon screwing with firefox defaults?

And if it was, why does it let me change it?

more options

No Steve.

PeerBlock and Firefox are both working just fine.

My point is that Yes, Firefox 3.6.4 is in fact using a custom Google search.

Not a functionality issue. It has to do with the way our searches with it our now being directed by"ValueClick Corporation".

PeerBlock blocks IP addresses of entities you don't want connecting to your ports in the background, incoming or outgoing.. Mainly TCP and UDP, however you may also choose to block HTTP as well.

In no way did it interfere with the Firefox update. It is simply blocking known entities from the lists I have loaded.

The default lists are: Adware and advertising, Spyware, P2P, and Education facilities. It blocks Edu facilities because they often host internet labs and conduct testing for large marketing firms and government entities.

One may choose what lists to use at any time, including others like known hackers or pedophiles for instance.

Great little piece of software. I can still use 3.6.4 but unfortunately I would have to disable HTTP blocking or disable a list, which I don't think I will do since I have been using this software with Firefox for a long time now.

It's back to 3.6.3. for me.

more options

K, just wanted to make sure I wasn't losing it. If you don't want to downgrade you can install the Add to Search Bar add on, delete google, go to google.com, and re-add it with the add on. It works then.

more options

Sorry about the confusion Steve.

I may try that to see if that changes anything. Thanks for the advice.

The offending IP address ranges if anyone is interested is:

209.85.157.0 - 209.85.157.255. Of course since it's HTTP it's on port 80.

more options

My 3.6.4 upgrade stated using a hijacked Google search page also, hijacks the right click search also.

Something very fishy with 3.6.4, like someone slipped in a hack.

I tried deleting Google from the search then re adding it, didn't fix it.

  1. 1
  2. 2