Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i've had 3.6.2,3.6.3,3.6.4 whan i was in math class these versions would have been newer,yet firefox took it upon itself to UPDATE? to 3.6??? how is that an update??of course chat is on vacation and ive never asked for help before so here goes . help??

  • 4 replies
  • 0 have this problem
  • 10 views
  • Last reply by zzxc

more options

3.6.4 had a bad adobe i went back to 3.6.3 why did firefox call it an update when 3.6.2,3.6.3,3.6.4 are a higher number than 3.6

This happened

Just once or twice

All Replies (4)

more options

Hi - I'm a bit confused by your question. According to the information sent with your forum post, you are using 3.6.4 now. Are you having problems with this version?

The order of the releases was Firefox 3.6, Firefox 3.6.1, Firefox 3.6.2, Firefox 3.6.3, Firefox, 3.6.4. You can view your current version in Help->About Firefox.

more options

i'm sorry .i worded it wrong.i had 3.5 originally.(computer hadn't been online in at least 6 months.next time i got online it updated to 3.6.4 beta ok i understand beta.itsstill technically 3.6 version basically.i began having hangups,and firefox crashes.found it was firefox plug-in-container.exe so removed firefox.back to cnet got 3.6.3 no beta either still same probs.today it updated to 3.6.4 this time it doesn't say beta yet i'm still getting the crashes .i thought they new about the java 1.18 buggy version i read in the forum when i began having trouible.i see they fied to java 1.20 i got my adobe 10.1 update just lost on how to stop this.i HATE microsloth and bing and ie but i don't like this problem.thanks for your patience

more options

The 3.6.4 beta and 3.6.4 are virtually the same. If your on an older version you can tell it not to update at that time.

3.6.4 has plugin helper support, so when a plugin crashes it doesn't take out the whole browser. If you haven't done so, you can try updating to the most recent release of each plugin by going here:

https://support.mozilla.com/en-US/kb/Troubleshooting+plugins http://www.mozilla.com/en-US/plugincheck/

I have 3.6.4 and have a problem, but I also don't use Facebook and Farmville or XP.

more options

thanks for all your help.i currently don't have internet,so i wont be having many problems for awhile.got ripped off by cricket broadband for the 5th month in a row.smashed my usb broadband from them.(couldnt even open a page with speed i was getting yet it was "unlimted" so browsers or java or wont be an issue for awhile.thanks again.