X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not load intranet sites. It used to prepend and append www. and com to all intranet lookups.

Posted

Firefox fails to load any local intranet sites. At one point it was prepending with www. and appending with .com.

URL of affected sites

http://gtoportal/sites/envsupport/default.aspx

Chosen solution

Are you sure your local host resolution recognizes these names? Type ping gtoportal into a terminal and see if it's recognized.

If it is not recognized, here are some fixes/workarounds:

  • Add .local to the end of the hostname. (so, http://toportal.local )
  • Change the server in /etc/resolv.conf to a server that includes hosts on the local network. (Such as a local router, or localhost if you are running bind)
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -Gecko Media Player 0.9.9.2Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • The IcedTea NPR Web Browser Plugin (using IcedTea6 1.8 (6b18-1.8-0ubuntu1)) executes Java applets.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100423 Linux Mint/9 (Isadora) Firefox/3.6.3

More Information

I have modified the Advanced>network to 'no proxy'. I also modified the about:config to not load these when loading from the address bar.

zzxc 22 solutions 242 answers

Chosen Solution

Are you sure your local host resolution recognizes these names? Type ping gtoportal into a terminal and see if it's recognized.

If it is not recognized, here are some fixes/workarounds:

  • Add .local to the end of the hostname. (so, http://toportal.local )
  • Change the server in /etc/resolv.conf to a server that includes hosts on the local network. (Such as a local router, or localhost if you are running bind)
Pedeleao 0 solutions 2 answers

I don´t know what you mean by "type ... into a terminal". What terminal? And your workarounds don't make any sense to me either:

  • I typed in "http://localhost.local/myfolder/myfile.php" and it failed to load the page, and I don´t know why it would, but even so, it added "www" in front of "localhost".
  • "resolv.conf" isn't a file that exists on my machine, and I don't know what you mean by change the server. I'm using an Apache server and it is already set to use my local network.

Modified by Pedeleao

Pedeleao 0 solutions 2 answers

Comment removed

Modified by Pedeleao

mcintyrem 0 solutions 1 answers

I am having a very similar problem to what this situation. My computer is running Windows 7 Enterprise (64-bit). I am using Firefox 3.6.15. Whenever I try to open one of of our intranet sites, all I get is a blank white page. It says done at the bottom, in the status bar. However, when I change the hostname to the IP address of the resource, it works perfectly fine. I know that this is a problem with Firefox, because these sites work in all of the other web browsers. I've tried uninstalling and reinstalling Firefox, including deleting the Mozilla folder in the AppData folder. Nothing seems to solve this problem.

ghostmachine 0 solutions 1 answers

Same problem for me I connect to the Internet via a corporate proxy, even if I specify the options that the site http://intranet should not use the proxy firefox 4 RC1 can not connect to my intranet

bobruce 0 solutions 1 answers

for me it is similar, but i'll give specific web links for my example: go to mlb.com (its major league baseball) that address used to work just like i typed above. now it takes 5 minutes (no exaggeration) to load! however if i press the "X" to stop the page load and then the reload icon it loads immediately... at first i thought i had a workaround by changing my bookmark link to WWW.mlb.com - that worked. but from the mlb web site there are sub links, that when clicked on give me the same massive delay, and if i attempt to enter a www prefix, i get a page error message. this never was a problem before. i am using winXp also.. if i click on the same site using a competitors browser, (IE) i have no problems... and no, i don't want to use IE as i have preferred FF since day 1 :)