X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Heading/Bold font comes up as gibberish

Posted

This has been an annoying problem with Firefox for the past month for me. The font of some heading or bold text on some websites comes out as gibberish, mostly a combination of foreign letters. Numbers end up displayed in a combination of MNOPQRSTUVW. Switching between character encoding does nothing but I am usually on Western (ISO-8859-1) or Unicode (UTF-8). It does not seem to be a system font issue on my PC because IE and Chrome is able to display fonts on the same pages correctly. I have tried to search for corrupt fonts on my PC and have come up with nothing. I have also tried disabling all my Firefox addons and plugins and it has made no difference. Would appreciate any inputs on this weird problem as I am running out of ideas.

Sample pic of the problem here: http://i50.tinypic.com/350jrr6.png

User Agent

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4

Chosen solution

This issue can be caused by the bitmap version of the Helvetica or Geneva font or another (bitmap) font that can't be displayed by Firefox in that font size. Firefox can't display that font in the specified size and displays gibberish instead. You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or find a True type version of that font that doesn't have the problem. ..... See http://kb.mozillazine.org/Issues_related_to_fonts#Gibberish

Read this answer in context 5

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Download Statusbar
0.9.6.8
true
Xmarks
3.6.14
true
foxmarks@kei.com
Forecastfox
0.9.10.2
true
{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
History Submenus
2.10
true
{7102aba3-045c-4ec2-b921-46d87636d84b}
QuickFox Notes
2.2N
true
amin.eft_bmnotes@gmail.com
Screenshot Pimp
2.1.6
true
{62ED169D-7F2E-449a-A88D-F4E6F153051F}
WebMail Notifier
2.4.3
true
{37fa1426-b82d-11db-8314-0800200c9a66}
DownloadHelper
4.7.3
true
FireFTP
1.0.9
true
Java Console
6.0.20
true
Modified Preferences
Name
Value
accessibility.blockautorefresh
true
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.last_vacuum
1274140953
print.print_printer
HP Photosmart C7200 series
print.printer_HP_Photosmart_C7200_series.print_bgcolor
false
print.printer_HP_Photosmart_C7200_series.print_bgimages
false
print.printer_HP_Photosmart_C7200_series.print_command
print.printer_HP_Photosmart_C7200_series.print_edge_bottom
0
print.printer_HP_Photosmart_C7200_series.print_edge_left
0
print.printer_HP_Photosmart_C7200_series.print_edge_right
0
print.printer_HP_Photosmart_C7200_series.print_edge_top
0
print.printer_HP_Photosmart_C7200_series.print_evenpages
true
print.printer_HP_Photosmart_C7200_series.print_footercenter
print.printer_HP_Photosmart_C7200_series.print_footerleft
&PT
print.printer_HP_Photosmart_C7200_series.print_footerright
&D
print.printer_HP_Photosmart_C7200_series.print_headercenter
print.printer_HP_Photosmart_C7200_series.print_headerleft
&T
print.printer_HP_Photosmart_C7200_series.print_headerright
&U
print.printer_HP_Photosmart_C7200_series.print_in_color
true
print.printer_HP_Photosmart_C7200_series.print_margin_bottom
0.5
print.printer_HP_Photosmart_C7200_series.print_margin_left
0.5
print.printer_HP_Photosmart_C7200_series.print_margin_right
0.5
print.printer_HP_Photosmart_C7200_series.print_margin_top
0.5
print.printer_HP_Photosmart_C7200_series.print_oddpages
true
print.printer_HP_Photosmart_C7200_series.print_orientation
0
print.printer_HP_Photosmart_C7200_series.print_pagedelay
500
print.printer_HP_Photosmart_C7200_series.print_paper_data
1
print.printer_HP_Photosmart_C7200_series.print_paper_height
11.00
print.printer_HP_Photosmart_C7200_series.print_paper_size_type
0
print.printer_HP_Photosmart_C7200_series.print_paper_size_unit
0
print.printer_HP_Photosmart_C7200_series.print_paper_width
8.50
print.printer_HP_Photosmart_C7200_series.print_reversed
false
print.printer_HP_Photosmart_C7200_series.print_scaling
1.00
print.printer_HP_Photosmart_C7200_series.print_shrink_to_fit
true
print.printer_HP_Photosmart_C7200_series.print_to_file
false
print.printer_HP_Photosmart_C7200_series.print_unwriteable_margin_bottom
0
print.printer_HP_Photosmart_C7200_series.print_unwriteable_margin_left
0
print.printer_HP_Photosmart_C7200_series.print_unwriteable_margin_right
0
print.printer_HP_Photosmart_C7200_series.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

This issue can be caused by the bitmap version of the Helvetica or Geneva font or another (bitmap) font that can't be displayed by Firefox in that font size. Firefox can't display that font in the specified size and displays gibberish instead. You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or find a True type version of that font that doesn't have the problem. ..... See http://kb.mozillazine.org/Issues_related_to_fonts#Gibberish

Question owner

Thank you for getting back to me so quick on this! It turns out it was a Helvetica font. Though it did not come up as a corrupt or infected file it was a very weird font file with a 1987 date and the file name not named properly. Must have installed it during one of my jobs without realizing. Quickly got rid of the thing and relieved to have my firefox displaying properly again. Thanks again!

pgtips 0 solutions 1 answers

Thanks for this info. This has resolved the same problem for me which I've put up with for a very long time!

jakobkramer 0 solutions 3 answers

Helpful Reply

I had the same problem on Windows 7 (64 bit). The culprit was the Helvetica font, but I had to do a bit of detective work to solve the problem, which is why I post here so anyone else in the same situation (hopefully) can find a solution.

I first went to the Windows/fonts directory and using administrator rights deleted all Helvetica fonts from the list. I had to do this 4-5 times since I had a lot of different versions of the font installed, and for some reason new versions seemed to appear, when I deleted the old (yes: they were not on the list before, but when I deleted other Helvetica versions, they appeared).

Anyway, I kept deleting until no new Helvetica fonts appeared. I then tried opening Firefox. Still headers with gibberish!

I then got the idea that perhaps some Hel(l)vetica versions did not appear in the Windows/Fonts directory (I hate that this directory for some reason is programmed to behave differently than other directories... as far as I can see, there is no "show hidden files" option).

What I did was opening up the command prompt (found under Start menu/All programs/accessories). I went to the Windows/Fonts directory (to step "up" in the directory hierarchy, type "cd..", to enter a directory, type "cd directoryname"). I looked through the directory ("dir /p") and found six Helvetica versions hiding in the corner! (to see only those, you can type "dir helve*", assuming you have no other fonts installed that begin with these five letters).

To make sure I didn't make some fatal damage, I made a new directory (called justincase) using Windows Explorer and then copied the files to that directory ("copy helve* C:\Windows\justincase"), and then deleted the Helvetica fonts from the Fonts directory ("del helve*").

Five of the six fonts deleted without problems, but the sixth had restricted access. I figured that it was this particular font that Firefox was trying to display (and did a horrible job doing so), so I restarted my computer and went straight to the Windows/Fonts directory (still using the Command Prompt). Now I could delete the final Helvetica font, and Firefox immediately displayed the headers correctly.

So - it seems that Helvetica is somewhat of a troublemaker, and even when you think you have killed it, it may still hide in the Fonts directory. Once you have deleted the font it may still appear as an option in different programs (such as Open Office or Photoshop), but only until you have restarted your computer.

Happy hunting!

Modified by jakobkramer

johman 0 solutions 1 answers

I'm having a similar problem with fonts. Some websites display in all bold font and the text is jumbled. I don't have any helvetica or geneva fonts installed. here's a pic. I've tried reducing the font size but it doesn't change anything. It was happening with FF 3.6. I uninstalled and reinstalled 4.0 and it's still a problem. Help is appreciated.

jakobkramer 0 solutions 3 answers

Hi Johman,

I took a look at the page on my version of Firefox (FF 4), and apart from the fact that I had to deactivate the Adblock Plus extension to be able to see the text boxes, everything works fine here.

I then compared your screenshot with what I see on my own screen, and it appears (as you also write yourself) that the problem on your computer is that the font is shown in bold, not normal. This causes all text lines to be a little longer and on some lines this appears to make the lines jump down a notch. If you look at the top menu bar the problem is the same. The last menu reads "About Zigzag", but on your screen the word "Zigzag" jumps to the next line because the bold font makes the whole menu line too long.

I then took a quick look at the coding of the page (only looking for what font is used). As far as I can see (but I may have missed something since I only took a quick look), the page uses the "Lucida Sans" font, and if that font is not present, it uses the "Lucida Grande" font. A possible explanation could be, that you have the lucida font installed, but only in a bold version, not a normal version. As far as I can see, the text on your screen IS Lucida, but only bold.

You could check whether you have Lucida installed in a normal (not bold) version or try to install it again.

I hope this is a bit of help :)

Modified by jakobkramer

voter 0 solutions 2 answers

I am not able to see any site with armenian letters properly with firefox 7. For instance www.google.am/preferences?hl=hy www.aravot.am www.news.am viparmenia.info

jakobkramer 0 solutions 3 answers

Hi Voter,

I tried visiting the sites, you linked to. I'm using Firefox 7.0.1, and it displays the Armenian text without problems (I have no Armenian fonts installed as far as I'm aware, but perhaps the pages use fonts Firefox downloads "on the go" from the web. Unfortunately, I don't know why your browser doesn't display the fonts.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

@voter

What is your Operating System?

Modern operating systems like Window Vista and Window 7 install a lot of fonts by default, but if you are on Windows XP then you most likely do not have fonts installed and you will have to install them yourself.

voter 0 solutions 2 answers

Seems it was just "Armenian AMU" font incompatible with new Firefox. The strange thing is, I have to change the default font in Options->Content and in Advanced for Western Fonts put under Serif some other font. So in principle it was nothing to do with Armenian fonts, but options of Firfox that somehow forcing to use Western Fonts on any Unicode web page and if one of fonts that Firefox uses is not fully Unicode compatible, one get's suares, cubes or other gabberish symbols.

I am wondering why I was not mentioning that problem in old version of Firefox.