Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not open without User Account Control asking if I will allow it to make changes on my computer.

  • 3 replies
  • 71 have this problem
  • 101 views
  • Last reply by landsailor

more options

Every time I click to open Firefox, I am prompted by Windows User Account Control asking if I want to allow the program to make changes to my hard drive. I just want to be able to open the internet without having to confirm this every time!

This happened

Every time Firefox opened

== I'm not entirely sure. It may have been when my computer downloaded the newest version of firefox.

Chosen solution

Check that you do not run Firefox as Administrator.

Right-click the Firefox desktop shortcut and choose "Properties".

In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.

You also need to check the Properties of the firefox.exe program in the Firefox program directory.

Read this answer in context 👍 6

All Replies (3)

more options

Chosen Solution

Check that you do not run Firefox as Administrator.

Right-click the Firefox desktop shortcut and choose "Properties".

In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.

You also need to check the Properties of the firefox.exe program in the Firefox program directory.

more options

Hello Abby.

Yes, it's well known that User Account Control is one of the greatest annoyiances known to mankind, but you can easily overcome that check by configuring Firefox to run in admin mode. Rightclick the shortcut (or the exe itself if you don't have a shortcut), go into Properties, then into the Compatibility tab and tick the "Run this program as an administrator". It should be fixed.

more options

Depends on the configuration of your machine's other settings. In my case, and with a Dell Vostro laptop, all I had to do was disable the "Digital Persona Extension" in Tools -> Add-ons -> Extensions section. There was no need to adjust anything else with UAC or the firefox.exe or its shortcut properties. :)