X
Tap here to go to the mobile version of the site.

Support Forum

Single word address bar searches resolve with bing search results, not google

Posted

I've installed all updates recently (win7/x64) apart from Windows Live Essentials.

In firefox (umm... 3.6.3), a single word search in the location bar, eg; "facebook", results in a bing page, not going to facebook.com, or showing google results like it used to.

Multi-word searches resolve with google.

I don't have any tool bars installed. Google is my default search engine. About:config keywordURL is set to google. "search helper extension" doesn't appear in add-ons, nor does zugo or bing bar. I've disabled all add-ons, restarted. Same result. I started in safe mode Same result.

I've removed bing from IE8, set google as default. There are no toolbars installed.

I've searched my programs list. Nothing mentioned appears, everything seems fine. I looked at recent updates, nothing related to "search". I've looked in program files/program files (x86) for Program Files\Microsoft\Search Enhancement Pack\ but no such folder exists. I searched regedit for "bing", few results, but nothing that seemed linked with FF.

Why is bing showing up? I don't want it, I didn't ask for it, and I can't get rid of it.

This happened

Every time Firefox opened

== not sure. Recently.

I've installed all updates recently (win7/x64) apart from Windows Live Essentials. In firefox (umm... 3.6.3), a single word search in the location bar, eg; "facebook", results in a bing page, not going to facebook.com, or showing google results like it used to. Multi-word searches resolve with google. I don't have any tool bars installed. Google is my default search engine. About:config keywordURL is set to google. "search helper extension" doesn't appear in add-ons, nor does zugo or bing bar. I've disabled all add-ons, restarted. Same result. I started in safe mode Same result. I've removed bing from IE8, set google as default. There are no toolbars installed. I've searched my programs list. Nothing mentioned appears, everything seems fine. I looked at recent updates, nothing related to "search". I've looked in program files/program files (x86) for Program Files\Microsoft\Search Enhancement Pack\ but no such folder exists. I searched regedit for "bing", few results, but nothing that seemed linked with FF. Why is bing showing up? I don't want it, I didn't ask for it, and I can't get rid of it. == This happened == Every time Firefox opened == not sure. Recently.

Additional System Details

Installed Plug-ins

  • -PDF-XChange Viewer Netscape Gecko Plugin
  • Shockwave Flash 9.0 r45
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • iTunes Detector Plug-in
  • Picasa plugin
  • 4.0.50524.0
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.2
true
AutoPagerize
0.4.4
false
autopagerize@relucks.org
BarTab
2.0
true
bartap@philikon.de
ColorZilla
2.0.2
false
{6AC85730-7D0F-4de0-B3FA-21142DD85326}
Download Statusbar
0.9.6.8
true
English (Australian) Dictionary
2.1.1
true
en-AU@dictionaries.addons.mozilla.org
Firebug
1.5.4
true
firebug@software.joehewitt.com
FireFTP
1.0.9
true
FoxyProxy Standard
2.19.1
false
foxyproxy@eric.h.jung
Glazoom (formerly known as Zoom It!)
0.4.1
false
zoomit@disruptive-innovations.com
Image Zoom
0.4.4
false
{1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
MeasureIt
0.4
true
{75CEEE46-9B64-46f8-94BF-54012DE155F0}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Personal Menu
4.3.2
false
CompactMenuCE@Merci.chao
Pixel Perfect
1.5.6
false
pixelperfectplugin@openhouseconcepts.com
Tiny Menu
2.0.2
true
Web Developer
1.1.8
true
Xmarks
3.6.14
true
foxmarks@kei.com
YSlow
2.0.7
true
yslow@yahoo-inc.com
zoomFox
0.8
false
{79fcaa13-5f29-4c33-aad7-6c48c175760a}
AutoPager
0.6.1.6
true
autopager@mozilla.org
Skype extension for Firefox
4.2.0.5198
false
Java Console
6.0.18
false
LastPass
1.68.2
true
support@lastpass.com
Screengrab
0.96.3
true
{02450954-cdd9-410f-b1da-db804e18c671}
PluginChecker
0.2
true
pluginchecker@dafizilla.sourceforge.net
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
3
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
google.co.nz
browser.startup.homepage_override.mstone
rv:1.9.2.3
browser.tabs.warnOnClose
false
extensions.lastAppVersion
3.6.3
font.minimum-size.x-western
10
keyword.URL
http://www.google.co.nz/search?q=
network.cookie.prefsMigrated
true
places.last_vacuum
1274078396
print.print_printer
Canon iP4200
print.printer_Canon_iP4200.print_bgcolor
false
print.printer_Canon_iP4200.print_bgimages
false
print.printer_Canon_iP4200.print_command
print.printer_Canon_iP4200.print_downloadfonts
false
print.printer_Canon_iP4200.print_edge_bottom
0
print.printer_Canon_iP4200.print_edge_left
0
print.printer_Canon_iP4200.print_edge_right
0
print.printer_Canon_iP4200.print_edge_top
0
print.printer_Canon_iP4200.print_evenpages
true
print.printer_Canon_iP4200.print_footercenter
print.printer_Canon_iP4200.print_footerleft
&PT
print.printer_Canon_iP4200.print_footerright
&D
print.printer_Canon_iP4200.print_headercenter
print.printer_Canon_iP4200.print_headerleft
&T
print.printer_Canon_iP4200.print_headerright
&U
print.printer_Canon_iP4200.print_in_color
true
print.printer_Canon_iP4200.print_margin_bottom
0.5
print.printer_Canon_iP4200.print_margin_left
0.5
print.printer_Canon_iP4200.print_margin_right
0.5
print.printer_Canon_iP4200.print_margin_top
0.5
print.printer_Canon_iP4200.print_oddpages
true
print.printer_Canon_iP4200.print_orientation
0
print.printer_Canon_iP4200.print_pagedelay
500
print.printer_Canon_iP4200.print_paper_data
9
print.printer_Canon_iP4200.print_paper_height
11.00
print.printer_Canon_iP4200.print_paper_size_type
0
print.printer_Canon_iP4200.print_paper_size_unit
1
print.printer_Canon_iP4200.print_paper_width
8.50
print.printer_Canon_iP4200.print_reversed
false
print.printer_Canon_iP4200.print_scaling
1.00
print.printer_Canon_iP4200.print_shrink_to_fit
true
print.printer_Canon_iP4200.print_to_file
false
print.printer_Canon_iP4200.print_unwriteable_margin_bottom
0
print.printer_Canon_iP4200.print_unwriteable_margin_left
0
print.printer_Canon_iP4200.print_unwriteable_margin_right
0
print.printer_Canon_iP4200.print_unwriteable_margin_top
0
print.printer_CutePDF_Writer.print_bgcolor
false
print.printer_CutePDF_Writer.print_bgimages
false
print.printer_CutePDF_Writer.print_command
print.printer_CutePDF_Writer.print_downloadfonts
false
print.printer_CutePDF_Writer.print_edge_bottom
0
print.printer_CutePDF_Writer.print_edge_left
0
print.printer_CutePDF_Writer.print_edge_right
0
print.printer_CutePDF_Writer.print_edge_top
0
print.printer_CutePDF_Writer.print_evenpages
true
print.printer_CutePDF_Writer.print_footercenter
print.printer_CutePDF_Writer.print_footerleft
&PT
print.printer_CutePDF_Writer.print_footerright
&D
print.printer_CutePDF_Writer.print_headercenter
print.printer_CutePDF_Writer.print_headerleft
&T
print.printer_CutePDF_Writer.print_headerright
&U
print.printer_CutePDF_Writer.print_in_color
true
print.printer_CutePDF_Writer.print_margin_bottom
0.5
print.printer_CutePDF_Writer.print_margin_left
0.5
print.printer_CutePDF_Writer.print_margin_right
0.5
print.printer_CutePDF_Writer.print_margin_top
0.5
print.printer_CutePDF_Writer.print_oddpages
true
print.printer_CutePDF_Writer.print_orientation
0
print.printer_CutePDF_Writer.print_pagedelay
500
print.printer_CutePDF_Writer.print_paper_data
9
print.printer_CutePDF_Writer.print_paper_height
11.00
print.printer_CutePDF_Writer.print_paper_size_type
0
print.printer_CutePDF_Writer.print_paper_size_unit
1
print.printer_CutePDF_Writer.print_paper_width
8.50
print.printer_CutePDF_Writer.print_reversed
false
print.printer_CutePDF_Writer.print_scaling
1.00
print.printer_CutePDF_Writer.print_shrink_to_fit
true
print.printer_CutePDF_Writer.print_to_file
false
print.printer_CutePDF_Writer.print_unwriteable_margin_bottom
0
print.printer_CutePDF_Writer.print_unwriteable_margin_left
0
print.printer_CutePDF_Writer.print_unwriteable_margin_right
0
print.printer_CutePDF_Writer.print_unwriteable_margin_top
0
privacy.cpd.formdata
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

Question owner

Same problem is happening on my install on Win 7 32 bit. Recent updates that were installed related to office, .net framework, and activex killbits, a security update to IE, security update for win 7.

I also get sent to bing when typing an address containing a local SMB hostname. (whether an option from the address bars autocomplete is selected or just the hostname typed alone)

My 64 bit desktop does NOT seem to have this problem. Same updates were installed by the desktop (apart from some being the x64 equivalents)

Copying my profile from the desktop does not solve the problem

Same problem is happening on my install on Win 7 32 bit. Recent updates that were installed related to office, .net framework, and activex killbits, a security update to IE, security update for win 7. I also get sent to bing when typing an address containing a local SMB hostname. (whether an option from the address bars autocomplete is selected or just the hostname typed alone) My 64 bit desktop does NOT seem to have this problem. Same updates were installed by the desktop (apart from some being the x64 equivalents) Copying my profile from the desktop does not solve the problem

Question owner

Same problem but I haven't installed any of the windows updates.

Same problem but I haven't installed any of the windows updates.

Question owner

exact same problem. single word entries are redirected to bing. new profile doesn't work. anyone got a solution?

exact same problem. single word entries are redirected to bing. new profile doesn't work. anyone got a solution?

Question owner

Same problem and I have installed the windows updates.

Same problem and I have installed the windows updates.
TXGuy 87 solutions 861 answers
See the following and try to find an answer there: https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=693508&forumId=1 https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=693948&forumId=1 https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=600837&forumId=1 https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=694323&forumId=1 https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=694288&forumId=1

Question owner

Hi TXGuy, thanks for your suggestions.

The only new one was uninstalling KB982381. Unfortunately, it hasn't done anything. Single words still end up as bing searches.

I might try uninstalling other updates, but I don't really want to do that.

Hi TXGuy, thanks for your suggestions. The only new one was uninstalling KB982381. Unfortunately, it hasn't done anything. Single words still end up as bing searches. I might try uninstalling other updates, but I don't really want to do that.

Question owner

i have the same problem, and its not only happening in FF. it also happens in opera. i dont have chrome on this pc, but i'm quite sure its also happening there.

my best bet is that m$ messed something up in registry.

damn you micrsoft

i have the same problem, and its not only happening in FF. it also happens in opera. i dont have chrome on this pc, but i'm quite sure its also happening there. my best bet is that m$ messed something up in registry. damn you micrsoft

Question owner

i also have the same problem too, i wanna destroy bing!

i also have the same problem too, i wanna destroy bing!

Question owner

i hate bing and do not want to use it!

i hate bing and do not want to use it!

Question owner

Same problem!

Same problem!
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers
See [[Removing the Search Helper Extension and Bing Bar]]

Question owner

@cor-el i tried b4 it doesn't work. btw iI dont have bing bar installed and no bing in Add-ons

@cor-el i tried b4 it doesn't work. btw iI dont have bing bar installed and no bing in Add-ons

Question owner

Hi cor-el,

If you read my original message, you'll see I don't have search helper or bing toolbar installed, but thanks for your suggestion.

Hi cor-el, If you read my original message, you'll see I don't have search helper or bing toolbar installed, but thanks for your suggestion.
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers
See http://kb.mozillazine.org/Location_Bar_search and http://kb.mozillazine.org/Keyword%2eURL (pref: '''keyword~46~URL''')

Question owner

Thanks cor-el,

Before you post more links, please read my original entry. You'll be able to see what I've already tried.

Thanks cor-el, Before you post more links, please read my original entry. You'll be able to see what I've already tried.

Question owner

@chrismoore

thanks for telling him, looks like bing or Microsoft downloaded something inside our computer

@chrismoore thanks for telling him, looks like bing or Microsoft downloaded something inside our computer

Question owner

I'm not able to fix this problem, I hate bing and for all single queries it results to search at bing. I've removed that

I'm not able to fix this problem, I hate bing and for all single queries it results to search at bing. I've removed that

Question owner

Check your "Connection-specific DNS Suffix Search List" (ipconfig /all from a command prompt). If there's an mshome.net in there, you're going to need to get rid of it. mshome.net is the default, but now it's redirecting to Bing. (Who approved that idea?)

Pull up your IPv4 properties for whatever interface you're using (under Control Panel\Network and Internet\Network Connections) and under Advanced select "Append these suffixes (in order)". Since it needs a suffix, hit add, and put in a dot. [See screenshot]

There's probably a better way to do this (i.e. not forcing it to use a dummy DNS suffix) but this is pretty foolproof.

Good luck!

Check your "Connection-specific DNS Suffix Search List" (ipconfig /all from a command prompt). If there's an mshome.net in there, you're going to need to get rid of it. mshome.net is the default, but now it's redirecting to Bing. (Who approved that idea?) Pull up your IPv4 properties for whatever interface you're using (under Control Panel\Network and Internet\Network Connections) and under Advanced select "Append these suffixes (in order)". Since it needs a suffix, hit add, and put in a dot. [See screenshot] There's probably a better way to do this (i.e. not forcing it to use a dummy DNS suffix) but this is pretty foolproof. Good luck!

Question owner

That fixed it for me.

But what I don't get is that my desktop (that uses ethernet to the router) does not need this, whereas my laptop (wireless) does...

That fixed it for me. But what I don't get is that my desktop (that uses ethernet to the router) does not need this, whereas my laptop (wireless) does...

Question owner

I posted this to another thread as well: I fixed this by editing the registry. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters and empty the "mshome.net" value from the ICSDomain key, then disable and re-enable your adapter. I hope that helps. I searched for other instances of "mshome.net" and "ICSDomain" in the registry and didn't find any so that should do the trick.

I posted this to another thread as well: I fixed this by editing the registry. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters and empty the "mshome.net" value from the ICSDomain key, then disable and re-enable your adapter. I hope that helps. I searched for other instances of "mshome.net" and "ICSDomain" in the registry and didn't find any so that should do the trick.