X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Address Bar Goes to Bing

Posted

When typing into the address bar everything goes to bing search now. I have done everything from changing keyword.url to starting in safe mode to completely uninstalling and reinstalling Firefox. Nothing works and it always goes back to a bing search whenever I type anything in.

Chosen solution

hijack firefox


solved by uninstalling this update. kb982381

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Google Update
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.18
true
Xmarks
3.6.14
true
foxmarks@kei.com
Adblock Plus
1.2
true
Screengrab
0.96.3
true
{02450954-cdd9-410f-b1da-db804e18c671}
Modified Preferences
Name
Value
browser.history_expire_days
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

Question owner

MS did install that add-on from the OS, but it can be disabled, removed, you can download search engines and use multiple ones all the time.. its so easy to select another from the drop down or install them from the addons site when you go to Manage Search Engines in the search bar.

Also just change your search engine in Firefox to what ever you want.. please do your homework and stop blaming everything on Firefox lots of the problems are 3rd party and extensions conflicting with Firefox. There are lots of KB articles and support here even may users seeking help here: http://forums.mozillazine.org/viewforum.php?f=49

Question owner

@cuz84d We've already tried uninstalling the update, and I've tried a few other things. The flushing the dns and everything seems to work even though bing still comes back every now and then. Does anyone have any idea on what scale this is happening? Because it seems to only be effecting a few people.

Question owner

Hello Anonymous namend "H", take this, WORK´s INSTANTLY! Install Firefox-AddOn "NoRedirect" (https://addons.mozilla.org/de/firefox/), then make a new regexp pattern "http://www.bing.com/search?" and ONLY click/check "dns error", not "allow" or "source".

Question owner

Hello everyone, Vu is right: www.bing.com is the same like www.mshome.net. It has nothing to do with the browser. Try it: Put mshome.net into the adressbar and you will get bing.com!!!! So you can do what Vu discribed here or took the firefox-addon "noredirect"! Best Didi

ekertz 0 solutions 2 answers

I was able to solve the Bing problem by going to "Tools", "Add-ons", "Extensions", then down to "Search Toolbar". I uninstalled the "Search Toolbar" and restarted Firefox. Problem solved! At least for now!

Trevorj4 0 solutions 1 answers

Helpful Reply

I had trouble finding this post answer but follow theses directions exactly and it will fix it...Type “about:config” in firefox address bar and type “keyword.url”. Right click and choose modify and type "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q="

Without ""

not my work i just put a note here cause its hard to find

risingPhoenix 0 solutions 1 answers

In the drop-down menu for Firefox I went to Tools > Add-ons and clicked "Uninstall" for "Microsoft .NET Framework Assistant". Then I clicked restart Firefox. When Firefox came up the problem was solved.

Gary 0 solutions 1 answers

I did this, too and it worked for a day. Then the problem returned. Then the addon reappeared and "uninstall" was gray. I could only "enable/disable." I "disabled", restarted FF but the problem was still there and the addon said it was disabled.

I checked other entries dealing with this same problem and someone named Tony suggested typing "about:config" (without quotes) in the URL bar. Accept the warning. In the Filter bar type "keyword" (without quotes). Right click on keyword.url, click reset. Close FF. My problem was solved ... for today, at least.

Microsoft is acting in an invasive, insipid manner. I am going MAC next computer.

mefelan 0 solutions 2 answers

If you have already uninstalled the Search Assistant and you are still having this problem, go to about:config and change the keyword.URL value to:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

mefelan 0 solutions 2 answers

The problem that bing has been added to the location bar and any address that can't be resolved automatically goes to a bing search. These people aren't idiots.

LowBrowser 0 solutions 1 answers

I have this same problem on a Mac. I tried the aboutconfig and keywordURL thing. Single OR multiple word entries into the URL window results in a Bing search. Is there a separate thread for Mac users? I'm prepared to changes browsers if this persists, simply out of principle. Microsoft should not be so underhanded in getting us to use their products!

genegr 0 solutions 1 answers

I captured with screen grabber the moment and could see the addresses of the sites that do redirection. Then I added them to my firewall. the problem with redirection is gone now for me. it is : search-goal.net and as the keyword "eetwbthmeis" Good luck

JohnMartoccio 0 solutions 1 answers

I have tried everything I can find pertaining to this:

1) Removing Update KB982381 2) Verify Search Engine isn't listed in both Firefox & IE (control panel) 3) Performed; About:config keyword.url fixes, and searched all of Firefox registry for bing (no entires - all reset to default)

I have spent many hours trying to fix this hijacking of Firefox 12 Location Bar.

Please email JohnM fastad.com if you are starting or are aware of a Class Action Suit I can join !