X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot clear cache - Offline storage button "Clear Now" does not work

Posted

I follow the steps for clearing cache: Tools>Options>Advanced>Network> Offline Storage>Clear Now. The "Clear Now" button does not work.

Additional System Details

Installed Plug-ins

  • -Garmin Communicator Plug-In 2.9.2.0
  • Office Plugin for Netscape Navigator
  • Coupons, Inc. Coupon Printer DLL
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Default Plug-in
  • Unity Player 2.6.1f3
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • NPWLPG
  • 6.0.11.847
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
BetterPrivacy
1.47.4
true
eMusic Toolbar
2.3.0.4
false
{9ee802e8-c931-47ab-b570-aa8f791598ca}
SearchPreview
4.3
true
Kodak EasyShare Gallery Companion
1.9
true
kodak-companion@mozilla.com
Microsoft .NET Framework Assistant
0.0.0
true
{20a82645-c095-46ed-80e3-08825760534b}
Yahoo! Toolbar
2.1.2.20100119091315
true
{635abd67-4fe9-1b23-4f01-e679fa7484c1}
Upromise TurboSaver
6.2.0.1281
true
FFToolbar@upromise
Modified Preferences
Name
Value
accessibility.blockautorefresh
true
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.yahoo.com/
browser.startup.homepage_override.mstone
rv:1.9.2.3
dom.disable_open_during_load
false
dom.storage.enabled
false
extensions.lastAppVersion
3.6.3
general.useragent.extra.betterprivacy
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
keyword.URL
http://search.yahoo.com/search?fr=ffds1&p=
network.cookie.prefsMigrated
true
places.last_vacuum
1271791006
print.print_printer
EPSON Stylus Photo R320 Series
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
false
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
privacy.cpd.cookies
false
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Do you still see entries on the about:cache page listed?

Make sure that you not run Firefox in Private Browsing - Browse the web without saving information about the sites you visit mode. In Private Browsing mode some menu items are disabled (grayed) and some features like visited links and others are disabled and not working. You are in Private Browsing mode if you see "Tools > Stop Private Browsing". See Private Browsing - Browse the web without saving information about the sites you visit and http://kb.mozillazine.org/Issues_related_to_Private_Browsing

Question owner

Thank you, but the button is not grayed and I do not have settings on private browsing.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You didn't answer whether you still see entries listed on the about:cache page after you have cleared the cache. You can open that page via the location bar like a website.

Question owner

I've cleared the cache from tools - clear recent history - everything - cache.

Reading : about:cache I found memory and disk cache device empty, but offline cache is not cleared.

I'm developing in html5 - manifest.

I was testing some scripts in html5. Now on some urls declared on my manifest files can't be loaded, instead i can see the offline url (sorry for my english).

I'm not in offline mode.

I note than in firefox offline cache is an different folder than cache.

I've erased the entire folder, now if i try to load the url the browser tells me i'm in offline browsing mode, but it isn't.

Question owner

ps: same configuration of kim.

Helpful Reply

I can not clear offline cache too. (firefox 3.6.8)

I can see offline cache entries in about:cache, but the "Clear Now" button in Tools>Options>Advanced>Network> Offline Storage does not work.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that you not run Firefox in Private Browsing - Browse the web without saving information about the sites you visit mode. In Private Browsing mode some menu items are disabled (grayed) and features like visited links and disabled and not available. You are in Private Browsing mode if you see "Tools > Stop Private Browsing", possibly grayed.

Question owner

I am not in Private Browsing mode, and the "clear now" button is not disabled, but just not work.

grandstaff 0 solutions 1 answers

Not sure if this is the same issue, but I was just having a similar issue. Firefox 3.6.13 was showing an out of date version of a page I was revising on a WordPress site.

I cleared all caches. About:cache showed 0 cache entries. I disabled all plugins and restarted the browser, but still saw an out of date version of the page.

Finally, I logged into the administration panel of the site and went back to the problematic page. It displayed correctly. I logged out and it still displayed correctly.

No idea what was causing this, but logging into the WordPress backend fixed it for some reason.

b.engelbrecht 0 solutions 1 answers
  • removed*

Modified by b.engelbrecht

Guinness2702 0 solutions 1 answers

I had the same problem, but fixed it.

Do you have the Web Developer toolbar plugin installed, with cache disabled? If you do, it appears that this also disables *emptying* the cache. Just re-enable the cache, hit the "clear now," and re-disable the cache :)