X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop Firefox from using the address bar as a google search field?

Posted

When I type a non URL phrase into the address bar, such as "big dog", it connects with Google search. I don't want to connect to Google without asking. Is there a way to stop this default behavior? Or at least change the default search engine?

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • Java(TM) Platform SE binary
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.0 r32
  • iTunes Detector Plug-in
  • Virtual Earth 3D 2.05080321002 plugin for Mozilla
  • Java Plug-in 1.6.0_12 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

asadotzler 0 solutions 3 answers

Helpful Reply

Search the web from the Address Bar has lots of information on this. If the steps here don't work for you or aren't clear enough, please visit that article.

  1.  In the Location bar, type about:config and press EnterReturn.
         * The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. 
  2. Search for the preference keyword.enabled.
  3. Double-click the keyword.enabled preference to toggle it between true and false.
         * false disables Internet Keyword searches.
         * true enables Internet Keyword searches.
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

See also http://kb.mozillazine.org/Location_Bar_search and http://kb.mozillazine.org/Keyword%2eURL (pref: keyword~46~URL)

Question owner

Every time I type anything on my pc Goggle pops up like its doing right now. Its driving me crazy. Pleasssssssssse help me make it stop. I can't take it any more.

Myrnaalive