X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

email links will not open in my Firefox browser

Posted

Hello, Using my Firefox web browser when I am in my emails. Inside the email body and there is a link to click on inside. The Firefox will not open the link page, it comes up as an error. However, if i right click and open in a new window. Firefox will then open the link and send me to that page.

I then decided to try IE and when I double click the link within the email body, it opens it up with no issues at all.

Firefox is my default browser.

This happened

Every time Firefox opened

== Two days ago

Additional System Details

Installed Plug-ins

  • -Version 1.1.2.0
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.0 r45
  • 3.0.50106.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

More Information

Morbus 134 solutions 2338 answers

Hello Kenn.

Be sure to read this:

http://support.mozilla.com/en-US/kb/Websites+look+wrong

Question owner

Hello,

I have tried numerous trouble shooting steps. I cannot find what is causing or blocking from the links in my emails to open to the website.

Here is an example of what it reads when I click on a link in an email. https://mail.go....er=ohh14rw8mbn4

Everything else works when I am using my Firefox but when I am inside my email and try to click on web addresses or links inside the emails. It will not open when I am using Firefox.

Morbus 134 solutions 2338 answers

You didn't really say what your email service provider was... Screenshots would be helpful too.

Question owner

I use Gmail. There are no screen shots to send to you. I was going to do this but when I click on a link inside an email to be redirected to a website. The page is blank and the tab reads https://mail.go....er=ohh14rw8mbn4

Unfortunately this is all I can pass along to you. I have been searching around some more and I just do not know what could be causing this. I have done a full scan of my computer in case I had a virus or some malware. I am fine there, no issues to be alarmed about.

Should I uninstall and then reinstall Firefox? This should solve the issue.

Morbus 134 solutions 2338 answers

Well, Kenn, that link is obviously truncated. You notice that "..." in the middle? That is not a valid link. Maybe that's what's confusing you?

Question owner

Hello,

This is a valid link.

https://support.mozilla.com/en-US/forum/1/676755#threadId677243

I get the same code once I click on the valid link in my emails. All the links in my emails are valid links. When I use IE I am not having this problem. When I go back and use Firefox. I cannot open the valid link. It brings up another page but the page is blank.

Hope this helps.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

See How to make web links open in Firefox by default and http://kb.mozillazine.org/Default_browser

Question owner

Hello,

I have checked all the above trouble shooting suggestions. I still am having the same problem.

I use Firefox as my default browser and have it checked off as per your last email. I am only having this problem in my emails. I cannot open url links in my emails anymore by double clicking on the mouse. I have to right click the mouse and choose open in a new window. It will then open that url link and take me to the website link.

If I try this by double clicking the url link, it takes me to a blank page with this "https://mail.go....er=ohh14rw8mbn4" at the top of the page in the tab.

Question owner

I have the same problem as Kenn.

Any link in my gmail opens a new tab (as is the default) but tries to load a URL like this:

https://mail.google.com/mail/?ui=2&view=bsp&ver=ohhl4rw8mbn4

and opens only a blank, white screen.

Though I am a novice, I too have tried most settings and updated all of my plugins assuming that that may be what triggered the change.

Any help is appreciated. Though I can right click and open the link in a new page or tab, I don't feel like relearning how I operate.

Thanks in advance for any help or insight!

Steven

Question owner

Me too. FF3.5.9 so i upgraded to 3.6.6. same thing. I'm also on Vista (Home Premium). Was the old Google 7.6 update fixing this? because it's not compatible with this version (tho it was on 3.5.9 and the problem followed me back to it when I downgraded before.)

If I turn on the tools/options/advanced/"warn me when websites try to redirect or reload the page", then it works provided I click on that damned "allow" button EVERYTIME! Not good for credit safelist viewing if I don't want to take forever. (Already getting sore fingers/hands from TE surfing.)

hopscotch 0 solutions 1 answers

Just upgraded to latest version of Firefox and now only get error messages when I click on a link from an email (Windows Mail, Vista) Firefox is default browser, nothing else has changed. Now I have to copy and paste a link. Firefox is the problem here. All other preferences haven't changed.

koehlerle 1 solutions 11 answers

My problem is the same as the ones above except that right clicking on the link doesn't do anything for me. When I click on the link the border of the page dims and brightens but no access to the linked page when Firefox is my default browser so I have to use IE as my default browser which my whole psychic/genetic makeup abhors. It seems that no one knows what is wrong or how to fix the problem. I tried the chat room but was never able to get through and not it is removed. Is there ANY way to get an answer/solution to this problem?

Modified by koehlerle

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Please start a new thread for your problem or question and provide troubleshooting information like your operating system and installed extensions and installed plugins.


(Locking)