Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Server Error Code when using Google Translate

  • 28 replies
  • 30 have this problem
  • 363 views
  • Last reply by cor-el

more options

Google Translation (embedded into a website) was working a few days ago but now, error code is received. (Error: The server could not complete your request. Try again later. ) Only happens when using Firefox. No problems with IE. Is this a problem with Google Translate or with Firefox? This is not only happening on my computer but several other people's as well.

This happened

Every time Firefox opened

== Not sure, within the last few days starting around May 12, 2010

All Replies (8)

more options

Hi all, I too have been struggling with this problem for over a week now. But today I downloaded and installed FF 3.6.3 again on top of my existing installation and it is now working. Is it working only for me or has Google or FF finally fixed where they messed up?

more options

It's working now. I'm thrilled...but curious...anybody have any idea what the original problem was?! - Mary

more options

It suddenly started working for me also without any updates, changes, etc. I do have to disable Flashblock for it to work though, just keep that in mind.

more options

I assume that it was as issue with Google and that Google fixed it. It now works for me too without making any changes like clearing cache or cookies.

more options

Mine is now working again also out of the blue. I didn't make any changes or anything. Apparently, Google fixed whatever the problem was.

more options

yes, my project also "magically" works again today in FF...

and the display issue in Chrome I had went away also.

magic on the Google end it seems.

more options

my website is www.answersforquestions.com. IE is working fine with "Translate this page feature" but not in Firefox. Hopefully, it will be fixed soon.

more options

No problems here with the Google Translate feature on http://www.answersforquestions.com/

Reload a web page and bypass the cache with:

  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

  1. 1
  2. 2