Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Get error msg: A copy of Firefox is already open. Only one copy of Firefox can be open at a time.


Get the following msg. when I try to open Firefox: " Close Firefox. A copy of Firefox is already open. Only one copy of Firefox can be open at a time." No other copy is installed or running.

This happened

Every time Firefox opened

== After I reloaded a new copy of OS X. Previous system folder was archived.

Additional System Details

Installed Plug-ins



  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/523.12 (KHTML, like Gecko) Version/3.0.4 Safari/523.12

More Information

Checked all disks and there are no other copies of Firefox installed. There is only one profile in the Applications Support folder in the Library folder.

Morbus 134 solutions 2338 answers

Hello Vernon.

That may have happened because Firefox hanged or is taking to long to close. Access your task manager and terminate Firefox's application. That will loose you no data and will allow you to run Firefox again.

It's probable that it's just taking a bit longer to close, though, so waiting a bit will probably fix the issue (like a few seconds, so this for future reference).

  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Try to create a new profile.

See: http://kb.mozillazine.org/Recovering_a_missing_profile http://kb.mozillazine.org/Profile_in_use

Question owner

I have the same problem. Running OSX 10.6.3

I have restarted, started in safe mode, fixed permissions, reinstalled FireFox. All the standard stuff.

FireFox does not show in System Monitor.

This is not a problem of FireFox taking too long to close - unless you consider three days and several restarts too long.

Clearly the answer was proposed by someone without Mac OSX experience.


Question owner

I have the same problem, I am able to find it still running by using ps in terminal but even a kill -9 wont stop the process. A reboot will fix it but obviously thats not a very good solution.

bash# ps -ef | grep firefox

 501  1885   116   0   0:00.00 ??         0:00.00 (firefox-bin)
 501  1953  1946   0   0:00.00 ttys000    0:00.00 grep firefox
Philipnb 0 solutions 2 answers

Dear Vernon - this is not a matter of waiting. I believe you are on a PC. On my Mac running the current OSX and the current FF, we will get a message saying that a copy of FF is already open and that 2 copies cannot be open at the same time. It does not appear in the Mac Activty Monitor (windose task manager) and so cannot be force quit - it requires restarting the system. Essentially FF makes using the computer impossible.

Morbus 134 solutions 2338 answers

Can you please try it in a new (temporary) Firefox profile and see if the issue is still present? See this article to know how to create a new Firefox profile. Please report back the results.

edwinw 0 solutions 1 answers

Are you sure you tried killing the right process id? “ps -ef” is a Linux/SVR4-ism and the first column is the parent process id, not the process id. On OS X and other BSD Unix system, “ps -ax” is the way to go and gives the process id in the first column.

oliverboyd 0 solutions 1 answers

I was able to use 'kill -9 PID' (PID - Process ID - first column if you use the 'top' command in terminal) to kill the firefox-bin process and then restart firefox successfully.

madakkadam 0 solutions 1 answers

Helpful Reply

You can fix it on a Mac by removing the old left over folders in your Library folder: There are folders "Firefox" and folder "Monzilla" sitting in your Library/Application folder. Trash them and reinstall Firefox and it will work.

Aldred 0 solutions 1 answers

Maddakadam's advice is what finally worked for me. thanks.

seinfeldmozilla 0 solutions 2 answers

Cor-el's second link helped me. I used FileXaminer by Gdeon softworks to find and delete the invisible .parentlock file from my firefox profile. That did the trick.

DJBigNUT 0 solutions 1 answers

I am experiencing this issue quite frequently. I work at a school and we have approximately 150 Mac clients running Snow Leopard, from a Snow Leopard server. Many of the students are experiencing this issue on their individual server accounts, and I have found a solution by simply going into ~/Library/Application Support/Firefox/ and deleting "Profiles.ini". This causes FireFox to reset, and everything is back up and working. I have not found the EXACT cause of this, however this is something I cannot deal with on a regular basis. Do we know why this is occuring or how to prevent it?

Randzman 0 solutions 3 answers

SECOND THAT - Maddakadam's advice is what finally worked for me. (AS WELL)

But the only reason I had this problem was because I got a message saying "This is not the latest version of FF, update..." so I did... and that was bad because my 5YO PB G4 can't run the newest FF. *** SO WHY DOES FF TELL ME TO UPGRADE? ***

Once I did, trouble all the way, my Mac crashed so bad I had to take it to the shop... easy fix but just the same it's horrible way for an app to act... why propose an upgrade when you don't have the system and my Mac CAN'T! run the system! WhY NOt just tell me that I can upgrade if I get the following OS!. INFORM ME!

howmanyds 0 solutions 1 answers

Helpful Reply

I got this message after trying to copy my profile folder over to a new computer

This worked for me: make sure hidden files can be seen go to (user)/Library/Application Support/Firefox find profiles.ini open it with textedit and make sure the default profile is the same folder you have under Firefox/Profiles good luck!

svbv 0 solutions 1 answers

i'm running mac osx 10.6.8. i got the same message upon attempting to invoke firefox. i discovered that there was a zombie executable still running of firefox which wouldn't display anything, yet had a PID. there is clearly some kind of bug keeping FF open, but a workaround "fix" i used was-

  1. open the terminal app
  2. do a ps -ax
  3. locate the firefox zombie, on my box, it was-
  4. 8030 ?? 0:43.44 /Applications/Firefox 4 Beta/Firefox 4.0b7.app/Contents/MacOS/firefox -psn_0_2
  5. identify its process ID (PID)
  6. do a kill -9 PID, which in this case was-
  7. kill -9 8030
  8. re-invoke firefox

this works. my take is that there is some form of garbage collection bug that allows a FF to stay open as a zombie in background, disabling you from invoking it.

i'm wondering if this is potentially some form of virus that has infected FF on macs? this was the first time my mac/ firefox has done this, ever....

anyone else have this paranoid hunch?

best regards, svbv-dan

Funambule 0 solutions 2 answers

I got the message after deleting the Mozilla and Firefox folders located in Applications Support folder, I have already tried all the possibilities posted but none is working. Even if I show the hidden files, Terminal is not able to find .parentlock neither in the ps -ax command or Activity Monitor show any trace of FF.

Any other idea that can help? Thanks!

Rio50 1 solutions 8 answers

My issue is if I have Firefox already open, and I go to Microsoft Outlook and click on any email that has a html link in it, the problem being that nothing happens when I click on it unless I close the already opened Firefox browser.

stevanikof 0 solutions 1 answers

Before you start blowing away your profile (which is a real pain if you have lots of preferences/bookmarks, etc. to recover), just check in case you have been left with a leftover "lock" file. To check, open a terminal and change directory to your firefox account data,

   cd Library/Application Support/Firefox/Profiles

Then remove any leftover lock files (be careful with the command, type it exactly, don't forget the "." character)

   rm */.parentlock

try staring firefox again

Rio50 1 solutions 8 answers

I forgot to come back here and say that I indeed found a solution to this.

1. Launch My Computer or Windows Explorer. 2. Choose menu 'Tools' -> 'Folder Options' 3. Click the 'File Types' tab. 4. Scroll down to find 'URL:HyperText Transfer Protocol' (under the File Types column) and make sure it's highlighted. 5. Click the 'Advanced' button. 6. In the 'Actions' box make sure that 'open' is highlighted (click on it if necessary) 7. Click the 'Edit' button. 8. Uncheck 'Use DDE', click the Browse button and browse to Firefox.exe on your system, and click OK. [Updated for clarification, sorry about the earlier omission.] If you get a "file not found" message, browse to Firefox.exe and click OK. 9. The path to Firefox.exe should now appear in the 'Application used to perform this action' box. 10. Go to that 'Application used to perform this action' box, and add '-url "%1"' at the end, without the single quotes, so that it reads e.g. (on my computer at least) "C:\Program Files\Mozilla Firefox\firefox.exe" -url "%1" - with the double quotes! 10. Click OK again. 11. Repeat the process with the file type 'URL:HyperText Transfer Protocol with Privacy'