X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

TypeError: Components.classes[cid] is undefined

Posted

TypeError: Components.classes[cid] is undefined

URL of affected sites

http:// google.ru

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Shockwave Flash 10.0 r45
  • 2.0.31005.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Java Plug-in 1.6.0_13 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

TypeError: Components.classes[cid] is undefined

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

The error "TypeError: Components.classes[cid] is undefined" is probably caused by an extension, maybe XPL Link scanner.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Safe mode start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")

Question owner

i also have the same problem.....


"TypeError: Components.classes[cid] is undefined"

this is the error message.....

Question owner

In my case, I disabled the RealPlayer Browser Record Plugin.

midori123 0 solutions 1 answers

enlevez l'add-one BuiObab si vous l'avez moi sa a fonctionner remove the add-one BuiObab me if you run Entfernen Sie das Add-on BuiObab mich, wenn Sie laufen rimuovere l'add-one mi BuiObab se si esegue あなたは、saを実行する場合、アドインを一BuiObabを私削除 удалить адд-оне BuiObab мне, если вы запустите verwijderen van de add-one BuiObab me als je

harry.green 0 solutions 4 answers

In my case, it was AVG Safe Search.

Particularly annoying because this was certainly disabled when I installed b9 but I notice it is showing as enabled (by itself, not by me) on both of my machines.

Why does this extension not have a "remove" button?

Why does firefox *allow* AVG to install uninvited extensions, enable them without asking ? Can't firefox blacklist extensions that do this and prevent them from being installed at all ?

mf_417 0 solutions 1 answers

10 months ago I wrote an extension for ff3 and it wotrks fine, but now in ff4 I get this error.

how should I fix my extension?

my extension uses XPCom

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

A forum better suited to ask such questions is this mozillaZine forum:

You need to register on the MozillaZine forum site in order to post at that forum.

Wolfespepe 0 solutions 2 answers

I just disabled the Crawler Toolbar for a while and the Problem went away

mlbrichard 0 solutions 1 answers

in my case, windows xp, firefox 4.0 the offending add-on is ip changer 2.0 by iprivacytools.com

indifox 0 solutions 1 answers

In my case, disabling the Esnips Downloader Extension solved the problem.

What a rogue extension! I had been getting this error from the last one month or so but I never tried to single out the offending extension by using the safe mode option due to laziness. But it was only today that I decided to isolate the problem if it was due to some addon, and succeeded. I never wanted to install it from the very beginning but esnips.com would not let me download anything from their site without installing the Esnips Downloader.

God Father 0 solutions 1 answers

I fixed this problem by disabling Fileserve Manager ver 1.0 You can do that by going to : Addon > Extensions > Fileserve manager (Click Disable) restart and your free...

hanvord 0 solutions 1 answers

In my case, I disabled the “Youdao Word Capturer For Firefox”.

taeddy 0 solutions 6 answers

It was AVG safe search for me as well.

The Beerslayer 0 solutions 2 answers

Helpful Reply

On my laptop, the culprit was "OneClick YouTube Downloader", version 1.0.6. I believe it came with Orbit Downloader, a standalone app. Once I disabled this addon, the error went away.

ArthurFirefoxThunderbird 0 solutions 1 answers

Regarding "TypeError:Components.classes[cid] is undefined" on Firefox 4 and 5, I went into Safe Mode and disabled Google Update 1.3.21.57. Then I went back into regular mode and Firefox opened without any problems. There is a recent online headline, "After Six Years, Google Drops Support for Toolbar on Firefox." I hope this information helps some of you.

zhenyuan100 0 solutions 1 answers

Yes ! I disable the "YouDao" plug , it work !! thank you !!

zscomyj 0 solutions 1 answers

I have solved this problem。 I disabled the extension called youdao world capturer

yili16438 0 solutions 1 answers

I've solved my problem,thank you!

jseger9000 0 solutions 1 answers

Disabling the OneClick YouTube Downloader 1.0.7 fixed it for me. I miss the GetIt button though...

brangane 0 solutions 1 answers

After weeks of going round in circles & being told by Talktalk that it was a Microsoft problem, I now realise that it is because certain things are NOT COMPATIBLE i.e. they are competitive & don't want to support each other ! My problem turned out to be that I would prefer a Google toolbar as I'm in my 80s, not a youngster so do not want the AOL toolbar. Firefox does not want to support Google, or vice versa, so they make life difficult for you till you lose Google toolbar & Bingo ! no more TypeError etc etc. Now I go STRAIGHT to my webmail page or website link !!! Go to the Add-ons & plugins page & see what is not 'compatible' & THAT'S your culprit !

Modified by brangane