X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

TypeError: Components.classes[cid] is undefined

Posted

TypeError: Components.classes[cid] is undefined

URL of affected sites

http:// google.ru

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Shockwave Flash 10.0 r45
  • 2.0.31005.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Java Plug-in 1.6.0_13 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

TypeError: Components.classes[cid] is undefined

Edi 0 solutions 1 answers

Disabling the "OneClick YouTube Downloader 1.0.7" fixed it for me too. Tks "jseger9000"

versitek 0 solutions 1 answers

cid refers to the user ID for conduit toolbar publishers. Somehow the latest update is not compatible with the Toolbars that are created by Conduit. Disable your toolbars and see if this message still appears.

btos 0 solutions 2 answers

FF 10 Update had a Microsoft.Net add-on/ plug-in compatibility issue. I was prompted to search for a newer .Net version... I think therein was the problem. I clicked YES. After the search found what was described as an upgrade to the extension of the .Net framework, I was prompted to WAIT while it installed. I waited for an HOUR (not my idea of time well spent). The upgrade animation was still spinning when I closed and loaded FF 10 and get the infernal error message every time I open a new window or session! I tried system restore and FF didn't even work from the previous restore point. Now my patience is tested with a bunch of error messages with each session or new page. Too much time on this already. Maybe uninstall and use Chrome. Never heard of safe mode. Loathe to waste more time on it. Uninstall or fix? That is the question.

Modified by btos

tomaschke 0 solutions 1 answers

I went to Add Remove Programs and uninstalled the Orbit Downloader and I am no longer receiving the TypeError: Components.classes[cid] is undefined message.

ferry2 0 solutions 1 answers

Disabling the "OneClick YouTube Downloader" fixed it for me too.

lyte_17 0 solutions 3 answers

I solved this problem by deleting the file "{35379F86-8CCB-4724-AE33-4278DE266C70}" on the "extension" folder located at the backup folder of the history and bookmarks of mozilla.

pirateDan 0 solutions 3 answers

Hi, I just switched to FF11 from 3.6 and now I'm getting the TypeError: Components.classes[cid] message every time FF starts up. I've tried some of the suggestions here, but even after turning off all my extensions, it still display the error message. It, however, works OK when in safe mode. Will appreciate a fix on this as the message is somewhat annoying.

pirateDan 0 solutions 3 answers

I tried using the solution posted by lyte_17 and it seemed to have worked with no other side effects...so far.

Here's the solution: Deleting the file "{35379F86-8CCB-4724-AE33-4278DE266C70}" on the "extension" folder located at the backup folder of the history and bookmarks of mozilla.

Thanks, lyte_17

I wonder what this file was for, or if by deleting the file, it might put my browser at risk for something? If someone can shed some light, it will be appreciated.

Modified by pirateDan

pirateDan 0 solutions 3 answers

Just found out that the file "{35379F86-8CCB-4724-AE33-4278DE266C70}" is for the Orbit Downloader, which by deleting the file, it got rid of the downloader extension and its function. I then reinstall Orbit Downloader, and had to manually enable the function. Everything works now and no more error message on start-up.

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi pirateDan, for future reference, the Help > Troubleshooting Information page is the best resource I've found for determining which folder names correspond to which Extensions.

lyte_17 0 solutions 3 answers

So that's what it's for haha. Thank you for shedding light on that pirateDan.

Snaglet 0 solutions 1 answers

Mine was fixed by disabling Avanquest safe search...In my extensions.

Modified by Snaglet

julian.pilbrow 0 solutions 1 answers

"ERROR6: TypeError: Components.classes[cid] is undefined"

I get this error when trying to run my IVONA txt to voice reader extension in firefox.

don't have youtube downloader..

Any fix for it?