Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't save as PDF from Firefox any more

  • 11 replies
  • 142 have this problem
  • 3706 views
  • Last reply by gdasko

more options

I can't convert pages to PDF any more. Not sure if this happened when I upgraded Firefox or when, but there is no menu option to convert to PDF. I use the Adobe CS3 suites and Firefox 3.5.9.

This happened

Every time Firefox opened

== can't pinpoint it - it used to work

All Replies (11)

more options

Same thing on my MAC. Started after the latest upgrade.

more options

same problem on my mac

more options

When is someone going to respond? I have to use IE for occasions when I know I'm going to need a PDF of the screen and that just isn't a good solution.

more options

Same problem w W7(64). It works w IE

more options

Still can't create a PDF from Firefox page. I found an add-on here, but the reviews are few and bad.

https://addons.mozilla.org/en-US/firefox/addon/636/

I can't believe this feature has been lost - it used to work fine. It's a deal-breaker for me. This is why I hate those pressure tactics to upgrade the browser that Firefox does. I caved to it and lost functionality.

more options

"pressure tactics" ??

Automatic installation of security updates is a feature that you can turn off, if you so wish.

more options

Too late now. I can't go back. Firefox, you're not my love any more!

more options

i have the same problem

more options

Have not been to create pdfs and now I get an error message saying that it can not be created and probably does not exist. Then I go to Safari and the very same pdf file that Firefox told does not exist does exist in Safari.

Can not print from Firefox now, also.

more options

I figured it out! I am going to assume you have installed the new Adobe Reader X and that's what's causing the problem. It's NOT Firefox.

Open the Adobe Reader and go to Edit on the top menu. Select Preferences. Click General on the left navigation. Uncheck the box: Enable Protected Mode at Startup Close the document or the reader if no document is open and reopen it. You should see in the General section that the Protected Mode has been disabled because the only option now is to re-enable it.

I did this and am now able to save PDFs through Firefox.

I can only assume that Adobe enabled the protected mode by default to stop the exploits in the Acrobat vulnerabilities because they assume that most people don't know how to protect themselves - and probably rightly so.

Hope this helps!

more options

I went and opened an old pdf file from my hard drive, went to "edit" then to "preferences" select "internet" and unchek the "Display in Read Mode by default" square, then click ok. Now i can save with firefox.