Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why FF always alert "would you like to save button.js"?

more options

Issue

Firefox is having problems with certain web sites

Description

Why FF always alerts me that "would you like to save button.js" when I visit some sites like http://techcrunch.com/?

URL of affected sites

http://techcrunch.com/

Firefox version

3.5.9

Operating system

Windows XP

User Agent

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 GTB7.0 ( .NET CLR 3.5.30729)

Plugins installed

  • -Shockwave Flash 10.0 r45
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 1.9.0009.1
  • Google Update
  • 3.0.50106.0
  • Google Updater pluginhttp://pack.google.com/
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Chosen solution

zhaiduo, The header information you posted doesn't show the content type (MIME type) of the button.js file.

If the problem no longer appears on your Windows 7 machine but still exists on the Windows XP computer, clear the cache in Firefox on the Windows XP computer, then try again. See How to clear the Firefox cache.

If the problem persists you could close Firefox and then rename the mimeTypes.rdf file in the Firefox profile folder to XmimeTypes.rdf This will generate a new mimeTypes.rdf when you reopen Firefox and that reset all Firefox download actions. Make sure you rename mimeTypes.rdf in the Firefox profile folder and not the one in the Firefox program folder. See the Profiles - Where Firefox stores your bookmarks, passwords and other user data article for help finding the profile folder.

Read this answer in context 👍 0

All Replies (15)

more options

I have a sanp


more options

does this happen in Firefox 3.6.3?

more options

My version is 3.5.9

more options

Well the 1st thing to check is the add-ons you have installed.

Go to: Tools > Add-ons > Extensions

Tell us what you have there.

2nd, you can try Firefox Troubleshoot Firefox issues using Safe Mode. It will disable all addons. You don't need to tick any of the checkboxes, just click the "Continue in Safe Mode" button.

Test to see if the problem occurs in this mode. If it doesn't, one of your addons is to blame.

XP Instructions: Click on the Start button and find:

Click on the Firefox (Safe Mode) choice.

Then, on this box, click Continue in Safe Mode button only:


more options

I disable all add-ons, but still in trouble

more options

This is a snap of all my add-ons.

more options

Are you clicking on a particular link or image (button) on http://techcrunch.com/ when you see the Firefox "Opening" dialog (minimal "save-ony" dialog) that is asking you to save the button.js file?

Do you have .js (JavaScript) files set to open from your hard drive with an associated application? (I don't ... .js files are unassociated on my Windows XP system).

Do you have an action set up in the Firefox Applications panel - Set how Firefox handles different types of files for any content types that refer to JScript or JavaScript?

Related bug: Bug 369431 - Firefox handling of preferred apps is broken (see comment 4)

You have the "Live HTTP Headers" extension in your list of add-ons. Was wondering, can you determine what's the content type of the button.js file that Firefox is asking you to save?

I only remember seeing the minimal "save only" dialog in recent Firefox versions downloading executable files, for example, this sample exe file.

Note: The above sample exe file is from http://entropymine.com/jason/testbed/mime/ MIME type: application/octet-stream (data looks like Windows executable) ... which is linked from this bug report.

more options

I just open some websites like techcrunch, never click anthing, then a dialog lets me download the button.js from api.tweetmeme.com. And I have never set up an action in the Firefox Options window. My system is Win7. And the same problem in the other PC with winXP.

But the most of interesting thing is this phenomenon never happened again in my win7 after I just check techcrunch a few miniutes ago. I will test it on winXP at tomorrow. Or I will test again later.

more options

Do a malware check with a few malware scan programs. You need to use all programs because each detects different malware. Make sure that you update each program to get the latest version of the database.

http://www.malwarebytes.org/mbam.php - Malwarebytes' Anti-Malware http://www.superantispyware.com/ - SuperAntispyware http://www.safer-networking.org/en/index.html - Spybot Search & Destroy http://www.lavasoft.com/products/ad_aware_free.php - Ad-Aware Free http://www.microsoft.com/windows/products/winfamily/defender/default.mspx - Windows Defender: Home Page .......... See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

more options

To AliceWyman:

oh, no, button.js dialog is still on winXP. This is the http header of button.js, actually there is two kinds of header. (firefox version: 3.6.3)

Header one:

http://api.tweetmeme.com/button.js?url=http://techcrunch.com/2010/05/20/twitter-app-store/&style=compact&source=TechCrunch&service=bit.ly&service_api=techcrunch:R_0381170e330c42dda299f92709e0ef5c

GET /button.js?url=http://techcrunch.com/2010/05/20/twitter-app-store/&style=compact&source=TechCrunch&service=bit.ly&service_api=techcrunch:R_0381170e330c42dda299f92709e0ef5c HTTP/1.1 Host: api.tweetmeme.com User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 ( .NET CLR 3.5.30729) Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Accept-Language: en-us,en;q=0.5 Accept-Encoding: gzip,deflate Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7 Keep-Alive: 115 Connection: keep-alive Referer: http://techcrunch.com/

HTTP/1.1 200 OK Server: nginx/0.7.65 Date: Fri, 21 May 2010 01:59:15 GMT Content-Type: text/html Transfer-Encoding: chunked Connection: close P3P: CP="CAO PSA" X-url-Lookup: OrAdd (7) X-Served-By: pipet Content-Encoding: gzip

Header two:

http://api.tweetmeme.com/button.js?url=http://techcrunch.com/2010/05/20/chinict-livestream-on-techcrunch/&style=compact&source=TechCrunch&service=bit.ly&service_api=techcrunch:R_0381170e330c42dda299f92709e0ef5c

GET /button.js?url=http://techcrunch.com/2010/05/20/chinict-livestream-on-techcrunch/&style=compact&source=TechCrunch&service=bit.ly&service_api=techcrunch:R_0381170e330c42dda299f92709e0ef5c HTTP/1.1 Host: api.tweetmeme.com User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 ( .NET CLR 3.5.30729) Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Accept-Language: en-us,en;q=0.5 Accept-Encoding: gzip,deflate Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7 Keep-Alive: 115 Connection: keep-alive Referer: http://techcrunch.com/

HTTP/0.9 200 OK



To cor-el: I use Microsoft Security Essentials, and think it is enough to help to check malware.

more options

Chosen Solution

zhaiduo, The header information you posted doesn't show the content type (MIME type) of the button.js file.

If the problem no longer appears on your Windows 7 machine but still exists on the Windows XP computer, clear the cache in Firefox on the Windows XP computer, then try again. See How to clear the Firefox cache.

If the problem persists you could close Firefox and then rename the mimeTypes.rdf file in the Firefox profile folder to XmimeTypes.rdf This will generate a new mimeTypes.rdf when you reopen Firefox and that reset all Firefox download actions. Make sure you rename mimeTypes.rdf in the Firefox profile folder and not the one in the Firefox program folder. See the Profiles - Where Firefox stores your bookmarks, passwords and other user data article for help finding the profile folder.

more options
more options

TO AliceWyman,

It works when I rename mimeTypes.rdf. Thanks very much~!

more options

Hey, that's great!

I'll mark this topic solved.