Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem setting "Never Remember History"

  • 2 replies
  • 163 have this problem
  • 8 views
  • Last reply by GraceG

more options

I have been trying to change my privacy setting to Never Remember History, but each time I set it, and I check it again, the setting is back to the "use custom setting for history." How do I change it to Never Remember History and make the change stick.

All Replies (2)

more options

Firefox shows the "(Never) Remember history" setting if all the history and cookie setting are the default. If at least one change is made to the default setting then "Use custom settings for history" will stay selected.

The choice "Use custom settings for history" will stay selected if at least one setting is not the default to make you aware that you made changes. --- You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"

See Private Browsing - Use Firefox without saving history

more options

The choice "Use custom settings for history" will stay selected if at least one setting is not the default to make you aware that you made changes. --- You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"

I want "use customer settings for history" to stay selected, but I don't understand what you mean by "if at least one setting is not the default to make you aware that you made changes" But anyway I'm on OS/X so there is no Tools Options, instead there is "Firefox Preferences".