Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cox / yahoo - User Name keeps changing. The fix I read does not work for me in 2024. Please, please help.

  • 23 replies
  • 2 have this problem
  • 18 views
  • Last reply by david

more options

""Description: COX Server Name: smtp.mail.yahoo.com Port: 465 Connection Security: SSL/TLS Authentication method: OAuth2 User Name: your user name, duh - Mine keeps changing the user name to the last name I put into any of my 6 accounts. The only way it will send mail is if the correct user name is in the correct account (obviously). Why is it changing constantly? click OK""

I've read the "fixes" from 2023 and they do not work for me. I tried changing the DESCRIPTION to blank, didn't work. Changed them to the corresponding e-mail for the account. Didn't work. Changed it to "SMTP" with the corresponding e-mail. Didn't work.

It keeps changing the last one I edit to the one I edited before it. It's driving me crazy. Won't send mail unless the User Name is correct (obv.)

Whole mess started when forced to switch from Cox to Yahoo recently. Seems to be working other than TB changing the name as soon as I type in the next one in the next email address and then it not working until I change the User Name back to the proper e-mail address of the 6 accounts.

""Description: COX Server Name: smtp.mail.yahoo.com Port: 465 Connection Security: SSL/TLS Authentication method: OAuth2 User Name: your user name, duh -''' Mine keeps changing the user name to the last name I put into any of my 6 accounts. The only way it will send mail is if the correct user name is in the correct account (obviously). Why is it changing constantly?''' click OK"" I've read the "fixes" from 2023 and they do not work for me. I tried changing the DESCRIPTION to blank, didn't work. Changed them to the corresponding e-mail for the account. Didn't work. Changed it to "SMTP" with the corresponding e-mail. Didn't work. It keeps changing the last one I edit to the one I edited before it. It's driving me crazy. Won't send mail unless the User Name is correct (obv.) Whole mess started when forced to switch from Cox to Yahoo recently. Seems to be working other than TB changing the name as soon as I type in the next one in the next email address and then it not working until I change the User Name back to the proper e-mail address of the 6 accounts.

Modified by Wayne Mery

All Replies (20)

more options

From your description, it seems you may have more than one account sharing the same SMTP server settings. I suggest this: - if there are six accounts, verify that there are six SMTP server settings. - for each one, place the email address in Description field for identification only. - for each one, go to account pane and verify the Outgoing server (bottom line) shows the email address of the account. Since each SMTP server has unique identification, this should confirm the proper connection,

Helpful?

more options

Here are screenshots. I don't know what I'm missing!?

I'm using Abc@cox.net as an example since I get enough spam mail as it is - don't want my e-mail out there even more, obv.

This last attempt, I tried naming each account a different name, so I chose "SMTP 1" "SMTP 2" etc.

These 4 screenshots should show what I'm doing wrong, if anything.

Helpful?

more options

Well, the key is the info that you aren't sharing (and I respect your decision on that), but the screenshot listing the different SMTP servers is puzzling and may be a key. It shows several POP accounts as SMTP servers. Do you have each SMTP server edited with the appropriate SMTP settings for Yahoo with the proper email address? Your response indicated that you can set each separately. My suggestion: - update all the SMTP servers, such as SMTP-1, SMTP-2, etc. - do a screenprint of the pane that lists the SMTP servers - do a screenshot of two SMTP server setups - let them show full email ids - do screenshot of two account panes that each identify with one of those panes, showing full email id - send to me at davidthunderbird at gmx dot com and I will attempt to help figure this out.

Helpful?

more options

Very literally nothing was changed except for the exact same actual email address. Instead of "XYZ@cox.net" I put ABC@cox.net (so to speak). Wherever it says ABC, that is in place of the same address name.

Those screen caps were for one of the 6 addresses, as the other 5 are the same but with their actual e-mail name.

Helpful?

more options

Okay, I will let this go, but the fact that you can change each description field tells me that your other observations may be wrong. Your screenshots so far aren't convincing. If you later decide to pursue this, you can write to my personal email with the requested screenshots.

Helpful?

more options

I did try to have my accounts as POP accounts, but it refused to work at all, so changing them back to SMTP they worked again.

I think this chat/situation could help someone else if we continue here, or are you over trying to help me here? Let me know and I will e-mail you instead, but if we can, I'd prefer to continue here. This has to be fixable, I am SO CLOSE to getting it to work!

Will try to figure out what you need above as screenshots and will post them after work today.

Is the issue that there is one of the 6 as a "master account"? If so, that needs to be addressed because I did nothing differently if I was supposed to. I'm not sure which of the 2 suspected ones is my master account (the account I started Cox with when I signed up 27 years ago). But I do know for a fact it's one of 2 accounts of the 6.

I honestly don't understand why I have to post my real e-mail addresses. If I have XYZ@cox.net as my real address and then photoshop every place it says XYZ@cox.net to ABC@cox.net that should make sense. Each of the 6 accounts has their own e-mail address in each of the appropriate spots. They were checked, rechecked and obsessively rechecked again. The only one that keeps changing back is the USER NAME under SMTP Server settings. if i can get one e-mail to work, won't it make all of the other ones work once i change whatever it is we figure out with this one account?

Helpful?

more options

Okay. I would like to see - a screenshot showing all SMTP servers with unique description fields, - a screenshot of SMTP details for at least two accounts. I assume one will be for ABC@ and the other a XTZ@ per your request - a screenshot of the account pane for each, showing the link to appropriate SMTP server - a screenshot of error message for one of them, showing that you have the incorrect email account.

VERY IMPORTANT to have two account examples, as that is the only way an observer can confirm the problem if it exists.

The reason I had requested seeing the actual email address is that is explicitly what you defined in opening statement that you could not do. If that is true, then you will be unable to provide what I am requesting. I look forward to your response - and I appreciate your desire to fix this.

Helpful?

more options

Here is a sample of the list of SMTP servers I would like to see. Each has a unique name. For yours, please use SMTP-1, SMTP-2, etc.

Helpful?

more options

Ok, I set up EMAIL 1. All was set up. Went to set up EMAIL2. Went BACK to EMAIL1 to see if anything changed and BOTH the USER NAME and DESCRIPTION changed to EMAIL2. I am at a loss.

How do I proceed if it always changes what I did last? That's what it keeps doing.

I was naming the servers SMTP1, SMTP2, but switched to EMAIL1 and EMAIL2 to try to make it easier?

Let me attach other info, if it helps.

Please don't give up on me just yet. I am ready to just send it un-'shopped, even though it makes zero difference if I substitute the names. I was meticulous and made no mistakes. It just keeps changing whichever last one I set up to the newest one I set up, no matter what order I do them in. So I have to change the User Name each and every time for whatever e-mail acct I want to send something out of. Incoming works fine.

Modified by ceeveekay

Helpful?

more options

Okay, I think were getting closer. Can you do a screenshot like the attached? Just click to 'account settings' m scroll down left side to 'Outgoing Servers (SMTP)' and click. That should display a list of SMTP servers . The lists you have shared so far do not look the same.

Helpful?

more options

I bet this is where the problem is. See note on screenshot, please.

I have no idea what to write as the User Name in this area though, as that will change on its own like the others.

Helpful?

more options

You're in the area. The SMTP servers listed on right side of your screenshot are your six servers. This is where SMTP servers are edited, not anywhere else. Highlight one (other than EMAIL1) and click the edit button and set it to EMAIL2 and the right content and then save it. Then, open EMAIL1 and it should still be whatever it was before. Assuming all is ok, continue and finish editing all of them. THEN, review account pane for each to have each account linking to the right SMTP server.

Question: If you haven't been going here to edit the SMTP servers, please share how you were doing it.

Helpful?

more options

This is how: I am going to try to understand and do what you suggested tomorrow with a fresh brain. I don't know how I am doing it wrongly, and i bet it's the easiest, simplest thing I am just glossing over somehow.

Helpful?

more options

I believe you have been editing the SMTP server from the account settings pane, which prevents you from seeing all the servers The ONLY way to set up the servers to be unique if from the pane in your recent screenshot. That is the importance of description field, as that is how you will be able to verify which SMTP server is associated with each account,

Helpful?

more options

I have this same problem... so i am following this since the move of Cox to Yahoo.(already have a Yahoo acct.) So when I Change the smtp.cox.net addy to "smtp.mail.yahoo.com" in the EDIT SERVER window a)do i change the DESCRIPTION? or does that matter? B)Do i need to change my UName to my WHOLE past(COX) email addY? (rt. now it shows only the Before @cox.net 'name'? C)now that w/in Acct. Settings has been changed to "COX- smtp.mail.yahoo.com(Default)" When I move to the SERVER SETTINGS window and try to change the ServerName from Imap.cox.net to"IMAP.mail.yahoo.com" it says i need to restart TB. but the user name is still W/Out the first addy from "@cox.net" After it restarts TB shows same as it did b4.... same ole cox addys for SMTP and IMAP but WHY? TY

Helpful?

more options

GOT IT, thanks!

Modified by ceeveekay

Helpful?

more options

why are you unable to post a screenshot of your SMTP servers? i told you how to get there - click 'account settings' - scroll down left side to 'Outgoing servers (SMTP' and click - this should now show a list of your SMTP servers. PLEASE do a screenshot of them and post. Do nothing else.

Helpful?

more options

To @bullhorn, I think this is a different issue. Please post a new thread as the solution you need is different. Thanks much.

Helpful?

more options

Ok, NOW I can't send mail at all when I change the info back like I was temporarily doing up until now. I am SO FRUSTRATED. Not everyone is a computer guru. I used to be really good at this stuff, heck I did web pages for people doing HTML BY HAND before programs were available. But life these past years really did a number with chronic stress and my mind now isn't what it used to be. I'm surprised I got this far with this issue at all!

This was the ugliest switchover Cox did with Yahoo. With some effort, they could have made this SO much easier. Instead, they rely on forums like this one and figure "Meh, they'll get upset, but they'll figure it out eventually - it's not like they'll switch companies, tee hee". I feel so badly for the older people and people who are far worse off than I am with these sorts of things!

WHAT AM I MISSING. I can't stand that I am probably missing something so simple.

Modified by ceeveekay

Helpful?

more options

Ok, whew, I switched it back like I used to and it was able to send my mail when I wrote in the USER and DESCRIPTION as the account I wanted to send from.

My TEMP fix so far is this: Where I am doing this from is when I click on one of the e-mails I want to use, I then make sure the USER NAME is matching the account I want to use, as well as the Description just being the actual e-mail itself.

Where it SEEMS the problem is, what do I put the setting on in the LOCAL FOLDERS area at the bottom of all the e-mail accounts? (The "v.s. this" area in pic). THIS local Folders area on the bottom SEEMS to be a universal setting for ALL of the e-mails. So far I've been doing one by one clicking on each accnt as stated before.

Modified by ceeveekay

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.