Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

trouble updating

  • 1 reply
  • 0 have this problem
  • 3 views
  • Last reply by James

more options

Duplicate thread, continue at /questions/1432649

I have trouble downloading the newest version because it says that Firefox has ended support for Windows 8 and Vista.

But I DO NOT USE THESE OLD VERSIONS - I DO USE WINDOWS 10 on this computer.

Could you please let me know how to fix this in plain english so I can easily do it myself - I am no computer wizzard.

Your help would be greatly appreciated. Please write your answer to my email account: [removed email from public] ,

Thank you, Chris

Duplicate thread, continue at [/questions/1432649] I have trouble downloading the newest version because it says that Firefox has ended support for Windows 8 and Vista. But I DO NOT USE THESE OLD VERSIONS - I DO USE WINDOWS 10 on this computer. Could you please let me know how to fix this in plain english so I can easily do it myself - I am no computer wizzard. Your help would be greatly appreciated. Please write your answer to my email account: [removed email from public] , Thank you, Chris

Modified by James

All Replies (1)

more options

Your useragent used to post this thread is Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0

The NT 6.0 is Windows Vista and Windows server 2008. The latest version to still support WindowsXP/Vista was 52.9.0esr.

The common reason for this is the Firefox user is running Firefox in Windows Compatibility mode for some reason. https://support.microsoft.com/en-us/windows/make-older-apps-or-programs-compatible-with-windows-783d6dd7-b439-bdb0-0490-54eea0f45938#ID0EBH=Windows_10


Another possible reason in this case is due to manually changing the useragent. https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Also this is a support forum as nobody here does one on one support by phone chat or email so please return to this thread at https://support.mozilla.org/en-US/questions/1432664 ..edit: turns out you made a bit earlier thread at /questions/1432649

Modified by James