Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

URL autocomplete defaults to site I haven't used in years

  • 2 replies
  • 0 have this problem
  • 17 views
  • Last reply by cor-el

more options

I'm a student, which means I'm constantly accessing my university's library page. I've run into a weird URL autocomplete issue that I can't seem to resolve.

Beginning to type "library" in the URL bar leads to Firefox autocompleting with a past college's library site that I haven't used in years. It's not in my bookmarks, I've deleted all its site data in Firefox's history, I've tried the "shift + delete" trick, but nothing's making this autocomplete go away. It doesn't seem like Firefox Suggest, but something else.

All I want is for my school's library to show up as the autocomplete. It's so annoying to navigate away from a website I haven't used in years every time.

Any suggestions on how to resolve this?

I'm a student, which means I'm constantly accessing my university's library page. I've run into a weird URL autocomplete issue that I can't seem to resolve. Beginning to type "library" in the URL bar leads to Firefox autocompleting with a past college's library site that I haven't used in years. It's not in my bookmarks, I've deleted all its site data in Firefox's history, I've tried the "shift + delete" trick, but nothing's making this autocomplete go away. It doesn't seem like Firefox Suggest, but something else. All I want is for my school's library to show up as the autocomplete. It's so annoying to navigate away from a website I haven't used in years every time. Any suggestions on how to resolve this?

Modified by Anna

All Replies (2)

more options

Double-check the unwanted site is not in bookmarks or history, then go to about:support in the address bar, scroll down to the "Places Database" heading, click the "Verify Integrity" button, wait for the result and then restart the browser.

Bookmark the site you want to autofill and visit it several times by typing in the address bar to give it a boost.

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose, make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website, data for that website will be saved once again.