Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot load website for local oil company

  • 1 reply
  • 0 have this problem
  • 11 views
  • Last reply by zeroknight

more options

I seem to not be able to access the website for my local oil company https://fegleyoil.com/ even though I have been able to do so multiple times over the past few years. I have checked every Firefox setting but am still unable to load their site to order oil. I have successfully been able to load their site not only on my smartphone but also on my work PC. I need to know how to fix this. Please advise and many thanks in advance for any assistance. BTW, it also doesn't load on my home PC in Firefox, Edge or Chrome but again loads just fine on my phone and work PC and my home PC VPN is turned off when I try to access this site and I have it added to my Firefox exceptions to be allowed.

I seem to not be able to access the website for my local oil company https://fegleyoil.com/ even though I have been able to do so multiple times over the past few years. I have checked every Firefox setting but am still unable to load their site to order oil. I have successfully been able to load their site not only on my smartphone but also on my work PC. I need to know how to fix this. Please advise and many thanks in advance for any assistance. BTW, it also doesn't load on my home PC in Firefox, Edge or Chrome but again loads just fine on my phone and work PC and my home PC VPN is turned off when I try to access this site and I have it added to my Firefox exceptions to be allowed.

All Replies (1)

more options

The insecure "http://" site works for me, make sure you aren't using "https://". If it tries to upgrade to https, click the padlock icon in the address bar and change "Automatically upgrade this site to a secure connection" to "Off".