Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

~10 second delay response when searching

  • 3 replies
  • 1 has this problem
  • 142 views
  • Last reply by Victor118

more options

On some webpage, I experience delay response when I trying to search sometime. For example, in Google homepage after typing something or even gibberish the page froze and not responding for about 10 second but the browser is still functioning (meaning I can still move other tabs or open option). Once that 10s delay is over, it responded with my result. And something when I when to search back something again(not in the homepage), more of the time is response back fast like 0.2s but other time the same 10s delay. This problem also happens in some other website but not all in their search bar. I have try in safe mode. disable all my extension, reinstall Mozilla Firefox, check any windows update and such. Also other browser does not have this problem such as chrome and brave. If this problem still persisting then I would such to other browser but prefer not to as I quite fond of Firefox. Thanks for your help in advance.

On some webpage, I experience delay response when I trying to search sometime. For example, in Google homepage after typing something or even gibberish the page froze and not responding for about 10 second but the browser is still functioning (meaning I can still move other tabs or open option). Once that 10s delay is over, it responded with my result. And something when I when to search back something again(not in the homepage), more of the time is response back fast like 0.2s but other time the same 10s delay. This problem also happens in some other website but not all in their search bar. I have try in safe mode. disable all my extension, reinstall Mozilla Firefox, check any windows update and such. Also other browser does not have this problem such as chrome and brave. If this problem still persisting then I would such to other browser but prefer not to as I quite fond of Firefox. Thanks for your help in advance.

Chosen solution

Hello, an update on this problem. I have fix the problem. It seem the problem came from Kaspersky.

I found this question here similar to my problem "Input delay in search field on Google-related sites" after trying that solution it fixes the problem.

Thank you Dropa and zeroknight for helping me out. I appreciate it.

Read this answer in context 👍 0

All Replies (3)

more options

Try disabling the accessibility service, go to about:config in the address bar and change accessibility.force_disabled to 1 then restart the browser.

Also go to about:third-party and try disabling third-party modules.

more options

Hello. Yes, I have verify that in Private Mode the problem is still there. I also try disabling the accessibility service and third-party modules but it did not solve it as well.

more options

Chosen Solution

Hello, an update on this problem. I have fix the problem. It seem the problem came from Kaspersky.

I found this question here similar to my problem "Input delay in search field on Google-related sites" after trying that solution it fixes the problem.

Thank you Dropa and zeroknight for helping me out. I appreciate it.