Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox preventing Mac from sleeping

  • 2 replies
  • 4 have this problem
  • 406 views
  • Last reply by Rumboogy

more options

I have noticed in the last few days that Firefox is keeping my Mac from sleeping. This seems to have started around the time of updating Firefox to version 113.0.2 which happened 4 days ago. Any thoughts on how to debug this?

I have noticed in the last few days that Firefox is keeping my Mac from sleeping. This seems to have started around the time of updating Firefox to version 113.0.2 which happened 4 days ago. Any thoughts on how to debug this?

Chosen solution

I solved the problem. I have the default Autoplay permission set "Block Audio and Video". But at some point I gave the Discord tab an override permission to be able to auto play audio and video. That tab was what was keeping Firefox from disallowing my Mac from sleeping. I am not sure how long this has been going on but I became aware of the Mac not sleeping around the time of the last Firefox update which is why I initially thought the two things were correlated.

Read this answer in context 👍 0

All Replies (2)

more options

I think I found the culprit. What seems to be keeping Firefox from preventing sleep is a tab I have open to Discord. I have my Discord tab pinned so it always loads. If I go into about:processes and unload that tab then Firefox stops preventing sleep.

So now that I know it is not the latest version of Firefox, but rather a bad behaving tab, what can I do about it?

more options

Chosen Solution

I solved the problem. I have the default Autoplay permission set "Block Audio and Video". But at some point I gave the Discord tab an override permission to be able to auto play audio and video. That tab was what was keeping Firefox from disallowing my Mac from sleeping. I am not sure how long this has been going on but I became aware of the Mac not sleeping around the time of the last Firefox update which is why I initially thought the two things were correlated.