Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Emails displaying wrong time (2) and Windows Auto Time Zone Updater service is disabled

  • 20 replies
  • 0 have this problem
  • 1 view
  • Last reply by adam154

more options

Hi,

I have the same problem as in this case:

https://support.mozilla.org/en-US/questions/1324441#answer-1397713

Everything is the same, except my timezone and the fact that my privacy.resistFingerprinting is already in "false". So, any idea?

Attached you will find my captures.

Thank you very much

Hi, I have the same problem as in this case: https://support.mozilla.org/en-US/questions/1324441#answer-1397713 Everything is the same, except my timezone and the fact that my privacy.resistFingerprinting is already in "false". So, any idea? Attached you will find my captures. Thank you very much
Attached screenshots

Modified by Wayne Mery

All Replies (20)

more options

So your problem is all your received emails are displaying UTC?

I see you have selected 'Date and Time Formatting as 'regional locale Spanish (Spain) Do you expect email dates to be UTC +2 because you are in mainland Spain ? https://www.timeanddate.com/time/zone/spain

Where are you? What is set up on the computer for Timezone? Does computer show correct time in bottom right of screen?

Exit Thunderbird this is important.

On computer - I'm assuming you are in mainland Spain. In bottom search type 'Control Panel' and choose the 'Control Panel' app. View by: select 'Large icons' Select 'Date & Time' click on 'Change time Zone' select anything - eg: London and then select: (UTC +01:00) Brussels, Copenhagen ,Madrid, Paris select checkbox for auto adjust clock for DST click on OK

click on OK.

Start thunderbird.

more options

Hi Toad-Hall,

Thanks for your response. Regarding your questions:

-Do you expect email dates to be UTC +2 because you are in mainland Spain ?

   Yes, I'm located in Spain and expect to have UTC+2 in the email dates

- What is set up on the computer for Timezone?

  UTC+2

- Does computer show correct time in bottom right of screen?

  Yes

I followed your steps without success.

Any other idea? I tried all the steps as explained in this thread(https://support.mozilla.org/en-US/questions/1324441#answer-1397713), but unfortunately they were not successful.


Best regards

more options

re :- What is set up on the computer for Timezone? Answer: UTC+2

That seems incorrect. Spain using 'Madrid' is UTC +1 not UTC+2, but you would have selected DST option so that the clock on computer is adjusted. Please post an image showing the computer timezone settings and shwoign DST is selected.

select: (UTC +01:00) Brussels, Copenhagen ,Madrid, Paris select checkbox for auto adjust clock for DST click on OK

Please confirm you selected exactly as stated above.

Additional info required. Select an email so you see it in Message Pane. Click on 'More' and select 'View Source' Please post an image of the 'View Source' - you can blank out your email address. I'm wanting to check the times against all the servers. So I need an image showing all the headers, but not the actual email message.

Also, post an image which shows that same email so I can see what Date you actually seeing in the Message List and Message Pane. Again I only need to see message in the list and the headers of Message in Message Pane, so you can omit the actual contents and blank out the email addresses.

This means I can compare the Source with the display.

more options

Hi Toad-Hall,

Sorry for the confusion, I have UTC+1, in attached image (date_time.png) you'll see.

I can see in the file source the correct time, but neither in the Message list nor Message Pane. Attached you'll find both images showing that.

Thanks for your support. Best regards

more options

Agree - Computer clock is correct - source is ok, but Message pane/list is using UTC - deducting 2 hours. Clearly very confused.

In Settings > Calendar image says Timezone 'Europe/ Paris' which is technically using UTC+2, so you would have thought it would not have much impact on results, but let's make sure it's has correct setting.

Please set Timezone to 'Europe/Madrid' Then Exit and restart Thunderbird.

Report on results.

more options

In Settings > General scroll to bottom and click on 'Config Editor' button

Check you have this setting: 'intl.regional_prefs.use_os_locales' = true

Meaning by default: Use Regional Settings locale of operating system.

more options

What Date info are you getting in:

'Tools' > 'Developer Tools' > 'Error console' At the bottom where you see >> chevrons: Type : Date() What date info is displayed below - please post image

more options

Please set Timezone to 'Europe/Madrid' --> DONE, no changes

'intl.regional_prefs.use_os_locales' = true --> Correct, I have true

What date info is displayed below - please post image --> Attached you'll find the image


Thanks!

more options

Thunderbird is definately picking up something wrong from the computer.

There is a known date/timezone issue that can occur in Windows. It occurred after Microsoft chose to create two places where to set the time. Thunderbird gets it's time info from the Operating System and the Date() info says UTC. So it seems the OS has got UTC selected somewhere.


Please exit Thunderbird now - this is important.

The following may seem a bit of a bore but can you please work through the following and actually reselect the options even if everything looks ok. It is an attempt to get all of the computer hidden registry timezone settings saying the same time.

  1. Type: 'Date' in bottom windows search and select 'Date and Time settings'
  2. Set the time automatically - YES
  3. Set the timezone automatically - NO
  4. Timezone: Select something else like Greenland then
  5. select: (UTC +01:00) Brussels, Copenhagen ,Madrid, Paris
  6. Adjust for daylight saving time automatically - ON
  7. Close the Date and Time window.

Now do the old fashioned way: again please select every step as if setting up new. Do not miss out step 3. On computer

  1. 'Control Panel' > 'Date & Time'
  2. click on 'Change time Zone'
  3. please select anything other than what you need eg: Greenland
  4. and then reselect: (UTC +01:00) Brussels, Copenhagen ,Madrid, Paris
  5. select checkbox for auto adjust clock for DST
  6. click on 'Apply'
  7. click on OK

Start thunderbird.

more options

I followed every step thoroughly but unfortunately it doesn't work yet.

more options

In Settings > General Date and time formatting Currently you have selected what you would have thought was the correct option - regional locale Spain.

What happens when you select to use the Application option ?

Please selected the 'Application locale -GB' Then restart Thunderbird.

Does the date now display as minus 1 hour ? Please post an image showing what it now says in list and in Message Pane header.

In error console, please use the Date() as before and post image of result.

more options

Same results.

Attached you'll find the screenshots.

Thanks, Best regards

more options

Are you by any chance using a duel boot system eg: you have a Linux OS as well as Windows OS ?

more options

No, I only have Windows 11. Neither virtual machines installed nor dual OS. Bios has the date/time correct, as Windows.

more options

re : my 'privacy.resistFingerprinting' is already in "false".

I have found a bug which may apply in this case - basically the setting above got stuck on 'true'.

So let's try to force it to reset.

In Settings > General Date and time formatting reselect the regional locale Spain.

click on 'Config Editor' set 'privacy.resistFingerprinting' = 'true' Exit Thunderbird - wait a few moments for background processes to complete and start Thunderbird.

check the dates - but I'm expecting it is still UTC

Then reset 'privacy.resistFingerprinting ' = "false".

Exit Thunderbird - wait a few moments for background processes to complete and start Thunderbird.

Did it force the date to locate spain time?

more options

I did exactly what you said but unfortunately it still doesn't work.

more options

Hi Toad,

I still have the problem. Do you think this disabled service (attached screenshot) can affect to Thunderbird?

Thanks

more options

adam154 said

Hi Toad, I still have the problem. Do you think this disabled service (attached screenshot) can affect to Thunderbird? Thanks

Why is your Windows Auto Time Zone Updater disabled?

I wonder if testing Windows started in safe mode would have revealed this?

more options

Hi,

I don't know why is disabled but I think it doesn't matter. I activated the service, I did a reboot but still working unproperly. Furthermore, another coleague has the service deactivated but he hasn't got the problem with the time in Thunderbird.

So, in summary, I think this doesn't affect on my issue.

more options

Hi,

Maybe someon can help me. Now the problem is even worse, goggle calendar I have syncronized inside thunderbir is also showing the time wrong. The same 2 hours difference. Do you think the best option is uninstall and reinstall thunderbird? I did it, but it didn't work, what must delete (windows register, appdata, programdata...) in order to delete absolutely all?

The problem is very annoying.

Thank you, Best regards