Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Emails displaying wrong time

more options

Ive been searching all over for a solution to this today and can find nothing new on this since the early 2000s. The emails displayed in Thunderbird are all displaying UTC and until today, it had the correct time (Central).

I have verified the following:

1) My system time and timezone Windows 10 settings are correct 2) The Thunderbird options calendar timezone is correct 3) My email can also be read on a web interface that those times are in the correct zone

From those 3, I believe I narrowed the problem down to the client.

An old issue I have found involves the environment variable %TZ%. There are 2 tests suggested that point to this being the case:

1) Running "Date()" in the Thunderbird error console does indicate my timezone being used is UMT.

2) Running 'Components.classes["@mozilla.org/process/environment;1"].getService(Components.interfaces.nsIEnvironment).exists("TZ")' in the error console returns true, which the poster of that test (in 2004) says should return false if things are set properly. That poster does not explain how to change the variable.

Only way I have found to change TZ is by editing autoexec.bat, which no longer exists in Windows 10. I cannot find a setting for it anywhere in the registry. The variable is clearly set somewhere, but how do I change it????

Thank you.

Chosen solution

Please check something for me and then post info/results.

Menu app icon > Options > General Scroll down to the bottom and click on 'Config Editor' button It will say beware :) In search type: resist Look for this line: privacy.resistFingerprinting Is this set to 'True' ? If yes, please double click on that line to toggle the value to 'False' Then close 'about:config' - top right X

Restart Thunderbird.

Read this answer in context 👍 1

All Replies (7)

more options

Windows 10 has the method of adjusting date time etc. Typically you would type in search 'Date' and select 'Date & Time Settings'. Those setting I'm presuming are correct as computer is showing correct time.

The old method of setting date time settings used prior to Windows 10 is still accessible. I would like you to use the old method of setting the 'Time zone' etc via the 'Control Panel' - see instructions below.

Exit Thunderbird this is important.

On computer In bottom search type 'Control Panel' and choose the 'Control Panel' app. View by: select 'Large icons' Select 'Date & Time' click on 'Change time Zone' select anything - eg: London and then reselect: (UTC-06:00) Central Time (US and Canada) select checkbox for auto adjust clock for DST click on OK

click on OK.

Start thunderbird.

Helpful?

more options

No change. Still displaying UTC in Thunderbird.

Helpful?

more options

Just so we know all is as it should be within Thunderbird itself. Please post some settings: Menu app icon > Options > General Under 'Language & Appearance' section sub section 'Date and Time Formatting' What do you have selected? Post image showing setting.

Menu app icon > Options > Calendar What timezone is selected?

Helpful?

more options

Attached here. Also, during my debugging I tried both settings under the "Date and Time Formatting" section.

Modified by groovechild2

Helpful?

more options

This is the one that has me stumped. I ran Date() immediately after posting those settings to you, but somewhere, something is telling the client to use UTC...

I was about to give up and switch to use Outlook 2019 when I checked if you had responded this morning. I appreciate the time you're taking to help.

Helpful?

more options

Chosen Solution

Please check something for me and then post info/results.

Menu app icon > Options > General Scroll down to the bottom and click on 'Config Editor' button It will say beware :) In search type: resist Look for this line: privacy.resistFingerprinting Is this set to 'True' ? If yes, please double click on that line to toggle the value to 'False' Then close 'about:config' - top right X

Restart Thunderbird.

Helpful?

more options

Yes! I got excited when I saw it was set to true and when I restarted, it worked.

So from a quick look am I correct in assuming that one of my privacy addons in firefox forces UTC to avoid helping to geolocate me and the setting also affects thunderbird?

Thanks again!

Modified by groovechild2

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.