Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't save files in Firefox

  • 8 replies
  • 4 have this problem
  • 2665 views
  • Last reply by zeroknight

more options

Firefox worked perfectly, but since a few days I can't download anything. I'm using Mozilla Firefox snap for Ubuntu 22.04, version 110.0.1 (64 bits) canonical-002 - 1.0 With Chrome everything works perfectly so I assume it's a problem from Firefox.

When I open a PDF, a MP3 or any file, the "save" option doesn't display anything. Usually it opened a dialog where I could choose the folder where I wanted to download the file, but now I have nothing.

I have only 4 extensions: - adblocker ultimate - duckduckgo privacy essentials - vuejs dev tools - zotero connector

I always had them and I never encountered any problem.

Firefox worked perfectly, but since a few days I can't download anything. I'm using Mozilla Firefox snap for Ubuntu 22.04, version 110.0.1 (64 bits) canonical-002 - 1.0 With Chrome everything works perfectly so I assume it's a problem from Firefox. When I open a PDF, a MP3 or any file, the "save" option doesn't display anything. Usually it opened a dialog where I could choose the folder where I wanted to download the file, but now I have nothing. I have only 4 extensions: - adblocker ultimate - duckduckgo privacy essentials - vuejs dev tools - zotero connector I always had them and I never encountered any problem.

Chosen solution

Well, I took the risk and installed a new version without losing anything, not even my session! Here is how I did:

- in Firefox, go to about:profiles and check the 2 folders of your current profile. Save them in another place; - close Firefox and open a terminal to run `sudo snap remove firefox` - create a new file with the command `sudo /etc/apt/preferences.d/mozilla-firefox` - in this file, write this:

Package: * Pin: release o=LP-PPA-mozillateam Pin-Priority: 1001

- run `sudo apt install firefox firefox-locale-fr` ("locale-fr" is if you want Firefox in French, like me); - open Firefox, go to about:preferences and add a new profile; - check the 2 folders which have been created and copy inside the contents of the 2 folders you saved earlier; - relaunch Firefox and voilà!


This solved my problem of not being able to save files. Many thanks to @jonzn4SUSE and @cor-el for pointing out the problem could come from snap.

PS: may I suggest that in Ubuntu the default Firefox installation shouldn't be with snap?

Read this answer in context 👍 0

All Replies (8)

more options
more options

Where are you saving those files as the Snap version has limitations when it comes to read/write access permission ?

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

more options

cor-el said

Where are you saving those files as the Snap version has limitations when it comes to read/write access permission ? You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

I'd like to try that, actually the snap version is the only I've been suggested when I installed Ubuntu and went to the Fireforw website.

Will I lose my bookmarks, extensions and saved password if I migrate like this?

more options

Chosen Solution

Well, I took the risk and installed a new version without losing anything, not even my session! Here is how I did:

- in Firefox, go to about:profiles and check the 2 folders of your current profile. Save them in another place; - close Firefox and open a terminal to run `sudo snap remove firefox` - create a new file with the command `sudo /etc/apt/preferences.d/mozilla-firefox` - in this file, write this:

Package: * Pin: release o=LP-PPA-mozillateam Pin-Priority: 1001

- run `sudo apt install firefox firefox-locale-fr` ("locale-fr" is if you want Firefox in French, like me); - open Firefox, go to about:preferences and add a new profile; - check the 2 folders which have been created and copy inside the contents of the 2 folders you saved earlier; - relaunch Firefox and voilà!


This solved my problem of not being able to save files. Many thanks to @jonzn4SUSE and @cor-el for pointing out the problem could come from snap.

PS: may I suggest that in Ubuntu the default Firefox installation shouldn't be with snap?

Modified by DJ Caësar 9114

more options

You are probably missing packages libcanberra-gtk-module, xdg-desktop-portal xdg-desktop-portal-gtk. Try executing `sudo apt-get install libcanberra-gtk-module xdg-desktop-portal xdg-desktop-portal-gtk` in terminal and retry.

more options

You should try to get the snap package to work, the inconveniences of snap/flatpak are greatly outweighed by the security benefits of sandboxing the browser.

more options

zeroknight a écrit

You should try to get the snap package to work, the inconveniences of snap/flatpak are greatly outweighed by the security benefits of sandboxing the browser.

Thanks for your answer. Actually this snap mechanism is a real inconvenience. Now I don't work with Firefox anymore, and I regret it, because it needs too many manual operations. For every other app everything goes smoothly with a `apt upgrade`, I expect for my main browser to have the same behavior, I don't want to make an exception to my work process. Maybe it's a developer thing, to "factorize" my tasks ;)

more options

DJ Caësar 9114 said

Actually this snap mechanism is a real inconvenience.

Getting hacked is a bigger inconvenience, especially if you are developer with important credentials.