Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox linked my work gmail and my personal one, now my personal one is under an administator

more options

As the subject says, I logged into my work gmail on my personal laptop, and since then my personal gmail (as well as every other gmail I used on this laptop BEFORE logging into my work one) is now under this Administrator, on all devices. I've contacted the IT department and they said they only had my work gmail under their system. More digging around and I found it to be a cookies issue, as Google Chrome (even after logging in and out of all my gmails personal and work) was absolutely fine and so was Microsoft edge.

No matter how many times I fresh install, clear cookies, or change settings in Firefox, my personal gmail is still locked under restricted mode. Linked below is proof that Google doesn't recognize my account under restriced mode, yet Youtube still says I'm being managed.

I would like my google accounts back, and if I have to wipe all my Firefox data and abandon it, I will. I just don't want to use another browser

As the subject says, I logged into my work gmail on my personal laptop, and since then my personal gmail (as well as every other gmail I used on this laptop BEFORE logging into my work one) is now under this Administrator, on all devices. I've contacted the IT department and they said they only had my work gmail under their system. More digging around and I found it to be a cookies issue, as Google Chrome (even after logging in and out of all my gmails personal and work) was absolutely fine and so was Microsoft edge. No matter how many times I fresh install, clear cookies, or change settings in Firefox, my personal gmail is still locked under restricted mode. Linked below is proof that Google doesn't recognize my account under restriced mode, yet Youtube still says I'm being managed. I would like my google accounts back, and if I have to wipe all my Firefox data and abandon it, I will. I just don't want to use another browser
Attached screenshots

All Replies (7)

more options

Firefox has no control over google accounts that is between google and the user to resolve google account support issue. You need to use Firefox in Private Mode browser to verify this isn't a Addon issue causing this and make sure to clear the cache/history to verify nothing is still running when closing and opening the Browser.

Helpful?

more options

Could you flush your cookies for google.com and youtube.com and sign in from scratch and see whether that helps resolve the confusion. Here's how:

While viewing a page on each site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data..." button should appear at the bottom. Go ahead and click that. Firefox will ask you to confirm; go ahead and confirm.

Then try reloading the page and you should be logged out. Any luck on the next try?

Helpful?

more options

jscher2000 - Support Volunteer said

Could you flush your cookies for google.com and youtube.com and sign in from scratch and see whether that helps resolve the confusion. Here's how: While viewing a page on each site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data..." button should appear at the bottom. Go ahead and click that. Firefox will ask you to confirm; go ahead and confirm. Then try reloading the page and you should be logged out. Any luck on the next try?

Thank you, I can't believe I missed it, but youtube.com had some cross tracking cookies enabled to my other google accounts, as well as google.com being connected to youtube.com. Disabling both and reloading the browser put my account back to normal.

Helpful?

more options

Dropa said

Firefox has no control over google accounts that is between google and the user to resolve google account support issue. You need to use Firefox in Private Mode browser to verify this isn't a Addon issue causing this and make sure to clear the cache/history to verify nothing is still running when closing and opening the Browser.

I don't have add-ons to either Google Chrome or Firefox. Clearing my cookies and caches, even fresh uninstalling and installing didn't work. But thank you, another commenter found the solution

Helpful?

more options

jscher2000 - Support Volunteer said

Could you flush your cookies for google.com and youtube.com and sign in from scratch and see whether that helps resolve the confusion. Here's how: While viewing a page on each site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data..." button should appear at the bottom. Go ahead and click that. Firefox will ask you to confirm; go ahead and confirm. Then try reloading the page and you should be logged out. Any luck on the next try?

So actually this solution was temporary. It seems my accounts have relocked as the cross-site cookies have been re-enabled. They keep re-enabling themselves, and sometimes the lined bars icon that opens the option to turn them back off don't appear and I cant' disable them. Do you know how to permanently disable cross site cookie connections?

Helpful?

more options

Dropa said

You need to use Firefox in Private Mode browser to verify this isn't a Addon issue causing this...

I believe that private windows don't automatically disable add-ons. It depends on whether or not the add-ons have been granted permission to run in them.

I am just making the point that a private window does not, for all users, guarantee that no add-ons are running.

Isn't "Troubleshoot Mode" in the Help menu the mode that will always disable all add-ons for any user?

Modified by TechHorse

Helpful?

more options

newlak778 said

jscher2000 - Support Volunteer said

Could you flush your cookies for google.com and youtube.com and sign in from scratch and see whether that helps resolve the confusion. Here's how: While viewing a page on each site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data..." button should appear at the bottom. Go ahead and click that. Firefox will ask you to confirm; go ahead and confirm. Then try reloading the page and you should be logged out. Any luck on the next try?

So actually this solution was temporary. It seems my accounts have relocked as the cross-site cookies have been re-enabled. They keep re-enabling themselves, and sometimes the lined bars icon that opens the option to turn them back off don't appear and I cant' disable them. Do you know how to permanently disable cross site cookie connections?

I don't know whether you can isolate YouTube from Google; they have various interconnections.

Since you need to access both personal and work accounts in Firefox, you could try the Container Tabs feature to create a group of isolated tabs for work Google+YouTube vs. personal Google+YouTube (one group will be among your regular tabs and the other will be in container tabs.

More info: Multi-Account Containers

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.