Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I maximize Firefox, the window gets larger than my screen's resolution

  • 15 replies
  • 1 has this problem
  • 36 views
  • Last reply by nochkin

more options

When I run Firefox on Linux, the window initially starts at 1260x720 size. But when I try to maximize it, then the Firefox window size gets much larger than my screen's resolution. The maximized size is 2800x1600 size, my monitor is 1920x1200 only.

I tried different versions of Firefox and noticed this new behavior started with version 73.0, while it worked fine in 72.0.2 and versions before it. I even tried 73.0b1 and it has the issue already. I see the same exact issue when I tried the latest version 108.0.2 as well. It seems like something got broken in 73.0 unless I'm doing something really wrong.

Not sure if it makes the difference, I'm using MWM window manager on Linux. Please advise.

When I run Firefox on Linux, the window initially starts at 1260x720 size. But when I try to maximize it, then the Firefox window size gets much larger than my screen's resolution. The maximized size is 2800x1600 size, my monitor is 1920x1200 only. I tried different versions of Firefox and noticed this new behavior started with version 73.0, while it worked fine in 72.0.2 and versions before it. I even tried 73.0b1 and it has the issue already. I see the same exact issue when I tried the latest version 108.0.2 as well. It seems like something got broken in 73.0 unless I'm doing something really wrong. Not sure if it makes the difference, I'm using MWM window manager on Linux. Please advise.

All Replies (15)

more options

Hi

I do not know that window manager (I use Xfce), but is there a context menu item for open apps in the toolbar that allows you to "unmaximise" an open app?

more options

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Paul said

Hi I do not know that window manager (I use Xfce), but is there a context menu item for open apps in the toolbar that allows you to "unmaximise" an open app?

Yes, there is such button, it's located on the toolbar on the right side. But I have to drag the whole window to the left side to get that button. I can also press Alt+F5 to bring the size to the original one, but I'd like the maximize to work as it worked before Firefox 73 and as anyone would expect -- just maximize to the allowed screen. Just trying to figure out if I'm doing something wrong or it's a bug in Firefox.

Modified by nochkin

more options

cor-el said

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

I'm sorry I forgot to mention that I tried it with my profile completely deleted and that did not help.

more options

Dropa said

Did you also check your monitor settings as well to insure they were adjusted correctly and also is the driver the correct driver and set to the right resolution? Coming from Windows that's what I would look at as well.

I'm not sure how that would affect it. Please note that any version before Firefox 73 works as expected, but anything starting with Firefox 73 and forward does not work properly. If I would have incorrect driver, then all versions would not work.

more options

Does Full Screen mode behave the same way or does that give a normal window size ?

I assume that you did try a new profile since you mentioned you did delete the profile?

See "Creating a profile":

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution or a snap/flatpack version to see if it behaves differently.

more options
more options

cor-el said

Does Full Screen mode behave the same way or does that give a normal window size ?

Yes, it does the same thing when in the Full Screen mode. I experience the same exact thing. Any version up to Firefox 72 including work fine, but Firefox 73 and newer extend behind the screen's resolution.

cor-el said

I assume that you did try a new profile since you mentioned you did delete the profile?

Yes, as I responded to you earlier, I tried to delete all my profiles and start from scratch. The same issue. I don't have any 3rd party extensions or any settings. Basically, a brand new installation behaves this way.

more options

cor-el said

See also:

That's an interesting test. Here is what I get using Firefox 73 and higher (unexpected behavior):

This test has no <meta viewport> tag. Iteration 1 screen.width/height = 1400 / 800 documentElement.offset = 2800 / 480 documentElement.client = 2800 / 1526 window.innerWidth/Height = 2800 / 1526 window.devicePixelRatio = 1 window.page = 0 / 0

And this is what I see in Firefox 72.0.2 (the latest "good" version):

This test has no <meta viewport> tag. Iteration 1 screen.width/height = 1400 / 800 documentElement.offset = 1386 / 499 documentElement.client = 1386 / 695 window.innerWidth/Height = 1386 / 695 window.devicePixelRatio = 1 window.page = 0 / 0

Modified by nochkin

more options

cor-el said

See also:

That's an interesting test. Here is what I get using Firefox 73 and higher (unexpected behavior):

This test has no <meta viewport> tag. Iteration 1 screen.width/height = 1400 / 800 documentElement.offset = 2800 / 480 documentElement.client = 2800 / 1526 window.innerWidth/Height = 2800 / 1526 window.devicePixelRatio = 1 window.page = 0 / 0

And this is what I see in Firefox 72.0.2 (the latest "good" version):

This test has no <meta viewport> tag. Iteration 1 screen.width/height = 1400 / 800 documentElement.offset = 1386 / 499 documentElement.client = 1386 / 695 window.innerWidth/Height = 1386 / 695 window.devicePixelRatio = 1 window.page = 0 / 0
more options

I tried a clean install of Debian on another device with a completely different set of hardware and configuration. Including a different monitor/resolution. The issue appears when I use MWM only. When I tried GNOME and Xfce, it works as expected. So it seems like some change was introduced in Firefox 73 which caused an issue when it's running under MWM.

more options

FYI, I would assume there is nothing much can be done on my side to mitigate the issue. So I went ahead and opened a bug report on this: https://bugzilla.mozilla.org/show_bug.cgi?id=1808992

more options

Right-click on the desktop and select Properties > Settings tab. Move the slider to select a screen resolution of at least 1024 by 768 pixels.

Regards, Will

more options

willjoe24421 said

Right-click on the desktop and select Properties > Settings tab. Move the slider to select a screen resolution of at least 1024 by 768 pixels. Regards, Will

That is for Windows when the OP is clearly using Linux.

more options

willjoe24421 said

Right-click on the desktop and select Properties > Settings tab. Move the slider to select a screen resolution of at least 1024 by 768 pixels.

Thanks for the suggestion. As I mentioned before, my monitor is set to 1920x1200. I don't see how setting a lower resolution would help in this case. The browser starts at smaller window size, but gets extended way over my monitor's resolution when maximized.